08-04-2022 02:56 PM - edited 08-04-2022 02:57 PM
Hello,
I have following configuration.
I am trying to configure optimal route reflection on RR. But XR3 does not advertise any route to XRV4. But if I remove 'optimal-route-r root1' under 'neighbor 4.4.4.4' of XR3 then XR3 advertises 1.1.1.1 to XRV4.
neighbor 4.4.4.4
use session-group session1
address-family ipv4 unicast
route-reflector-client
optimal-route-r root1
exit
I am not sure what configuration am I missing on XR3.Below is the complete config of all the routers.
XRV1--(ebgp)--XRV2--(ibgp)--XRV3(RR) --(ibgp)---XRV4
RP/0/0/CPU0:XRV4#show bgp ipv4 unicast
Thu Aug 4 21:53:14.944 UTC
RP/0/0/CPU0:XRV4#
XRV1
------------
int gi0/0/0/0
ip address 100.10.20.1 255.255.255.0
no sh
int lo0
ip address 1.1.1.1 255.255.255.255
exit
route-policy pass
pass
exit
router bgp 1
address-family ipv4 unicast
network 1.1.1.1/32
exit
session-group session1
remote-as 12
exit
af-group af1 address-family ipv4 unicast
route-policy pass in
route-policy pass out
exit
neighbor 100.10.20.2
use session-group session1
address-family ipv4 unicast
use af-group af1
exit
XRV2
------------
int gi0/0/0/0
ip address 100.10.20.2 255.255.255.0
no sh
int gi0/0/0/1
ip address 100.20.30.2 255.255.255.0
no sh
int lo0
ip address 2.2.2.2 255.255.255.255
exit
route-policy pass
pass
exit
router bgp 12
address-family ipv4 unicast
exit
session-group session1
remote-as 1
exit
session-group session2
remote-as 12
update-source lo0
exit
af-group af1 address-family ipv4 unicast
route-policy pass in
route-policy pass out
exit
neighbor 100.10.20.1
use session-group session1
address-family ipv4 unicast
use af-group af1
exit
neighbor 3.3.3.3
use session-group session2
address-family ipv4 unicast
next-hop-self
exit
router ospf 1
area 0
int gi0/0/0/1
int lo0
exit
XRV3
-----------------------------------------
int gi0/0/0/1
ip address 100.20.30.3 255.255.255.0
no sh
int gi0/0/0/0
ip address 100.30.40.3 255.255.255.0
no sh
int lo0
ip address 3.3.3.3 255.255.255.255
exit
router bgp 12
address-family ipv4 unicast
optimal-route- root1 4.4.4.4
exit
address-family link-state link-state
exit
session-group session1
remote-as 12
update-source lo0
exit
neighbor 2.2.2.2
use session-group session1
address-family ipv4 unicast
exit
neighbor 4.4.4.4
use session-group session1
address-family ipv4 unicast
route-reflector-client
optimal-route- root1
exit
router ospf 1
distribute link-state
area 0
int gi0/0/0/0
int gi0/0/0/1
int lo0
exit
XRV4
-----------------------------------------
int gi0/0/0/0
ip address 100.30.40.4 255.255.255.0
no sh
int lo0
ip address 4.4.4.4 255.255.255.255
exit
router bgp 12
address-family ipv4 unicast
exit
session-group session1
remote-as 12
update-source lo0
exit
neighbor 3.3.3.3
use session-group session1
address-family ipv4 unicast
use af-group af1
exit
router ospf 1
area 0
int gi0/0/0/0
int lo0
exit
Thanks,
Sachin
Solved! Go to Solution.
08-07-2022 06:32 PM - edited 08-07-2022 06:38 PM
Hi @sachin30720041 ,
As per the document provided by @pman , there is the following restriction if you use ospf as the IGP.
"The MPLS TE configuration on the root router needs to have the minimal configuration for MPLS TE enabled so that OSPF advertises the MPLS TE router ID in an opaque-area LSA (type 10)."
So at a minimum in your scenario, you need to add the following configuration on XRv4, so that it generates the LSA type 10.
mpls traffic-eng
!
router ospf 1
area 0
mpls traffic-eng
Regards,
08-07-2022 01:04 AM - edited 08-07-2022 01:06 AM
Hi,
I am attaching 2 links on the subject, including an example configuration:
https://www.noction.com/blog/bgp-optimal-route-reflection-alternative-to-bgp-add-path
I tried to restore your lab, see the result:
RP/0/0/CPU0:XRV4#show bgp
Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 100.10.20.1 0 0 1 i
RP/0/0/CPU0:XRV3#show orrspf database detail
Sun May 9 19:52:54.239 UTC
ORR policy: root2, IPv4, RIB tableid: 0xe0000027
Configured root: primary: 2.2.2.2, secondary: NULL, tertiary: NULL
Actual Root: 2.2.2.2, Root node: 2.2.2.2
Prefix Cost
2.2.2.2 1
3.3.3.3 3
4.4.4.4 5
ORR policy: root4, IPv4, RIB tableid: 0xe0000026
Configured root: primary: 4.4.4.4, secondary: NULL, tertiary: NULL
Actual Root: 4.4.4.4, Root node: 4.4.4.4
Prefix Cost
2.2.2.2 5
3.3.3.3 3
4.4.4.4 1
Number of mapping entries: 8
XRV2
---------
interface Loopback0
ipv4 address 2.2.2.2 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 100.10.20.2 255.255.255.0
!
interface GigabitEthernet0/0/0/1
ipv4 address 100.20.30.2 255.255.255.0
!
interface GigabitEthernet0/0/0/2
shutdown
!
route-policy pass
pass
end-policy
!
router ospf 1
area 0
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/1
!
!
!
router bgp 12
address-family ipv4 unicast
!
af-group af1 address-family ipv4 unicast
route-policy pass in
route-policy pass out
!
session-group session1
remote-as 1
!
session-group session2
remote-as 12
update-source Loopback0
!
neighbor 3.3.3.3
use session-group session2
address-family ipv4 unicast
next-hop-self
!
!
neighbor 100.10.20.1
use session-group session1
address-family ipv4 unicast
use af-group af1
!
!
!
mpls traffic-eng
interface GigabitEthernet0/0/0/0
!
interface GigabitEthernet0/0/0/1
!
!
XRV3
---------
interface Loopback0
ipv4 address 3.3.3.3 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 100.20.30.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
ipv4 address 100.30.40.3 255.255.255.0
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 1
distribute bgp-ls
address-family ipv4 unicast
area 0
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/0
!
interface GigabitEthernet0/0/0/1
!
!
!
router bgp 12
address-family ipv4 unicast
optimal-route-reflection root2 2.2.2.2
optimal-route-reflection root4 4.4.4.4
!
session-group session1
remote-as 12
update-source Loopback0
!
neighbor 2.2.2.2
use session-group session1
address-family ipv4 unicast
optimal-route-reflection root2
route-reflector-client
!
!
neighbor 4.4.4.4
use session-group session1
address-family ipv4 unicast
optimal-route-reflection root4
route-reflector-client
!
!
!
mpls traffic-eng
interface GigabitEthernet0/0/0/0
!
interface GigabitEthernet0/0/0/1
!
XRV4
---------
interface Loopback0
ipv4 address 4.4.4.4 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 100.30.40.4 255.255.255.0
!
interface GigabitEthernet0/0/0/1
ipv4 address 4.5.4.4 255.255.255.0
!
interface GigabitEthernet0/0/0/2
shutdown
!
!
route-policy pass
pass
end-policy
!
router ospf 1
area 0
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/0
!
!
mpls traffic-eng router-id Loopback0
!
router bgp 12
address-family ipv4 unicast
!
session-group session1
remote-as 12
update-source Loopback0
!
neighbor 3.3.3.3
use session-group session1
address-family ipv4 unicast
!
!
!
mpls traffic-eng
interface GigabitEthernet0/0/0/0
!
!
08-07-2022 06:32 PM - edited 08-07-2022 06:38 PM
Hi @sachin30720041 ,
As per the document provided by @pman , there is the following restriction if you use ospf as the IGP.
"The MPLS TE configuration on the root router needs to have the minimal configuration for MPLS TE enabled so that OSPF advertises the MPLS TE router ID in an opaque-area LSA (type 10)."
So at a minimum in your scenario, you need to add the following configuration on XRv4, so that it generates the LSA type 10.
mpls traffic-eng
!
router ospf 1
area 0
mpls traffic-eng
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide