Showing results for 
Search instead for 
Did you mean: 

PI 1.2 access not anymore possible

VIP Alumni
VIP Alumni

Hi all

We use Prime Infrastructure Yesterday I installed a certificate signed by our internal CA. I installed it and the access worked fine.

Now today I can't anymore access it. Neither Chrome, Firefox nor IE10 can load the site after the login. The login page loads fine though. I tried clearing the caches and everything.

After that I tried it from a second machine and there I could still access the site. But once I switch to the classic (the actual useable design for WIFI) design, the page doesn't anymore load on the second machine too.

Do I run into some bug or something?

Chrome simply seems to hang while loading the page.

Disabling Pepperflash and using normal Flash also doesn't seem to make a difference.

I already rebooted the PI server twice.                

After scanning this with wireshark I get a weird message from PI Server: cpi1_problem1.jpg

20.12 = PI server, 140.23 = my Client.

Any ideas?

5 Replies 5

VIP Alumni
VIP Alumni

Small update.

I was able to access the web interface after using the IP address instead of hostname.

  Now it's working in Firefox Private Browsing window, but still not in Chrome. Veeeery weird this

We had this same issue and was the customer who found this bug initially. Give this workaround a try:

1. SSH to the NCS and enter root mode

2. Backup the file /opt/CSCOlumos/tomcat/webapps/webacs/lib/wcs/loadLayers.js

3. Edit the file /opt/CSCOlumos/tomcat/webapps/webacs/lib/wcs/loadLayers.js and commend out the contents of the file. It should look something like this after you comment out the dojo line:

/* Copyright (c) 2009, 2012 Cisco Systems, Inc. All rights reserved. */

/* dojo.require("wcs.layers.login");dojo.require("");dojo.require("wcs.layers.dashboard"); */

4. Restart NCS

Hope it works for you. Did the trick for us!

Raise a TAC SR, this is bug CSCud03122 where the root account no longer works after upgrading. They have internal process to run to recover account and patch as well.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: