Showing results for 
Search instead for 
Did you mean: 

Read only user cannot login on C2960X webinterface

Gabriel Grabner

Hi there,

I have an issue with my Catalyst 2960X Switches. I have activated ip http secure-server and can login to the web interface with my privilege level 15 admin user. Then I created a read-only user with privilege level 1. With this read user i can access the switch via ssh but not with the web interface! I also tried other privilege levels e.g. 14 or less but this also doesn't work! When trying to login with the read user, the password prompt keeps showing up after sending the credentials.

When i try to configure an user through the web interface, i get the error "Configuration failed to appy - invalid input detected".

I tried with different usernames and passwords (e.g. "readuser" & "readuserpass" or "re@duserpass1" or "r4aduser")


It is a WS-C2960X-48LPD-L Switch with software version 15.2(7)E4 


Any help would be very appreciated.


4 Replies 4

VIP Mentor VIP Mentor
VIP Mentor


 - Check if this thread can help :



Unfortunately this thread is not able to help me. The flash:dc_profile_dir/day0.cfg file from this thread does not exist on my switch. In this specified directory i can find only this file: dc_default_profiles.txt




      - I tend to believe that normally you can only use the web-interface with a level  15 admin user.


Is this a thing on 2960X switches? Because on my C9200 & 9500 switches, I can access the webinterface with an read-only user without any troubles.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers