cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
832
Views
0
Helpful
23
Replies
kick534
Beginner

SG 350 configuration guidance

Hi team,

we purchase sg350 52P Switch , we will connect it to internet modem ( from modem DHCP is enabled so without any configuration we will get internet) range such as 192.168.1.1 to 192.168.1.254.

 

but i want to create vlans such as ( users, cameras, voice, cctv) and configure inter vlan routing so each vlan can communicate each other,

user network : 172.168.25.0/24

cameras : 172.168.26.0/24

voice : 172.168.27.0/24

cctv: 172.168.28.0/24

Please advice  how to configure the switch port which is connect to internet modem.

or i need routing to configure ????

 

 

23 REPLIES 23

Please advise ISR4221/k9 it will solve my issues

intervlan routing and Layer3/routing/NAT features.

 

 

@ Tyson Joachims

Question-1 :

i want to configure Voice and Data on a single port.

for example my data vlan -10 and voice vlan -11

.i configured the below configuration in switch sg-350 but when i make show run it show only (config-if-range)#switchport trunk allowed vlan add 10 and data vlan ip not taken in int gi port config

please provide the correct steps :

(config)#voice vlan id 11

(config)#voice vlan state auto-enabled

(config)#interface gi 1

(config-if-range)#switchport trunk native vlan 11

(config-if-range)#switchport trunk allowed vlan add 10

 

Question 2: if i configured both data vlan and voice in single port and want to use only laptop or PC it will work or i need to connect compulsory to phone.

 

Question 3: i want to remove the below macro configuration ( please provide a command for port factory reset as new)

interface GigabitEthernet6

spanning-tree portfast

switchport access vlan 12

no macro auto smartport

 

Question 4 : Same here i want to remove the all the configuration ( factory reset port as new)

 

interface GigabitEthernet17

spanning-tree link-type point-to-point

switchport mode trunk

macro description switch

!next command is internal.

macro auto smartport dynamic_type switch

 

 

Thank you for your support

1. Depending on the phones that you use will determine if the bellow configuration will work but I typically use the following commands for the switch interfaces:

interface range GigabitEthernet1-24
 switchport mode access
 switchport access vlan 10
 switchport voice vlan 11
 spanning-tree portfast

2. Yet again this is dependent on the phone. If it is a Cisco phone then the phone will know that the voice VLAN is 11 via CDP from the switch and then any computer plugged into the phone will get VLAN 10.

3. On an SG350, I believe the commands you will need to remove the configuration that you showed will be:

interface GigabitEthernet6
 no spanning-tree portfast
 switchport access vlan 1
 macro auto smartport

I'm still not a fan of the macros so I'd leave it as "no macro auto smartport" but that's up to you.

4. I believe the commands to return the following port to defaults would be

interface GigabitEthernet17
 switchport mode access
 switchport access vlan 1
 no spanning-tre link-type point-to-point
 macro auto smartport

Thank you for your support ( Just to confirm before going to customer site )

below commands will support in SG350 series Switch

 

interface range GigabitEthernet1-24
 switchport mode access
 switchport access vlan 10
 switchport voice vlan 11
 spanning-tree portfast

 

 

That is correct. I'd also add the command "no macro auto smartport" as well. The smartport seems to me to be more trouble than it's worth and tends to make changes that I don't want it to make. You may prefer to use them so I'm just offering my opinion.

@Tyson Joachims 

 

i try to configure the Voice Vlan in SG-350 series switch below error :

 

Mfa-Sw2(config-if)#sw
Mfa-Sw2(config-if)#switchport voi
Mfa-Sw2(config-if)#switchport voice vlan 11

% Wrong number of parameters or invalid range, size or characters entered

Mfa-Sw2(config-if)#

 

Please provide me the correct command for CLI.

So it appears as though I gave you some bad advice. I did some searching and found this article:https://community.cisco.com/t5/small-business-switches/sg350-28p-voice-and-data-vlan-config-on-a-single-port/td-p/4008018

it appears that to add a Voice VLAN, you will actually want the following commands:

(config)#voice vlan id 100
(config)#voice vlan state auto-enabled
(config)#interface fa1   <--change the interface or range depends on the requirement
(config-if-range)#switchport trunk native vlan 101
(config-if-range)#switchport trunk allowed vlan add 100

Sorry about that.

@Tyson Joachims 

Thank you for your support,

Can you please confirm the below configuration is correct, Suppose My Data vlan is 10 and Voice vlan is 11

 

(config)#voice vlan id 11
(config)#voice vlan state auto-enabled
(config)#interface Gi 1
(config-if-range)#switchport trunk native vlan 10
(config-if-range)#switchport trunk allowed vlan add 11

 here Native vlan will be Data Vlan ???

correct

Content for Community-Ad