cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
176
Views
2
Helpful
4
Replies

WLC and APs problem

Erti14
Level 1
Level 1

I've been trying to implement the following topology with real devices. The topology is as follows: 

Erti14_0-1732307633712.png

 

My devices are:
WLC (5520 Series)
Access Points (2600 Series) - Lightweight

The configurations made on the switch are as follows:

vlan 60
name Management
vlan 50
name Neurologie
vlan 70
name Laboratorien

interface vlan 60
ip address 192.168.0.69 255.255.255.192
no shutdown
interface vlan 50
ip address 192.168.0.5 255.255.255.192
no shutdown
interface vlan 70
ip address 192.168.0.133 255.255.255.192
no shutdown

int fa0/1
switchport mode trunk

//DHCP
ip dhcp excluded-address 192.168.0.65 192.168.0.69
ip dhcp pool Management
network 192.168.0.64 255.255.255.192
default-router 192.168.0.69
dns-server 8.8.8.8

ip dhcp excluded-address 192.168.0.1 192.168.0.5
ip dhcp pool Neurologie
network 192.168.0.0 255.255.255.192
default-router 192.168.0.5
dns-server 8.8.8.8

ip dhcp excluded-address 192.168.0.129 192.168.0.133
ip dhcp pool Laboratorien
network 192.168.0.128 255.255.255.192
default-router 192.168.0.133
dns-server 8.8.8.8

int fa0/2
switchport mode access
switchport access vlan 50

int fa0/3
switchport mode access
switchport access vlan 70

If I connect a laptop to the switch the laptop becomes the correct network parameters. But if I connect an access point it does not work.

Another problem I have is that i have changet the management interface ip address to one in the management vlan, but still the ping does not succeed from the switch to the wlc.

Regarding the WLC and the Access Points they have had previous owners and the access points show the following logs. I have tried to factory reset them but they yet have the same logs.

 

Erti14_2-1732307684138.jpeg

 

4 Replies 4

@Erti14 

Either you connect the AP on the same Vlan as the WLC, which seems to be vlan 60 or you need to add the following to your DHCP scope. You need to inform to the AP which is the WLC IP address.

 

ip dhcp excluded-address 192.168.0.1 192.168.0.5
ip dhcp pool Neurologie
network 192.168.0.0 255.255.255.192
default-router 192.168.0.5
dns-server 8.8.8.8

option 43 hex <hexadecimal string>

 

ip dhcp excluded-address 192.168.0.129 192.168.0.133
ip dhcp pool Laboratorien
network 192.168.0.128 255.255.255.192
default-router 192.168.0.133
dns-server 8.8.8.8

option 43 hex <hexadecimal string>

Take the WLC management IP address and convert the IP address to a string by using some online service

https://www.browserling.com/tools/ip-to-hex

 

Thank you for your response. Do you think that this would also solve the fact that I can't ping from my Switch to the WLC?

 

No. I believe this is related to trunk config. If you enable trunk on the switch, you need enable LAG on the WLC.

Or leave it as access on the switch side

Just to note for Cisco option 43 for the AP needs to start with F1XX where XX is how many sets of hex is coming basuically 04 if 1 controller and 08 if 2.

So, lets just say your WLC IP is 10.10.10.10

So the option 43 hex code would be F1040A0A0A0A

 

 

https://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-00.html

 

Review Cisco Networking for a $25 gift card