We have found out that we can "POAP" downstream switch on a non-LACP port-channel. Here is the configuration on the uplink switch:
interface port-channel101
no switchport mtu 9216
no lacp suspend-individual
ip address 10.10.100.100/31
ip router isis underlay
ip pim sparse-mode
ip dhcp relay address 10.10.128.48
interface Ethernet1/47
no switchport
mtu 9216
channel-group 101
no shutdown
show port-channel summary
101 Po101(RU) Eth NONE Eth1/47(P)
As soon as the downstream port links up, the IP interface on the upstream at 10.10.100.100 comes back,
ping 10.10.100.100 PING 10.10.100.100 (10.10.100.100):
...
64 bytes from 10.10.100.100: icmp_seq=0 ttl=255 time=0.925 ms
64 bytes from 10.10.100.100: icmp_seq=1 ttl=255 time=0.806 ms
If I reload the downstream switch at IP 10.10.100.101, POAP for the downstream switch works fine.
However, we would like to leverage the LACP protocol on the port channel (when we add more interfaces later on), it seems that we can never make downstream POAP work, is it possible? Here is the configuration for upstream interface:
interface port-channel101
no switchport mtu 9216
no lacp suspend-individual
ip address 10.10.100.100/31
ip router isis underlay
ip pim sparse-mode
ip dhcp relay address 10.10.128.48
interface Ethernet1/47
no switchport mtu 9216
channel-group 101 mode active
no shutdown
Eth1/47 -- eth routed up none 10G(D) --
101 Po101(RD) Eth LACP Eth1/47(I)
ping 10.10.100.100 PING 10.10.100.100 (10.10.100.100):
56 data bytes Request 0 timed out
Within this configuration, we can never get downstream DHCP going, since the upstream IP is not up.
Is it possible to make it work at all while the upstream port-channel stays in L3 mode? Thank you!