cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
145
Views
5
Helpful
2
Replies
Highlighted
Beginner

load-native-config results in "not implemented" error

I am trying out the new load-native-config command under NSO 5.1.1. When I try it, I get errors like this:

admin@ncs(config)# devices device ios0 load-native-config data "hostname asd"
Error: External error in the NED implementation for device ios0: not implemented

admin@ncs(config)# devices device dell0 load-native-config file test.ftos mode replace verbose
Error: External error in the NED implementation for device dell0: not implemented

ios0 and dell0 are both netsims. ios0 was created with the sample cisco-ios-cli-3.8 NED that came with NSO 5.1.1. dell0 was created with the new Dell FTOS NED.

What am I doing wrong?

Thanks,

-Allen

 

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: load-native-config results in "not implemented" error

Hello the NED that comes as example are quite old - if you look at the CHANGES.txt for cisco-ios-cli-3.8

 

  1 cisco-ios v3.8.0 [March 16, 2015]
  2 =================================
  3
  4 Enhancements:
  5
  6   - Support for NCS-3.4.

The support for cisco-ios NED for load-native config was added later:

 

  393 cisco-ios v6.20.3 [2019-04-05]
  394 ==============================
  402
  403   - Added support for NSO 5.1 config CLI command 'load-native-config' which
  404      can be used to load and convert device config into ncs_cli config mode:
  405      admin@ncs(config)# devices device <device> load-native-config data|file
  406     Note: Even with netsim the data is parsed as it was in native IOS format.
  407     (CISCOIOS-1360)

I assume it is the same explanation for the Dell NED.

 

 

2 REPLIES 2
Cisco Employee

Re: load-native-config results in "not implemented" error

Hello the NED that comes as example are quite old - if you look at the CHANGES.txt for cisco-ios-cli-3.8

 

  1 cisco-ios v3.8.0 [March 16, 2015]
  2 =================================
  3
  4 Enhancements:
  5
  6   - Support for NCS-3.4.

The support for cisco-ios NED for load-native config was added later:

 

  393 cisco-ios v6.20.3 [2019-04-05]
  394 ==============================
  402
  403   - Added support for NSO 5.1 config CLI command 'load-native-config' which
  404      can be used to load and convert device config into ncs_cli config mode:
  405      admin@ncs(config)# devices device <device> load-native-config data|file
  406     Note: Even with netsim the data is parsed as it was in native IOS format.
  407     (CISCOIOS-1360)

I assume it is the same explanation for the Dell NED.

 

 

Beginner

Re: load-native-config results in "not implemented" error

Thanks for the reply.  I didn't know that additional work had to be done to add support for load-native-config.  The Dell NED is brand new, but they probably didn't add support for it, either.  I'll open a TAC case to request it.

 

-Allen