Showing results for 
Search instead for 
Did you mean: 

Click to call , annoying security alert


I have installed "click to call" and regarding calls when I use this application everything is fine. BUT ...   every time I want to place calls using click to call, security alert appears on the screen although I have installed CUCM certificate .

How to resolve this annoying thing ???



Re: Click to call , annoying security alert


I have same problem,

Please Help


Re: Click to call , annoying security alert

Also having the same problem.

I've installed the certificates as advised on other posts, also under "Click to Call Preferences" I have tried using both server name and IP address. All this has done is that instead of getting 2 security alerts I am now only getting one.


Re: Click to call , annoying security alert

I had the same issue and did the following to fix it:

1. Uninstall click to call from add/remove programs

2. Open regedit and delete the following: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\Unified Communications\Click To Call

3. Delete all that is under c:\program files\cisco systems\click to call (delete the entire folder)

4. Reboot the pc

5. Edit the regedit key I'm posting, change the following:


to be the HOSTNAME of the server (not the ip), it must be the name that the certificate is showing when you try to install it.  Only modifiy that, do not remove the extra spaces in the file.  Import the key under HKEY_CURRENT_USER\Software\Policies

6. Install click to call and give it a try


Re: Click to call , annoying security alert

Thanks for the reply but still getting the same problem unfortunately. I have not tried it on a fresh build yet so will give that a go next.

Just FYI I only started getting this problem with the latest version of click to call and Office 2010. On Office 2007 and version 7.x of click to call I didn't have any issues.


Click to call , annoying security alert

Hi All,

I'm also facing this issue with C2C widget

My steps to get this work:

At first I also had this security alert popping up twice, then:
- installed callmanager certification on the client PC

after this, I have the alert message only once.

then I've also modified (just to be sure if this not the cause of the issue)
- 'hosts' file including the IP address and the name of the CUCM, but the issue is the same, getting the error but still once. (but now I can put the CUCM name instead of the IP address into the C2C application)

What step is still missing to get rid of this alert message?

Do I also need to use a trusted certificate for the CUCM pages too?

Thanks for your time and help!

Best regards,

tdo Beginner

Click to call , annoying security alert


I know this thread is a little dated, but thanks for the info, that worked for us!  Problem was that C2C would not save the updated webdialer info.  We had mistakenly put in the IP address instead of actual name on cert during the initial setup.

We are using self generated certs if this helps anyone else out there.


Re: Click to call , annoying security alert


Did you get this resolved?




Re: Click to call , annoying security alert

I had this issue, and found that the "certificate issued by" and the website i was trying to go to (the webdialer service) were not exactly the same.

for example.

In the Click to call preferences the webdialer service was set to "ccm01" , which is correct.

the certificate was issued by  which is also correct.

However when comparing the certificate issuer with the webdialer service they don't match.

SO in the preferences set the webdialer to the fully qualified domain name of the server.

Second issue I had was that I could not change it easily.  I found that if Outlook was still running, I could not make the change.

Exit all applications that might be using C2C.

Even if you exit on the tray icon, it will still be running.

I actually changed my setting in the registry before I realized this.

Good Luck

Frequent Contributor

Re: Click to call , annoying security alert


I`m looking to istsall C2C but I can`t work ou which certicate to download from CUCM- Can you let me know


CreatePlease to create content
Ask the Expert- Webex Hybrid Services Solutions