cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
548
Views
1
Helpful
3
Replies

T38 fallback not working

Clifford McGlamry
Spotlight
Spotlight

Customer is running a 4331 router and has T38 up and working both inbound and out.  However, there are a few places they attempt to send a fax to that fail every time.  

 

We pulled a SIP trace on the call, and found that the CUBE is getting a 488 no acceptable media when it passes through the T38 re invite.  We saw the fax server hanging up at this point, and we are unclear why this is not failing back to G711.

 

The vendor for the fax server pulled a wireshark fromt he server, and they see the CUBE sending RTP packets trying to disable echo cancellation immediately following the 488 not acceptable ACK is received.  The fax server doesn't know what to do with this and is terminating the call.  

My question is about what we need to do to make this fallback work.  I've been digging through documentation, and the documentation on this is pretty thin at best.  Is there some additional command or commands required ino order to make this work?  We have the command fax protocol t38 ls-redundancy 0 hs-redundancy 0 pass-through g711ulaw command in place globally. 

CliffordMcGlamry_0-1696450002562.png

 

 

3 Replies 3

b.winter
VIP
VIP

Maybe try the keyword "fallback" in your fax command:
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

You must use fallback as @b.winter  mentioned.

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

 



Response Signature


It actually has the fallback key word in the command on the router.  I simply didn't type it out when I made the original post (my bad).  But I'm still not understanding why the fax server is disconnecting when it receives the ECM Disable from the gateway instead of continuing.