Showing results for 
Search instead for 
Did you mean: 

877 router reset itself, no ADSL connection after restoring config



There was no Internet connection this morning and I looked at the router - the CD light was blinking fast.

Router did not respond to SSH connection and I plugged in the console cable.

sh run had factory default configuration. So I've restored the last running config, but still would not have Internet.

CD light continues to flash frequently and this is what router reports:

#sh dsl int atm0
Alcatel 20190 chipset information

Line has not yet been activated.

Modem Status:    Down (DMTDSL_DO_OPEN)
DSL Mode:        Unknown
Interrupts:      8238 (0 spurious)
PHY Access Err:  0
Activations:     0
LED Status:      OFF
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-4.0.015.bin
Operation FW:    AMR-4.0.015.bin
FW Source:       external

DSL: Training log buffer capability is not enabled

As of now I am connected thru a combination of SpeedTouch modem and DLink router as a backup.

Is there any way to diagnose what is missing for the DSL connection to be established by 877?

35 Replies 35



your config looks ok. to troubleshoot, try to connect your laptop/PC directly on any spare FE ports on your 877 and assign static IPs on the subnet. ping your GW and on the SP side. i bet you would expect replies from the router GW and time out from the SP. if you detect CD light is blinking fast, this automatically indicates an ADSL sync problem. check for any Layer 1 issues (RJ11, splitter) and report this to your SP/telco and have this fixed.

Like I said above, backup modem syncs just fine.

I was hoping for specifics in troubleshooting ADSL connection with 877.


Does anybody know what commands could be used on 877 to find out why the modem can't sync to DSL?

Add the following to your ATM interface.

dsl enable-training-log

Then run the following and hopefully it will give you some useful info.

show dsl interface ATM0

Here attached is the output of sh dsl int atm0 after dsl training log was enabled.

I don't know how to interpret that output.

I myself have had issues with the auto training mode on serveral 877s.  When the ATM interface was set to auto it never trained up.  Once I set  "dsl operating-mode ansi-dmt" it worked flawlessly. If you do not know what mode your carrier supports you might want to give each a try.

  adsl2     ITU G.992.3 Annex A and L

  adsl2+    ITU G.992.5 Annex A

  ansi-dmt  ANSI T1.413

  itu-dmt   ITU G.992.1 Annex A


It worked in auto mode for a year. I was told that the modem is not hearing any signal from DSLAM and is upping the volume as far as it can, then gives up.


Does anybody know how to interpret dsl training log attached above to troubleshoot the issue with no connection?


I don't understand why you're unable to troubleshoot using simple pings. I used the command dsl enable-training-log before but couldn't even interpret it unless you open a TAC case. You mentioned this works with your back up router and I've seen this kind of situation before. I would suggest to replace the 877's power adapter and try to test again.

Sent from Cisco Technical Support iPhone App

What specifically are you proposing to ping?

I am sceptical about 'simple pings' because we are facing an issue with training to the telco's ADSL signal. Do you really understand what is the issue here? See, there would be nothing to ping on the WAN until carrier is detected and PPP authenticated. Does it help?

I hate to say it but if you have another modem training up but the Cisco will not, then the ADSL interface most likely is bad.  I would still try and specify a dsl mode just in case the auto funtion is what went out.


No amount of specifying DLS mode helps the modem to hear any signals from the line.


Sorry but it looks like the adsl port is bad. If the router has advanced ip services you could always use the external modem in bridging mode and use a second vlan with one of the 4 switch ports.

Sent from Cisco Technical Support iPhone App

Yes, it's advanced IP services IOS. How can achieve that?

I heard about putting Alcatel SpeedTouch into bridge mode, but no idea how to use 877 with that.

What would do PPPoE dialing and what is required on the IOS to support that?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers