ā03-17-2024 10:16 PM
Dears,
OSPF diagram show as below
R1 (Area 12 ) ---- R2( Area 0) ---- R3 (Area 0)---- R4(Area 10)
if only R1 loopback 0 interface advertised to R3 and only ABR router summurize to Area 10 , how to configure
Best Regards,
ā03-17-2024 10:48 PM - edited ā03-17-2024 11:00 PM
Hello @yo8-20
"if only R1 loopback 0..." you want to summarize or restrict advertisement ?
Summarize one loopback ? Summarizing only one loopback interface might seem unusual in a such case. Generally, summarization is used to aggregate multiple networks or subnets to reduce the size of the routing table and optimize routing efficiency.
To go further with summarization:
To summarize routes in OSPF, you typically use the `area` command with the `range` option on the router that is the ABR between the areas being summarized. In your scenario, R2 is the ABR between Area 0 and Area 12. Assuming you want to summarize the loopback interfaces of R1 into a single summary route advertised into Area 0, here's how you can do it:
R2 Configuration
router ospf 1
area 10 range <summary_address> <mask>
Replace <summary_address> with the network address to be summarized, and <mask> with the corresponding subnet mask... For example, if R1's has 3 Loopback interfaces with IP addresses: 192.168.1.1/32, 192.168.1.10/32 and 192.168.1.250/24 and you want to summarize it into a single route ''192.168.1.0/32 to Area 10, you should configure:
router ospf 1
area 10 range 192.168.1.0 255.255.255.0
This configuration on R2 will summarize the routes within the specified range and advertise the summary route into Area 0. R3 will then only see this summarized route to reach R1's Loopback interfaces.
ā03-17-2024 11:09 PM
I explain wrong message , I want to question if R1 Loopback0 not advertise out of Area 12
how to configure and use prefix-list command , right ?
ā03-17-2024 11:17 PM
this LAB for you
two LO one advertise and other not
I use area range NOT-ADVERTISE
ā03-18-2024 02:38 AM
Thanks, I want to know command use on interface below is use to advertise in single area right ?
interface 30/0
ip ospf area 0
ā03-18-2024 02:46 AM
hostname R4
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback10
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 10.0.0.4 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 100
network 4.4.4.4 0.0.0.0 area 10
network 10.0.0.0 0.0.0.255 area 10
network 44.44.44.44 0.0.0.0 area 10
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R4#
R1#show run
R1#show running-config
Building configuration...
Current configuration : 1813 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 100.0.0.1 255.255.255.0
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 10.0.0.1 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 100
area 10 range 44.44.44.44 255.255.255.255 not-advertise
network 10.0.0.0 0.0.0.255 area 10
network 100.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R2#show run
Building configuration...
Current configuration : 1756 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 100.0.0.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.2 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 100
network 20.0.0.0 0.0.0.255 area 20
network 100.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R3#show run
Building configuration...
Current configuration : 1709 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.3 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet5/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet6/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 100
network 20.0.0.0 0.0.0.255 area 20
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R3#
this all command I use in lab
MHM
ā03-17-2024 11:17 PM - edited ā03-17-2024 11:40 PM
Yes @yo8-20
Under router ospf peocess on R3 (ABR) add this command:
area 0 filter-list <name prefix-list> out
Prefix-list deny the IP address and permit 0.0.0.0/0 le 32
ā03-18-2024 02:16 AM - edited ā03-18-2024 02:35 AM
Hello
M02@rt37solution will work although it will ONLY be filtered in area 10
So If the goal is to filter the prefix from the ospf database then use the solution @MHM Cisco World suggested or a egress filter-list on R2 (ABR) to deny the area 12 loopback to enter the ospf backbone, both solutions should then filter the prefix from the ospf database
Example: R2
ip prefix-list loop deny 1.1.1.1/32
ip prefix-list loop permit 0.0.0.0/ le 32
router ospf x
area 12 filter-list prefix loop out
ā03-18-2024 02:38 AM - edited ā03-18-2024 12:57 PM
check below
MHM
ā03-18-2024 03:07 AM
Hello @MHM Cisco World
Cannot see why not, you can test it if you like, I dont the availability to do so.
Filter it egress at the ABR of R2, the prefix should then ONLY be available from it original area (12)
ā03-18-2024 03:08 AM
sure I will test and share result here
MHM
ā03-18-2024 04:24 AM
Hello @MHM Cisco World ,
area filter lists can be applied on ABR for all types of internal routes including LSA Type 3.
For filtering the most effective is to filter inbound on area 0 on the ABR nodes between source area and area 0.
Filtering outbound on a specific area has a more limited effect.
Best Regards
Giuseppe
ā03-18-2024 12:58 PM
@Giuseppe Larosa @paul driver @yo8-20
I test also filter-list and it also work
ā03-18-2024 04:21 PM
Hello
@MHM Cisco World
yeap makes sense, filtering egress at R1(ABR) will remove the prefix from the areas 0 & 20
ā06-11-2024 09:55 PM
Thanks all for discussion , I understand OSPF summarization , the prefix list and the fliter list
and one more thing I want to know is how to calculate the link cost (bandwidth and cost measure) of Router between OSPF Router
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide