- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 05:55 AM
Hello
I am struggling a bit with BGP and different IP Subnets. Well, I can now reach the two directly attached
neighbors AS100 | 10.10.10.7>-<9.9.9.8 | AS200 But why arnt possible to reach the L0 interfaces?
yes remote-as and the Net, i have created. thanks
This are a SIM:
-- # R7
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface Ethernet0/0
ip address 10.10.10.7 255.255.255.0
!
router bgp 100
bgp log-neighbor-changes
neighbor 8.8.8.8 remote-as 200
neighbor 8.8.8.8 update-source Loopback0
neighbor 9.9.9.8 remote-as 200
!
address-family ipv4
network 7.7.7.7 mask 255.255.255.255
network 8.8.8.8 mask 255.255.255.255
neighbor 8.8.8.8 activate
neighbor 8.8.8.8 next-hop-self
neighbor 9.9.9.8 activate
exit-address-family
!
ip forward-protocol nd
!
ip route 9.9.9.0 255.255.255.0 Ethernet0/0
--# R8
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface Ethernet0/0
ip address 9.9.9.8 255.255.255.0
!
router bgp 200
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 update-source Loopback0
neighbor 10.10.10.7 remote-as 100
!
address-family ipv4
network 7.7.7.7 mask 255.255.255.255
network 8.8.8.8 mask 255.255.255.255
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 next-hop-self
neighbor 10.10.10.7 activate
exit-address-family
!
ip forward-protocol nd
!
ip route 10.10.10.0 255.255.255.0 Ethernet0/0
!
Solved! Go to Solution.
- Labels:
-
Routing Protocols
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 08:41 AM
Hello,
not really sure what you are asking, but if you use loopbacks for BGP connectivity, you need static routes (as you did), or use another routing protocol and redistribute it. Either way, BGP by itself does not provide for loopback connectivity. It only works for directly connected networks:
So you have to configure either:
R7
interface Ethernet0/1
ip address 11.11.11.1 255.255.255.252
!
router bgp 100
bgp router-id 7.7.7.7
neighbor 8.8.8.8 remote-as 200
neighbor 8.8.8.8 ebgp-multihop 255
neighbor 8.8.8.8 update-source Loopback0
!
ip route 8.8.8.8 255.255.255.255 11.11.11.2
R8
interface Ethernet0/1
ip address 11.11.11.2 255.255.255.252
!
router bgp 200
bgp router-id 8.8.8.8
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 ebgp-multihop 255
neighbor 7.7.7.7 update-source Loopback0
!
ip route 7.7.7.7 255.255.255.255 11.11.11.1
or
R7
interface Ethernet0/1
ip address 11.11.11.1 255.255.255.252
!
router bgp 100
bgp router-id 7.7.7.7
neighbor 11.11.11.2 remote-as 200
R8
interface Ethernet0/1
ip address 11.11.11.2 255.255.255.252
!
router bgp 200
bgp router-id 8.8.8.8
neighbor 11.11.11.1 remote-as 100
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 06:04 AM
Personally i do not believe you have BGP peer relation establish.
can you check the BGP peering established ?
show bgp summary
Note : by just doing static route forwarding router does not mean that routing establish. they should know each other either they should be part of same subnet or other kind of reachability)
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 06:52 AM
Disable direct connect check
Or
Use ebgp multi hop
Also' there is no route for loopback' the bgp need l3 reachability between two neighbor before it established
MHM
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 08:08 AM - edited 03-31-2024 08:21 AM
Hello balaji.bandi and VIP MHM Cisco World
first let me thanks for your quick Answer!
i have 2 Site A and B
Site A Ethernet0/0 10.10.10.7 UP UP
>L0 7.7.7.7
Site B Ethernet0/0 9.9.9.8 UP UP
>L0 8.8.8.8
Also on sh ip bgp summ, i see the Loopback interface IP Adresses
I just don't think the Ip route approach seems to be right. yes possible
after adding this ip route you will reach the other L0 interface, but
this is a function that handling BGP?? here i dont need a quick fix,
i need to understand this, i read now the BGP Chapter.....
R7#sh ip bgp summary
BGP router identifier 7.7.7.7, local AS number 100
BGP table version is 2, main routing table version 2
1 network entries using 144 bytes of memory
1 path entries using 80 bytes of memory
1/1 BGP path/bestpath attribute entries using 152 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 376 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
8.8.8.8 4 200 0 0 1 0 0 never Idle
9.9.9.8 4 200 0 0 1 0 0 never Idle
R7#
R7#sh run | s ro b
router bgp 100
bgp log-neighbor-changes
neighbor 8.8.8.8 remote-as 200
neighbor 8.8.8.8 disable-connected-check
neighbor 8.8.8.8 update-source Loopback0
neighbor 9.9.9.8 remote-as 200
!
address-family ipv4
network 7.7.7.7 mask 255.255.255.255
network 8.8.8.8 mask 255.255.255.255
neighbor 8.8.8.8 activate
neighbor 8.8.8.8 next-hop-self
neighbor 9.9.9.8 activate
exit-address-family
R7#
R8#
R8#sh ip bgp summary
BGP router identifier 8.8.8.8, local AS number 200
BGP table version is 2, main routing table version 2
1 network entries using 144 bytes of memory
1 path entries using 80 bytes of memory
1/1 BGP path/bestpath attribute entries using 152 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 376 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
7.7.7.7 4 100 0 0 1 0 0 never Idle
10.10.10.7 4 100 0 0 1 0 0 never Idle
R8#
R8#
R8#sh run | s ro b
router bgp 200
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 disable-connected-check
neighbor 7.7.7.7 update-source Loopback0
neighbor 10.10.10.7 remote-as 100
!
address-family ipv4
network 7.7.7.7 mask 255.255.255.255
network 8.8.8.8 mask 255.255.255.255
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 next-hop-self
neighbor 10.10.10.7 activate
exit-address-family
R8#
and why the ip route bgp are empty? on bgp 100 and 200 i add the Networks 6.6.6.6 and 7.7.7.7
R7#sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
R7#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
7.0.0.0/32 is subnetted, 1 subnets
C 7.7.7.7 is directly connected, Loopback0
9.0.0.0/24 is subnetted, 1 subnets
S 9.9.9.0 is directly connected, Ethernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, Ethernet0/0
L 10.10.10.7/32 is directly connected, Ethernet0/0
R7#
R7#sh bgp ipv4 unicast neighbors | include BGP neighbor|TTL
BGP neighbor is 8.8.8.8, remote AS 200, external link
External BGP neighbor not directly connected.
External BGP neighbor NOT configured for connected checks (single-hop disable-connected-check)
BGP neighbor is 9.9.9.8, remote AS 200, external link
External BGP neighbor not directly connected.
External BGP neighbor configured for connected checks (single-hop no-disable-connected-check)
R7#
if i delete this route, the other side arnt reachable, and the BGP Establishment
are gone.
ip route 9.9.9.0 255.255.255.0 Ethernet0/0
I am simply of the opinion that BGP should do this or do I really need OSPF with Redistribution?
thanks
Mauri
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 08:41 AM
Hello,
not really sure what you are asking, but if you use loopbacks for BGP connectivity, you need static routes (as you did), or use another routing protocol and redistribute it. Either way, BGP by itself does not provide for loopback connectivity. It only works for directly connected networks:
So you have to configure either:
R7
interface Ethernet0/1
ip address 11.11.11.1 255.255.255.252
!
router bgp 100
bgp router-id 7.7.7.7
neighbor 8.8.8.8 remote-as 200
neighbor 8.8.8.8 ebgp-multihop 255
neighbor 8.8.8.8 update-source Loopback0
!
ip route 8.8.8.8 255.255.255.255 11.11.11.2
R8
interface Ethernet0/1
ip address 11.11.11.2 255.255.255.252
!
router bgp 200
bgp router-id 8.8.8.8
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 ebgp-multihop 255
neighbor 7.7.7.7 update-source Loopback0
!
ip route 7.7.7.7 255.255.255.255 11.11.11.1
or
R7
interface Ethernet0/1
ip address 11.11.11.1 255.255.255.252
!
router bgp 100
bgp router-id 7.7.7.7
neighbor 11.11.11.2 remote-as 200
R8
interface Ethernet0/1
ip address 11.11.11.2 255.255.255.252
!
router bgp 200
bgp router-id 8.8.8.8
neighbor 11.11.11.1 remote-as 100
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
03-31-2024 09:15 AM
first off all to peer with BGP using Loopback you need to be aware each router to reach each other using Loopback
If they do not know each other, then you can use P2P Ethernet to bring the BGP up and BGP learn the Loopback IP address in the routing table.
example simple config for your testing, on top you can develop your own.
R34
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.8 4 200 102 103 3 0 0 01:29:19 1
interface Ethernet0/0
ip address 10.10.10.7 255.255.255.0
!
router bgp 100
bgp log-neighbor-changes
neighbor 10.10.10.8 remote-as 200
!
address-family ipv4
network 7.7.7.7 mask 255.255.255.255
neighbor 10.10.10.8 activate
exit-address-family
R33
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface Ethernet0/0
ip address 10.10.10.8 255.255.255.0
!
router bgp 200
bgp log-neighbor-changes
neighbor 10.10.10.7 remote-as 100
!
address-family ipv4
network 8.8.8.8 mask 255.255.255.255
neighbor 10.10.10.7 activate
exit-address-family
R34#show bgp summary
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.8 4 200 102 103 3 0 0 01:29:19 1
R33#show bgp summary
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.7 4 100 103 103 3 0 0 01:29:47
R34#show ip route bgp
Gateway of last resort is not set
8.0.0.0/32 is subnetted, 1 subnets
B 8.8.8.8 [20/0] via 10.10.10.8, 01:29:25
R33#show ip route bgp
7.0.0.0/32 is subnetted, 1 subnets
B 7.7.7.7 [20/0] via 10.10.10.7, 01:30:05
