cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
189739
Views
7
Helpful
19
Replies
Highlighted
Beginner

Can we assign multiple Vlans to same physical switch port-Access Port

Hi,

We are having L2 Vlans on our switch and there is a requirement of assigning multiple VLANs to same physical switch port-Access port. We will be terminating server over this port having multiple applications.

Thanks

19 REPLIES 19
Beginner

Re: Can we assign multiple Vlans to same physical switch port-Ac

If you need to have more than one vlan on this port, then this will become a trunk where you have multiple vlans and the traffic will be distinguished by adding the vlan tag to it

Sent from Cisco Technical Support iPhone App

Beginner

Hi guys,i know this is too

Hi guys,
i know this is too late reply, but i wonder What if we say like this:
!

interface FastEthernet0/11
 switchport trunk allowed vlan 10,20
 switchport mode access
 switchport voice vlan 30
!

Cisco Employee

Re: Hi guys,i know this is too

ty

Can we assign multiple Vlans to same physical switch port-Access

If your switch is POE then you can assign 2 VLAN

!

interface fa0/1

switchport mode access

switchport access vlan 2

switchport voice vlan 3

end

VIP Advisor

Can we assign multiple Vlans to same physical switch port-Access

As Amjad said, you could create a trunk port and tag VLANs, but you could also specifiy a native vlan:

switchport trunk native vlan XX

...which would send out that particular VLAN (XX) untagged, and any traffic recieved untagged will be put in VLAN XX.

So would behave like an access switchport.

cheers,

Seb.

Beginner

Re: Can we assign multiple Vlans to same physical switch port-Ac

Thanks Seb, will try & revert on the result. Also please let me know this native Vlan(XX) has to be a different vlan from the Vlans used or we can speficy native vlan from any of the used vlans.

Regards

Beginner

Re: Can we assign multiple Vlans to same physical switch port-Ac

The switch would assume that all the untagged frames coming in on that port are part of the native VLAN. For an example if you are using that port for server and if the server NIC is capable to tag the different subnet traffic with the VLAN tag and if the switch receive any untagged frames sent by the server then they belongs to the native VLAN.

It is not necessary that you should configure native VLAN and it depends on what you configured on your server NIC and if the server is sending any uptagged frames or not.

Thanks,

Kasi

Cisco Employee

Re: Can we assign multiple Vlans to same physical switch port-Access

ty
Frequent Contributor

Re: Can we assign multiple Vlans to same physical switch port-Ac

What kind of server?  Are you going to be plugging in a VMWare ESX server or something?  You just need a trunk port in that case.

Beginner

Re: Can we assign multiple Vlans to same physical switch port-Ac

Try these two steps.

Configure the port as a trunk

switchport mode trunk

Configure the trunk to only allow vlans 10 and 15

switchport mode trunk allowed vlan 10,15

Beginner

Can we assign multiple Vlans to same physical switch port-Access

Yes, we can assign multiple Vlans to same physical switch port-Access Port.

first, you need change the switchport to mode trunk end then allow the ports

int f0/0

switchport mode trunk

switchport trunk allowed vlan 10,20

show interfaces trunk

Fa0/1       10,20

if you wanna add another vlan in the same interface:

switchport trunk allowed vlan add 5

show interfaces trunk

Fa0/1       5,10,20

source = https://supportforums.cisco.com/docs/DOC-2218

Beginner

but i want to dynamically

but i want to dynamically assign ip to my laptops, so will i do?

thanks

Frequent Contributor

Can we assign multiple Vlans to same physical switch port-Access

you can assign 1 vlan to 1 access port but you can assign secondary ip address to vlan interface

so you will get 2 networks

Beginner

Can we assign multiple Vlans to same physical switch port-Access

please guide me.. in my organisation there is approx 350 users and 15 catlyst switch 3760 series. .but only vlan 1 is create on root switch. and connet to other switch..some issue is frequenty facing in network. . i want to implement atleat two  vlan and stp .but issue is that i dont want to do changes on users desktop as their is no dhcp in our organistain. all have assign static ip address.4 network ip are user in our organisation network. but all are interconnete and able to ping each other. may be configured on fireware. there is large number of live user.. is there any possible way . to overcome form this issue. need your guide..

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards