03-12-2005 12:35 PM - edited 03-03-2019 09:01 AM
Hi ,
I have Cisco 1721 router with two Wic1-ADSL cards, I wanna setup an internet connection over two ADSL lines. However, I want that router must automatically balance the total bandwidth, in other words router should balance all traffic on these two lines (load sharing/balancing) and also if a problem occur at one of this connections, router should automatically forward requests to 2.nd ADSL line (may be called redundancy or something like that). Please, I really need such a solution urgently, here is my current configuration (below), with this configuration only ATM1 is working. Thank for your helps.
-------------
!
hostname Anka1_1721
!
enable password ************
!
ip subnet-zero
ip name-server 212.156.4.4
ip name-server 212.156.4.1
!
interface ATM1
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
no fair-queue
ip load-sharing per-packet
!
interface ATM1.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
no fair-queue
ip load-sharing per-packet
!
interface ATM0.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet0
description +++ LAN +++
ip address 10.0.0.130 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
speed 100
hold-queue 100 out
half-duplex
!
!
interface Dialer1
description +++ TTNet ADSL via ATM1 +++
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ******* password *******
!
!
interface Dialer0
description +++ TTNet ADSL via ATM0 +++
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
ppp authentication pap callin
ppp pap sent-username ******@ttnet password ******
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.0 255.255.255.0 FastEthernet0
!
ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static 10.0.0.100 10.0.1.100
!
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 101 permit ip 10.0.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
line vty 0 4
password *******
login
!
03-12-2005 01:15 PM
I take it you do get IP's on both ATM subinterfaces, is that right?
For equal, per-destination loadbalancing over both interfaces see this: http://forum.cisco.com/eforum/servlet/NetProf;jsessionid=xa8x8enn61.SJ1A?page=netprof&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40.1dd7430b/1#selected_message
For the "redundancy" see this: http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html#wp1066247
03-13-2005 02:19 AM
Hi, i tried to implement your advice to my configuration, unfortunately no connetion. In shortly I need load balancing on two ADSL lines, my ISP gives dynamic IP's for both lines. Last configuration is below, I am inexpreienced in routing, if you explaind in details i will be happy, Thank you.
!
hostname Anka1_1721
!
enable password *****
!
ip subnet-zero
ip name-server 212.156.4.4
ip name-server 212.156.4.1
!
interface ATM1
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
no fair-queue
!
interface ATM1.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
no fair-queue
!
interface ATM0.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet0
description +++ LAN +++
ip address 10.0.0.130 255.255.255.0
ip nat inside
ip policy route-map pbr
ip tcp adjust-mss 1452
speed 100
half-duplex
!
!
interface Dialer1
description +++ TTNet ADSL via ATM1 +++
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ******@ttnet password ********
!
!
interface Dialer0
description +++ TTNet ADSL via ATM0 +++
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
ppp authentication pap callin
ppp pap sent-username ******@ttnet password ******
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.0 255.255.255.0 FastEthernet0
!
ip http server
!
ip nat inside source route-map Dialer0 interface Dialer0 overload
ip nat inside source route-map Dialer1 interface Dialer1 overload
ip nat inside source static 10.0.0.100 10.0.1.100
!
access-list 97 permit 10.0.0.0 0.0.0.255
access-list 98 permit 10.0.0.0 0.0.0.255
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
route-map pbr permit 10
match ip address 97
match interface Dialer0
!
route-map pbr permit 20
match ip address 98
match interface Dialer1
!
line vty 0 4
password *************
login
!
03-13-2005 05:44 AM
OK, then no explanation, just configuration.
Start by doing a "sh ip int brie", do both ATM subinterfaces have an IP address?
Then write the following.
ip cef
no ip route 10.0.0.0 255.255.255.0 FastEthernet0
no route-map pbr
route-map Dialer0 permit 10
match ip address 97
match interface Dialer0
!
route-map Dialer1 permit 10
match ip address 98
match interface Dialer1
Now you should be able to see 2 default routes in the route-tabel, when doing a "sh ip route", is that correct?
If you do a check from http://www.google.com/search?hl=en&q=my+ip+address&btnG=Google+Search, clicking on the links, you should see that the different websites, states 2 different IP's, right?
09-16-2005 06:11 AM
Hi tekha,
I have a question about the configuration. When you configured the two route-map, you introduce the ip policy command on the ethernet interface, or on each dialer interface ??
Thanks
09-16-2005 09:01 AM
Your configuration should already support equal cost load balancing, but you need to understand what it is you are asking. Your configuration has two, equal cost, static, default routes. These two routes should both appear in your routing table when you issue the "show ip route" command like so:
S* 0.0.0.0/0 [1/0] via Dialer0
S* 0.0.0.0/0 [1/0] via Dialer1
If that is the case (i.e. please check your routing table), then you need to decide which type of load balancing you want to use. Based on your posted configuration, the router is already configured for Per-Destination load balancing (meaning that each IP stream or flow will alternate between up to four routes in most cases). While this approach is fine for most environments, it will almost certainly leave an unequal distribution of bandwidth used between the available links.
Since you want to even distribute bandwidth, you need to use Per-Packet load balancing, which alternates between available routes on a per-packet basis, regardless of destination. While this approach will result in better distribution of bandwidth, it will also present problems with out-of-sequence packets and address translation. Since you are using NAT, I would recommend keeping your existing configuration (even with the lack of true sharing for bandwidth between the two links).
Here's the best references I could find to illustrate what I just stated:
http://www.cisco.com/warp/public/105/46.html (How does load balancing work?)
http://www.cisco.com/en/US/products/hw/modules/ps2033/prod_technical_reference09186a00800afeb7.html (Load balancing with CEF)
Hope this helps,
JW
--
Justin White, CCIE #14745, MCSE
09-19-2005 06:09 AM
I have this configuration:
interface FastEthernet0/0
ip address 10.10.1.1 255.255.0.0
no ip redirects
no ip proxy-arp
ip nat inside
ip tcp adjust-mss 1452
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.10 255.255.255.0
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
pvc 8/32
pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0/1/0.1 point-to-point
pvc 8/32
pppoe-client dial-pool-number 2
!
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
ip policy route-map adsl1
dialer pool 1
ppp authentication pap chap callin
ppp chap hostname xxxxxxxxxx
ppp chap password 7 00051715084B1B16
ppp pap sent-username xxxxxxxxxxxx
password 7 yyyyyyyyyyy
!
interface Dialer2
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
ip policy route-map adsl2
dialer pool 2
ppp authentication pap chap callin
ppp chap hostname xxxxxxxxxxxxx
ppp chap password 7 yyyyyyyyyyy
ppp pap sent-username xxxxxxxxxx
password 7 yyyyyyyyy
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
ip nat inside source route-map adsl1 interface Dialer1 overload
ip nat inside source route-map adsl2 interface Dialer2 overload
!
access-list 3 permit any
route-map adsl2 permit 10
match interface Dialer2
!
route-map adsl1 permit 10
match interface Dialer1
I would like to know if this configuration will permit lan connect to the internet through the two adsl.
I'm no sure about the nat and route-map configuration.
Please, help as much as you can.
Thanks in advance
09-19-2005 10:34 AM
Looks pretty allright to me.
The route-map/NAT configuration is to let the router
NAT all internal addresses to the address of the interface its traversing.
If you have enabled ip cef, your interfaces should be running ip load-sharing per-destination, which it should. If you haven't allready enabled CEF, then please do. (ip cef)
You don't need the "ip policy route-map" on the Dialer interfaces, so remove those.
Could you do a "sh ip cef internal" and "sh ip nat stat", and post the results here.
Yhat would give us a hint, to see if it's working or not.
09-20-2005 03:11 AM
Now, I don't have the two adsl lines to connect and make proves.
But I have this message doing "sh ip cef internal" and "show ip nat stat":
r1841_aud#show ip cef inter
IP CEF with switching (Table Version 6), flags=0x0
5 routes, 0 reresolve, 0 unresolved (0 old, 0 new), peak 0
5 leaves, 8 nodes, 9136 bytes, 13 inserts, 8 invalidations
1 load sharing elements, 376 bytes, 1 references
universal per-destination load sharing algorithm, id CB41AB75
3(1) CEF resets, 1 revisions of existing leaves
Resolution Timer: Exponential (currently 1s, peak 1s)
1 in-place/0 aborted modifications
refcounts: 2312 leaf, 2304 node
Table epoch: 0 (5 entries at this epoch)
0.0.0.0/0, version 4, epoch 0, attached, per-destination sharing
0 packets, 0 bytes
via Dialer2, 0 dependencies
traffic share 1
valid punt adjacency
via Dialer1, 0 dependencies
traffic share 1
valid punt adjacency
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
r1841_aud#show ip nat stat
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
Dialer1, Dialer2
Inside interfaces:
FastEthernet0/0
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] route-map adsl1 interface Dialer1 refcount 0
[Id: 2] route-map adsl2 interface Dialer2 refcount 0
Queued Packets: 0
I supose that you want to see this commands with the two lines connectec, but I can do this until next week.
Can you explain me why "ip policy route-map" command are not necessary on dialers interfaces?
Thank you very much.
09-20-2005 05:31 AM
We don't want to use the 2 route-maps for policy-routing, only for the NAT translation.
We will let CEF and load-sharing per-destination, figure out which interface to use.
And the NAT statements will then NAT the destination address, to whatever IP address the the packet is traversing.
From the output you can see that you have 2 default routes, one via Dialer1 and the other via Dialer2. And using Per-destination load-sharing.
0.0.0.0/0, version 4, epoch 0, attached, per-destination sharing
0 packets, 0 bytes
via Dialer2, 0 dependencies
traffic share 1
valid punt adjacency
via Dialer1, 0 dependencies
traffic share 1
valid punt adjacency
And these 2 statements in the "sh ip nat stat":
[Id: 1] route-map adsl1 interface Dialer1 refcount 0
[Id: 2] route-map adsl2 interface Dialer2 refcount 0
Means that your are natting on 2 different interfaces.
It looks like this would work.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide