cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1191
Views
20
Helpful
8
Replies

Cisco1921 Router DHCP Problem

mschmieder
Level 1
Level 1

I'm having a DHCP problem with a configuration I know should work. Currently I have an ASA 5505 sitting in front of my ISP's wireless router. Int VLAN1 is DHCP client getting an IP address from my ISP. and int VLAN2 is DHCP server giving the ISP's wireless router's outside interface an IP address. The ISP's wireless router's inside interface is pointing to my network both wireless and wired. This configuration works just fine and prevents my ISP from snooping in my network and seeing all my devices.

I bought a Cisco 1921 router loading IOS image file c1900-universalk9-mz.SPA.157-3.M6. I want to give he ASA 5505 to my son. My configuration on the 1921 is a follows;

Outside interface

Router(config)# int g0/0
Router(config-if)# ip address dhcp
Router(config-if)# no shutRouter(config-if)# exit

Inside interface

Router(config)# int g0/1
Router(config-if)# ip address 10.0.100.1 255.255.255.252
Router(config-if)# no shut

Router(config-if)# exit

At that point I'm getting an IP address from my ISP but I need to assign an IP address to the ISP's wireless router so I add DHCP router;

 

Router# configure terminal

Router(config)# ip dhcp-server 10.0.100.1
Router(config)# ip dhcp pool pool1
Router(dhcp-config)# network 10.0.100.0 255.255.255.252
Router(dhcp-config)# exit

That's when I loss the ISP's IP assignment. Then I reverse the process;

 

Router(config)# ip dhcp pool pool1

Router(dhcp-config)# no network 10.0.100.0 255.255.255.252

Router(dhcp-config)# exit

Router(config)# no ip dhcp pool pool1

Router(config)# no ip dhcp-server 10.0.100.1

As soon as I remove the line

ip dhcp-server 10.0.100.1

I'm getting DHCP again from the ISP. When I debug DHCP this is what I see;

 

Router#debug dhcp

DHCP client activity debugging is on

Router#

*Aug  5 12:06:26.755: DHCP: deleting entry 30C04CD0 0.0.0.0 from list

*Aug  5 12:06:26.755: DHCP: Client socket is closed

*Aug  5 12:06:36.207: DHCP: Try 9 to acquire address for GigabitEthernet0/0

*Aug  5 12:06:36.207: DHCP: allocate request

*Aug  5 12:06:36.207: DHCP: new entry. add to queue, interface GigabitEthernet0/0

*Aug  5 12:06:36.207: DHCP: Client socket is opened

*Aug  5 12:06:36.207: DHCP: SDiscover attempt # 1 for entry:

*Aug  5 12:06:36.207: DHCP: SDiscover: sending 312 byte length DHCP packet

*Aug  5 12:06:36.207: DHCP: SDiscover 312 bytes

*Aug  5 12:06:36.207:             B'cast on GigabitEthernet0/0 interface from 0.0.0.0

*Aug  5 12:06:36.755: DHCP: Received a BOOTREP pkt

*Aug  5 12:06:36.755: DHCP: offer received from 173.75.63.1

*Aug  5 12:06:36.755: DHCP: offer: server 173.75.63.1 not in approved list

*Aug  5 12:06:39.755: DHCP: SDiscover attempt # 2 for entry:

*Aug  5 12:06:39.755: DHCP: Received a BOOTREP pkt

*Aug  5 12:06:39.755: DHCP: offer received from 173.75.63.1

*Aug  5 12:06:39.755: DHCP: offer: server 173.75.63.1 not in approved list

*Aug  5 12:06:43.755: DHCP: SDiscover attempt # 3 for entry:

*Aug  5 12:06:43.755: DHCP: SDiscover: sending 312 byte length DHCP packet

*Aug  5 12:06:43.755: DHCP: SDiscover 312 bytes

*Aug  5 12:06:43.755:             B'cast on GigabitEthernet0/0 interface from 0.0.0.0

*Aug  5 12:06:43.759: DHCP: Received a BOOTREP pkt

*Aug  5 12:06:43.759: DHCP: offer received from 173.75.63.1

*Aug  5 12:06:43.759: DHCP: offer: server 173.75.63.1 not in approved list%Unknown DHCP problem.. No allocation possible

The line 'DHCP: offer: server 173.75.63.1 not in approved list' caught my attention (173.75.63.1 is my ISP) but what list? There's only the local DHCP pool which the DHCP client shouldn't have anything to do with. Is there an unknown fluke with this particular IOS because this configuration should work. It works just fine on the ASA 5505. If anybody could shed so liht on this I'd be extremely grateful.

Thanks,

Mike

1 Accepted Solution

Accepted Solutions

Hello


@mschmieder wrote:
ISP <---------| g0/0 1921 Router g0/1 |---------> LAN (home network)

Cisco does say you can have both DHCP Server and DHCP Client on the same router to get an IP address from an ISP and assign IP addresses to devices on a LAN 


Well yes you can however I would suggest to use a private address for your lan subnet when you enable your own dhcp service on the rtr.

Example 1921 router



Int gig0/0
Descritption WAN ISP
no shut
ip address dhcp
ip nat outside

Int gig0/1
Descritption LAN 
no shut
ip address 192.168.1.1 255.255.255.0
ip nat inside

Ip route 0.0.0.0 0.0.0.0 gig0/0 dhcp

ip dhcp pool LAN_DHCP
network 192.168.1.0 /24
dns server 192.168.1.1
default-gateway 192.168.1.1
lease 0 8

ip dns server 192.168.1.1

access-list 100 permit ip 192.168.1.0 0.0.0.255 any
ip nat inside source list 100 interface gig0/0


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

8 Replies 8

Hello,

going through your post, I am having a bit of a problem visualizing your topology. Can you provide a schematic drawing showing what is connected to what ?

Hi,

Thanks for your reply. Although I've consulted this community board numerous times over the years I never posted so I don't know how to add a topology map image. It's a pretty simple setup though;

ISP <---------| g0/0 1921 Router g0/1 |---------> LAN (home network)

Cisco does say you can have both DHCP Server and DHCP Client on the same router to get an IP address from an ISP and assign IP addresses to devices on a LAN (works just fine on my ASA 5505 like that) but it's not working on the 1921 router. As soon as I enable DHCP Server on the inside interface (g0/1) I stop getting an IP Address from my ISP on the outside interface (g0/0). As a lab test I substituted the ISP with a working ASA 5505 to eliminate the possibility of anything quirky with my ISP but I'm getting the same results.

Lab test;

ASA 5505 <---------| g0/0 1921 Router g0/1 |---------> LAN (home network)

For some reason DHCP Client is having a conflict with DHCP Server

 

Hello


@mschmieder wrote:
ISP <---------| g0/0 1921 Router g0/1 |---------> LAN (home network)

Cisco does say you can have both DHCP Server and DHCP Client on the same router to get an IP address from an ISP and assign IP addresses to devices on a LAN 


Well yes you can however I would suggest to use a private address for your lan subnet when you enable your own dhcp service on the rtr.

Example 1921 router



Int gig0/0
Descritption WAN ISP
no shut
ip address dhcp
ip nat outside

Int gig0/1
Descritption LAN 
no shut
ip address 192.168.1.1 255.255.255.0
ip nat inside

Ip route 0.0.0.0 0.0.0.0 gig0/0 dhcp

ip dhcp pool LAN_DHCP
network 192.168.1.0 /24
dns server 192.168.1.1
default-gateway 192.168.1.1
lease 0 8

ip dns server 192.168.1.1

access-list 100 permit ip 192.168.1.0 0.0.0.255 any
ip nat inside source list 100 interface gig0/0


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thanks Paul works like a charm.
After removing the

ip dhcp-server 10.0.100.1

command but leaving the DHCP pool intact I'm not only receiving an IP address from the ISP but also able to assign IP addresses to client devices on the LAN. Along with other commands you provided the router is doing exactly what it was intended to do. The final configuration is as follows;

int g0/0
description ISP
ip address dhcp
ip nat outside

int g0/1
description LAN
ip address 10.0.100.1 255.255.255.252
ip nat inside

ip route 0.0.0.0 0.0.0.0 g0/0 dhcp

ip dhcp pool pool1
network 10.0.100.0 255.255.255.252
default-router 10.0.100.1

I didn't configure DNS at this time but I am saving your configuration for future reference.
Again thanks.
Mike

Hello Mike
Glad to hear you have got it working - thank you for marking your OP as solved and for the rating.

Kind Regards
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

ammahend
VIP
VIP

your DHCP pool does not seem to have gateway information, may be that's the problem, and I agree a topology might be better to visualize.

-hope this helps-

RachelGomez161999
Spotlight
Spotlight

Solution Cisco1921 Router DHCP Problem-

Check the adapter settings on the host. Make sure that the "Obtain Ip address automatically" and "Obtain DNS server address automatically" options are selected.
Verify whether the IP address pool (for the host "vrf") has been created on the DHCP server.
Verify whether the DHCP server runs out of addresses to lease for that particular IP pool.

 

 

Greeting,

Rachel Gomez

Hello


@mschmieder wrote:

 Currently I have an ASA 5505 sitting in front of my ISP's wireless router. Int VLAN1 is DHCP client getting an IP address from my ISP. and int VLAN2 is DHCP server giving the ISP's wireless router's outside interface an IP address. The ISP's wireless router's inside interface is pointing to my network both wireless and wired


Can you confirm if you are trying to use the same subnet range in your DHCP scope as what the isp is supplying?
Also based on what you have described the physical setup seems to suggest:

ASA


ISP<>(outside)ASA(outside)<>WLAN router<> LAN

 

Would have expected to something more like this:


ISP<>(outside)ASA(inside)<>WLAN router<> LAN

Router


ISP<>(wan)RTR(lan)<>WLAN router<> LAN

Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card