cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
18838
Views
5
Helpful
17
Replies
youssef abdalla
Beginner

Eigrp Doesn't redistibute static routes

hello i have a router 2901 and

i have a problem in my eigrp  configuration that the other branch   only see the network that i am advertised in eigrp and can't see the the redistibuted static route inside eigrp .. i dunno why is  that
and that's my running

!

aaa new-model

aaa session-id common

!

no ipv6 cef

ip source-route

ip cef

!

no ip domain lookup

ip domain name andalusia.loc

multilink bundle-name authenticated

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 41.32.188.36 255.255.255.248

ip nat outside

ip virtual-reassembly

!

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

ip address 192.168.3.180 255.255.255.0

ip nat inside

ip virtual-reassembly

ip policy route-map redirect

!

interface GigabitEthernet0/0.110

encapsulation dot1Q 110

ip address 10.21.176.180 255.255.240.0

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.150

encapsulation dot1Q 150

ip address 10.21.160.180 255.255.240.0 secondary

ip address 192.168.150.180 255.255.255.0

!

interface GigabitEthernet0/0.240

encapsulation dot1Q 240

ip address 10.21.240.180 255.255.240.0

ip nat outside

ip virtual-reassembly

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

!

interface Serial0/0/0

description LinkDotNet_MPLS

no ip address

ip flow ingress

encapsulation frame-relay IETF

no fair-queue

clock rate 2000000

frame-relay lmi-type ansi

!

interface Serial0/0/0.1 point-to-point

description Mgt

ip address 10.193.7.54 255.255.255.252

ip flow ingress

frame-relay interface-dlci 80  

!

interface Serial0/0/0.2 point-to-point

description Data1

ip address 10.193.7.58 255.255.255.252

ip flow ingress

frame-relay interface-dlci 81  

!

interface Serial0/0/1

description TEdata_MPLS

no ip address

ip flow ingress

encapsulation frame-relay IETF

clock rate 2000000

frame-relay lmi-type q933a

!

interface Serial0/0/1.16 point-to-point

ip address 172.16.2.2 255.255.255.252

ip flow ingress

frame-relay interface-dlci 16  

!

!

router eigrp 100

network 10.21.160.180 0.0.0.0

network 172.16.2.2 0.0.0.0

redistribute static

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

!

ip nat inside source route-map To-101 interface GigabitEthernet0/0.240 overload

ip nat inside source route-map To-102 interface GigabitEthernet0/0.1 overload

ip nat inside source static 10.21.176.50 41.32.188.37

ip route 10.21.0.0 255.255.0.0 10.21.160.1

ip route 0.0.0.0 0.0.0.0 41.32.188.33

ip route 0.0.0.0 0.0.0.0 10.21.240.101 200

ip route 10.1.0.0 255.255.0.0 10.193.7.57 200

ip route 10.2.0.0 255.255.0.0 10.193.7.57 200

ip route 10.3.0.0 255.255.0.0 10.193.7.57 200

ip route 10.22.0.0 255.255.0.0 10.193.7.57 200

ip route 213.131.65.192 255.255.255.224 10.193.7.53

ip route 213.131.66.0 255.255.255.0 10.193.7.53

!

ip access-list extended To-101

permit ip host 192.168.3.8 any

permit ip 10.21.176.0 0.0.15.255 any

ip access-list extended To-102

permit ip host 192.168.3.7 any

!

access-list 10 permit 10.21.0.0 0.0.255.255

access-list 15 deny   0.0.0.0

access-list 15 permit any

!

route-map test permit 10

match ip address 10

!

route-map redirect permit 10

match ip address To-101

set ip next-hop 10.21.240.101

set interface GigabitEthernet0/0.240

!

route-map redirect permit 20

match ip address To-102

set ip next-hop 41.32.188.33

set interface GigabitEthernet0/0.1

!

route-map To-102 permit 10

match ip address To-102

set ip next-hop 41.32.188.33

!

route-map To-101 permit 10

match ip address To-101

set ip next-hop 10.21.240.101

!

!

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

privilege level 15

password 7 09764F1B170C1C1A5A5957

transport input ssh

!

scheduler allocate 20000 1000

end

======================================================================================

i need to advertise the subnet 10.21.0.0/16 inside the eigrp ..
anyone can help with this problem ?

1 ACCEPTED SOLUTION

Accepted Solutions
mfarrenkopf
Beginner

Youssef,

I know that this thread is pretty old.  Nevertheless . . .

Could it be as simple as the network is not included in the list of networks in your router eigrp section?

router eigrp 100

network 10.21.160.180 0.0.0.0

network 172.16.2.2 0.0.0.0

redistribute static

Neither of those network statements will cover 10.21.0.0/16.  I'd try adding:

network 10.21.0.0 0.0.255.255

And see what that does.

View solution in original post

17 REPLIES 17
Marwan ALshawi
Advisor

This is because you missing the metric

Use the default metric under eigrp confignas bellow

default-metric 10000 100 255 1 1500

Or use it with redistribute command like

Redistribute static metric 10000 100 255 1 1500

See the bellow link for more details

http://www.ciscopress.com/articles/article.asp?p=27839&seqNum=7

Hope this help

If helpful rate

tx but i tried this also yesterday and it didn't solve the problem .
another ideas ?

is 10.21.0.0/16 made it to RIB?

sh ip route 10.21.0.0 255.255.0.0

is this marked by red subnet missing, or the other statics as well?

what is the configuration on the other side? stubs won't accept externals for example.

HTH,

Ivan.

Can you run a debug and see if it's even being advertised out towards the remote destination? If so, it could be getting blocked down the yellow brick road by some other security measure or routing manipulation? Also, do you see any other routes that are being redistributed on this remote router?

Marwan ALshawi
Advisor

Also. Under eigrp config add

No auto-summary

And you have to use the metric for redistribution to work in eigrp it is not optional

Hope this help

Peter Paluch
Hall of Fame Cisco Employee

Hello Marwan,

It has been my experience - but I may be wrong here or the IOS default may have changed! - that when redistributing specifically static or connected routes, the seed metric is not necessary as it will be derived from the EIGRP metrics of the egress interface of the redistributed route. I did not need to specify a seed metric when redistributing static/connected routes into EIGRP. However, having the seed metric specified is a safe bet, certainly.

Just my two cents...

Best regards,

Peter

Hi Peter,

Is there some document that indicates "that when redistributing specifically static or connected routes, the seed metric is not necessary as it will be derived from the EIGRP metrics of the egress interface of the redistributed route"?

Thanks in advance,

David

Peter Paluch
Hall of Fame Cisco Employee

Hello David,

I have not found any document so far that would explicitly confirm that for redistribution of connected or static routes into EIGRP, the metric will be computed automatically using the metric of egress interface. I have found this simply by experimenting. I remember noticing that even though I did not specify the seed metric, the static and connected routes always got redistributed, and after a couple of experiments and paying close attention to the metrics of redistributed routes, I have come to this conclusion.

Best regards,

Peter

I hate to say it, but while you should not require a metric for redistributed statics, i've taught at networkers for the past dozen years that you should only leave the metric off if you don't care whether it works or not. It's quite buggy deriving the metric and it always just works if you define it. Why leave it off? What value is there in leaving it off.

Sent from Cisco Technical Support iPad App

Also did you ever supply the output of show ip route on the static. I didn't see it. Which interface do you reach the next hop through? Is it a recursive route?

Sent from Cisco Technical Support iPad App

I know this is an old post and all, but this one comment of yours saved me while troubleshooting some old IOS issues today. Thank you! 

The statics were NOT being distributed, I was starting to suspect VRFs being the culprits, but then I read this and just tried configuring the default metrics.

Voila! 

youssef abdalla
Beginner

no the red subnet is shown in the routing table but it's not advertised .. that the main route that i need to advertise the other routes is not important for me ..
the other side is not a stub i think it's normal eigrp and reditibution working great from the other side ..

to marwan

i read before the metric issue and it should be written but from the practical side i did that and it doesn't differ and in the other branch the redistiburion is working great without the metric commnd

also the no auto-summary is the default option in this ios that's why it doesn't appear hear ..

i need to know the command to see the advertised routes from eigrp from my router

" debup ip eigrp  "or their is another commands coz that's the first time for me to troubleshoot using debug in eigrp

or their is another comand

I'd start looking into 'sh ip eigrp topology'

deb ip routing will show what's happening with redistribution

HTH,

Ivan.

Youssef,

Check the "show ip eigrp topology " in both the routers (the router that advertises and the router that receives)

In the advertising router you must see the route as being redistributed (via Redistributed)

In the received router you must see this route as being received from its neighbors (via next hop)

Then check which of the received routes will get into the routing table and why?

And static routes doesnot need a metric to be redistributed into EIGRP as it would take interface's parameters just like connected routes.