cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1224
Views
0
Helpful
2
Replies

fair-queue command (WFQ)

mackeyuk
Level 1
Level 1

Hello All,

I am trying to implement some QoS on my 851w router and it seems my options are somewhat limited.

My best option it seems is to enable WFQ on the WAN interface.

Question how does the router know how to equally share the bandwidth.  The router is connected to a cable modem via a 100Mb/s Ethernet cable and thus doesnt know the bandwidth is limited by our ISP.  Do I have to tell the cisco the "true" bandwidth of the connection?  If so how.

Thanks for all your help so far!

G.

2 Replies 2

rstanisl
Cisco Employee
Cisco Employee

HI,

You need to make sure you have the Advance ip service IOS code to be able to enable qos on the router.

Below is a sample config.

First you create a acl to match the traffic that you want to give priority.

second you create a class-map and specify the match traffic.

then you configure a policy-map and apply the bandwidth you want to give to the specific class for priority

You configure a child policy to match the traffic classes.

The parent policy will be the amount of bandwith you are gettnig for this connection.

you will create a shape average command to specify this value,so the interface will know how much bandwidth you have.

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_configuration_example09186a0080094af9.shtml

has some good info

Below is a sample for giving voice traffic priority.

ccess-list 100 permit udp any any range 16384 32767
access-list 100 permit udp any any precedence critical
access-list 100 permit udp any any dscp ef
access-list 101 permit tcp any eq 1720 any
access-list 101 permit tcp any any eq 1720

class-map VOICE
  match access-group 100
class-map VOICE-SIG
  match access-group 101

policy-map child
  class VOICE
    priority 720 <---This is variable depending on your bandwidth
  class VOICE-SIG
    bandwidth 50<---This is variable depending on your bandwidth
policy-map parent
  class class-default
   shape average 720000 7200 0 <---This is variable depending on your
bandwidth
   service-policy VOICE-POLICY

interface FastEthernet0/0
  service-policy output parent

hope this helps.

Raymond

Hi Raymond,

Thanks for taking the time to reply in such detail.

Unfortunately the Cisco 850 series does not support CBWFQ only WFQ (fair-queue).

regards,

Gary.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: