12-06-2021 06:20 AM
When i try to Ping fron internal router (192.168.40.2/24)to Layer-3 switch(192.168.40.1/24) same subnet ip address, it's not pinging.
NOTE: topology is attached below
Configuration:
INTERNAL ROUTER
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.40.2 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.50.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.40.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
L3-SW
!
!
!
!
!
!
!
!
vtp file nvram:vlan.dat
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet1/0
switchport access vlan 10
duplex full
speed 100
!
interface FastEthernet1/1
switchport access vlan 10
duplex full
speed 100
!
interface FastEthernet1/2
no switchport
ip address 192.168.40.1 255.255.255.0
duplex full
speed 100
!
interface FastEthernet1/3
duplex full
speed 100
!
interface FastEthernet1/4
duplex full
speed 100
!
interface FastEthernet1/5
duplex full
speed 100
!
interface FastEthernet1/6
duplex full
speed 100
!
interface FastEthernet1/7
duplex full
speed 100
!
interface FastEthernet1/8
duplex full
speed 100
!
interface FastEthernet1/9
duplex full
speed 100
!
interface FastEthernet1/10
duplex full
speed 100
!
interface FastEthernet1/11
duplex full
speed 100
!
interface FastEthernet1/12
duplex full
speed 100
!
interface FastEthernet1/13
duplex full
speed 100
!
interface FastEthernet1/14
duplex full
speed 100
!
interface FastEthernet1/15
no switchport
no ip address
duplex full
speed 100
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.3 255.255.255.0
!
interface Vlan200
ip address 192.168.30.2 255.255.255.0
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.10.5
ip route 3.3.3.0 255.255.255.0 192.168.30.1
ip route 192.168.50.0 255.255.255.0 192.168.40.2
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
12-06-2021 06:52 AM
if the interface up from both the side from Router to Layer 3 switch able to ping.
i would suggest unknow network send to Internet, specific to respected gateways
L3-SW ( make sure ip routing enabled)
ip route 0.0.0.0 0.0.0.0 192.168.40.1
Can you post below output
show interface FastEthernet1/2
show interface FastEthernet0/0
show ip route
show ip interface brief.
12-06-2021 07:03 AM
Hello
Try:
interface FastEthernet1/2
duplex auto
speed auto
12-06-2021 07:27 AM
I didn't do anything, just closed the gns3 and reopend, now it's pinging.
but got new problem, when i try to ping from L3-sw to 192.168.30.1/24 its showing :
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
NOTE: topology is attached below
12-06-2021 08:31 AM
Hello
@noob_route wrote:
when i try to ping from L3-sw to 192.168.30.1/24 its showing :
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
Looks like external 192.168.30.1 doesn't know how to reach the internal router.
External router
sh ip route
sh ip int brief
12-06-2021 06:26 PM
EXTERNAL ROUTER:
#sh ip route
3.0.0.0/24 is subnetted, 1 subnets
S 3.3.3.0 [1/0] via 10.10.10.1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, FastEthernet0/0
L 10.10.10.2/32 is directly connected, FastEthernet0/0
192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.30.0/24 is directly connected, FastEthernet0/1
L 192.168.30.1/32 is directly connected, FastEthernet0/1
S 192.168.40.0/24 [1/0] via 192.168.30.2
#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.2 YES NVRAM up up
FastEthernet0/1 192.168.30.1 YES NVRAM up up
FastEthernet1/0 unassigned YES NVRAM administratively down down
FastEthernet1/1 unassigned YES NVRAM administratively down down
12-06-2021 08:56 AM
still we need below output :
show ip route
show ip interface brief.
12-06-2021 02:13 PM
Hello,
the problem is that you are trying to connect a physical interface to an SVI. You have three options to make this work (I used physical interfaces GigabitEthernet0/0 in the examples, yours might be different);
Option 1
External Router
interface GigabitEthernet0/0
description Link to L3 Switch
ip address 192.168.30.1 255.255.255.0
L3 Switch
interface GigabitEthernet0/0
description Link to External Router
switchport mode access
switchport access vlan 200
!
interface Vlan 200
ip address 192.168.30.2 255.255.255.0
Option 2
External Router
interface GigabitEthernet0/0
description Link to L3 Switch
ip address 192.168.30.1 255.255.255.0
L3 Switch
interface GigabitEthernet0/0
description Link to External Router
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 200
!
interface Vlan 200
ip address 192.168.30.2 255.255.255.0
Option 3
External Router
interface GigabitEthernet0/0.200
description Link to L3 Switch
encapsulation dot1q 200
ip address 192.168.30.1 255.255.255.0
L3 Switch
interface GigabitEthernet0/0
description Link to External Router
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan 200
ip address 192.168.30.2 255.255.255.0
12-06-2021 01:48 PM
L3 for L3SW need to config
ip routing in global to turn on the L3 of L3SW and hence L3SW can use the routing table.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide