ā05-10-2017 09:34 PM - edited ā03-05-2019 08:30 AM
Hi all, I'm sure this will be an easy solution for an experienced person :) My Google-fu is failing me.
I have a 1941 with a dialer0 interface connecting to an ADSL2 service just fine, and default route points to the dialer0. There are some existing IP NAT INSIDE commands configured with the overload parameter corresponding to our inside address space, plus some static mappings to allow access to inside services.
I'm now adding a new service that we will migrate over to. It's a VDSL service configured on dialer1 and the service itself seems to be configured fine.
My goal is to migrate services from the original ADSL2 to the VDSL and I would like BY DEFAULT the default route to go out the dialer0 and only specified networks go out dialer1.
I've added some /32 routes for external IP addresses and traceroute to them from the router works 100% as I would expect. However, traceroute to other outside IPs that don't have routes I would expect to go out dialer0 as the default route. However these often seem to be actually going out dialer1 and I just don't know why.
Am I missing the NAT INSIDE command with overload parameter? Something else?
ā05-10-2017 10:23 PM
Please share the configuration.
ā05-10-2017 10:43 PM
The full config is about 500 lines long, so I think I have all the interesting parts below. if I traceroute 8.8.8.8 it goes out dialer1 as expected. I would think everything else would go out dialer0 but this doesn't seem to be the case. If I tracert to (for example) www.microsoft.com.au I see traceroute hops from the provider behind dialer1.
interface GigabitEthernet0/0
ip address 10.1.9.254 255.255.255.0
ip nat inside
!
interface Ethernet0/1/0
no ip address
pppoe enable group global
pppoe-client dial-pool-number 2
!
interface Dialer0
description ADSL2 connection to Internet
ip address negotiated
ip flow ingress
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp chap hostname xxxxxxx
ppp chap password 7 xxxxxxx
no cdp enable
!
interface Dialer1
description New VDSL Connection
mtu 1492
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 2
dialer-group 2
ppp authentication chap callin
ppp chap hostname 0701341169@qld.exetel.com.au
ppp chap password 7 096447583837423C0A0516
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 8.8.8.8 255.255.255.255 Dialer1
!
ip nat inside source list 101 interface Dialer0 overload
!
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
!
ā05-10-2017 11:07 PM
Hello,
which networks do you want to be reachable through interface Dialer 1 ? In your example, in order to reach 8.8.8.8 always through Dialer 1, your configuration would need to look like this:
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 8.8.8.8 255.255.255.255 Dialer1
!
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source list 102 interface Dialer 1 overload
!
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 102 permit 10.0.0.0 0.255.255.255 host 8.8.8.8
ā05-10-2017 11:45 PM
In addition,
you have got ppp ipcp route default under dialer 1 and might be due to that you have got a default route via PPP on dialer 1
get rid of it and add static route towards dialer 1 with higher AD. better way of doing it is PBR.
HTH
Hitesh
ā05-14-2017 04:31 PM
You were indeed correct that the default route was being altered! :)
ā05-15-2017 04:32 AM
Glad that its sorted.
Cheers
Hitesh
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide