cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1147
Views
0
Helpful
5
Replies

Qos in sub interface

frank2812
Level 1
Level 1

Hi, i´m trying to emulate a QOS in a network in GNS3. I attached sh run  of both routers and the image where the cloud represents my computer. I´m trying to limit the traffic from 192.168.1.108 (my computer) in the link between routers to 512 kbps. The link between routers should be 4Mb maximun. im generating traffic from a traffic generator in my laptop and the QOS in the interface is not working. I´ll wait your answers

In sumary the confi in R1 and r2 is

COnfig R1

class-map match-any MARCAJE_ANTIVIRUS

match access-group name ANTIVIRUS

policy-map QOS-ANTIVIRUS

class MARCAJE_ANTIVIRUS

  priority 512

policy-map parent

class class-default

  shape average 4000000

  service-policy QOS-ANTIVIRUS

ip access-list extended ANTIVIRUS

permit ip  host 192.168.1.108 any

no permit ip  any  host 192.168.1.108

load-interval 30 dentro de la if fisica

interface FastEthernet0/1.800

description METROETHERNET-PRIVADO-CANTV

encapsulation dot1Q 800

ip address 10.10.10.4 255.255.255.0

no snmp trap link-status

service-policy output parent

bandwidth 4000

end

Config R2

class-map match-any MARCAJE_ANTIVIRUS

match access-group name ANTIVIRUS

policy-map QOS-ANTIVIRUS

class MARCAJE_ANTIVIRUS

  priority 512

policy-map parent

class class-default

  shape average 4000000

  service-policy QOS-ANTIVIRUS

ip access-list extended ANTIVIRUS

permit ip any host 192.168.1.108

interface FastEthernet0/1.800

service-policy output parent

  description METROETHERNET-PRIVADO-CANTV

encapsulation dot1Q 800

ip address 10.10.10.2 255.255.255.0

no snmp trap link-status

service-policy output parent

bandwidth 4000

1 Accepted Solution

Accepted Solutions

Hello

Try this:

ip access-list extended ANTIVIRUS

permit ip host 192.168.1.108 any

class-map match-all MARCAJE_ANTIVIRUS

match access-group name ANTIVIRUS

class-map match-all DSCP

match  dscp 2

policy-map Child

class DSCP

bandwidth 512

random-detect

class class-default

fair-queue

policy-map parent

class class-default

shape average 4000000

service-policy Child

policy-map QOS-ANTIVIRUS

class MARCAJE_ANTIVIRUS

police 512000 80000 conform-action transmit  exceed-action drop

set dscp 2

interface FastEthernet0/0

service-policy input QOS-ANTIVIRUS

interface FastEthernet0/1.800

service-policy output parent

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

5 Replies 5

Nagendra Kumar Nainar
Cisco Employee
Cisco Employee

Hi Frank,

Per you configuration, you have 4 MB of total traffic allowed and anything more will be buffered. Also yo have a child policy applied to match the traffic from you PC and have it in LLQ. So when there is no traffic on otehr classes (in your case class-default whihc will have the remaining bandwidth), traffic in LLQ can go uptil the shapoing rate whcih is 4 MB.

The above coniguration will allow 4 Mb of traffic from you PC. If your intension is to limit the traffic from PC less than 512 Kb, you need to apply policing to match the traffic from PC and police @ 512 Mb.

HTH,

Nagendra

i think when i put "policy-map QOS-ANTIVIRUS" i´m doing policing to match the traffic from PC. Could you explain me in more detail?

policy-map QOS-ANTIVIRUS

class MARCAJE_ANTIVIRUS

  priority 512

Hello

You can mark on the interface for the traffic ingress from.your pc and match on and apply Llq to this traffic outbound on the egress interface between your two routers

Or

Police all the ingress traffic from the pc before it hits the wan interface and then shape your overall.traffic to.your CIR

Res
Paul

Sent from Cisco Technical Support Android App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

usasigcis
Level 1
Level 1

Negative you re prioritizing thst traffic kf there is a congestion
As explained above if there is enough bw 4mb will be used
Yiu need to jse police command rsther than priority


Sent from Cisco Technical Support Android App

Hello

Try this:

ip access-list extended ANTIVIRUS

permit ip host 192.168.1.108 any

class-map match-all MARCAJE_ANTIVIRUS

match access-group name ANTIVIRUS

class-map match-all DSCP

match  dscp 2

policy-map Child

class DSCP

bandwidth 512

random-detect

class class-default

fair-queue

policy-map parent

class class-default

shape average 4000000

service-policy Child

policy-map QOS-ANTIVIRUS

class MARCAJE_ANTIVIRUS

police 512000 80000 conform-action transmit  exceed-action drop

set dscp 2

interface FastEthernet0/0

service-policy input QOS-ANTIVIRUS

interface FastEthernet0/1.800

service-policy output parent

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking for a $25 gift card