cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
919
Views
30
Helpful
12
Replies

Routing troubleshooting

lucad7846
Level 1
Level 1

Hi everyone

I have to do some routing troubleshooting for one of my assignments. I was provided a PKT file which I have attached. The routes don't work as expected and I have to troubleshoot the issue. 

After adding a few static routes and implementing RIPv2, I sort of got connectivity between the pc's and the internet. However, when I try to ping I get a success rate of about 40% sometimes 60% but never 100%. 

I am not entirely sure what the issue could be. I tried tracert and everything looks to be working ok. 

Any idea how I could fix this? 

On a slightly different note, I noticed that after configuring RIPv2 none of the routers seems to have any "r" routes listed in their  routing table. I am not sure why this is.

Any help would be much appreciated. 

Cheers 

 

3 Accepted Solutions

Accepted Solutions

Hello,

basically, you need the static routes marked in bold. Also, the requirements state that you only need static routes, so I would get rid of RIP altogether. 

If you have actual IP addresses on the other side of the link, it is usually recommended to use these as the

next hop 

in static routes, rather than the outgoing interfaces. It saves time and CPU because the routers do not have to ARP for the

next hop IP address...

Here are the working configs (the revised file is attached as well):

ROI-SYD-R1#sh run
Building configuration...

Current configuration : 1391 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROI-SYD-R1
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX152430K7-
!
spanning-tree mode pvst
!
interface Loopback1
description Multimedia Productions
ip address 192.168.102.1 255.255.255.0
!
interface Loopback2
description IT Support
ip address 192.168.104.1 255.255.255.0
!
interface Loopback3
description Sales and Marketing
ip address 192.168.106.1 255.255.255.0
!
interface GigabitEthernet0/0
description Connection to ROI-SYD-WEB-SVR1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 209.165.200.17 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to ROI-PER-R1
ip address 10.0.0.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
description Connection to ISP
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
--> ip route 0.0.0.0 0.0.0.0 209.165.200.18
--> ip route 10.2.10.0 255.255.255.0 10.0.0.2
--> ip route 10.2.20.0 255.255.255.0 10.0.0.2
--> ip route 10.2.99.0 255.255.255.0 10.0.0.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

ROI-PER-R1#sh run
Building configuration...

Current configuration : 1786 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname ROI-PER-R1
!
enable password 7 0822404F1A0A
!
--> ip dhcp excluded-address 10.2.10.1
--> ip dhcp excluded-address 10.2.20.1
!
ip dhcp pool MULTIMEDIA
network 10.2.10.0 255.255.255.0
default-router 10.2.10.1
dns-server 192.168.100.3
domain-name roi.perth.mm.local
1
ip dhcp pool SALESMARKET
network 10.2.20.0 255.255.255.0
default-router 10.2.20.1
dns-server 192.168.100.3
domain-name roi.perth.mm.local
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524HT19
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
description Connection to ROI-PER-S1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.2.10.1 255.255.255.0
!
interface GigabitEthernet0/1.20
encapsulation dot1Q 20
ip address 10.2.20.1 255.255.255.0
!
interface GigabitEthernet0/1.99
encapsulation dot1Q 99 native
ip address 10.2.99.1 255.255.255.0
!
interface Serial0/0/0
description Connection to ROI-SYD-R1
ip address 10.0.0.2 255.255.255.252
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
--> ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
ip flow-export version 9
!
banner motd ^CUnauthorised access is prohibited!^C
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
access-class VTY_ACCESS in
password 7 0822455D0A16
login
line vty 5 15
access-class VTY_ACCESS in
password 7 0822455D0A16
login
!
end

View solution in original post

Mostly from routing table. Add static route something u don't have like

ip route 8.7.7.0 255.255.255.0 serial 0.0.0 and then find it in routing table

Also. Use ? With comands

ip route destination network mask next hop. 

What network u must reach ? which way to reach it ? Via

next hop 

of your neighbor or exit interface on your router. 

You can find many videos on YouTube 

Regards, ML
**Please Rate All Helpful Responses **

 

View solution in original post

No, next hop is always IP of your neighbor and technically you should say "next hop is xx.x.x"; but you could say "exit via IP x"

if you want to use exit interface, it is interface on your router (where u configuring) and you should not say next hop but "exit interface xyz" or just "interface xyz" or "reach network x via interface xyz".  So , you can give exit via next hop IP which is IP of a neighbor or exit interface as my exit interface, i.e serial0

When you give IP as exit (aka next hop), router will do recursive lookup to find exit interface for that IP.  Sometimes such entry fails if router does not know how to reach that IP.  Try enter ip route 8.8.8.8 255.255.255.255 1.1.1.1  and then do show ip route.  Network 8.8.8.8/32 via 1.1.1.1 is not in the  routing table because there is no route to 1.1.1.1.

But if you change IP to something that router knows about it, like ip route 8.8.8.8 255.255.255.255 209.165.200.18. This will show up in the routing table as

S 8.8.8.8/32 [1/0] via 209.165.200.18

because router had figured it out that IP of 209.165.200.18 is on network 209.165.200.16/28 and it is directly connected to  GigabitEthernet0/1, see output below

sh ip ro 209.165.200.18

Routing entry for 209.165.200.16/28

Known via "connected", distance 0, metric 0 (connected, via interface)

Routing Descriptor Blocks:

* directly connected, via GigabitEthernet0/1

Route metric is 0, traffic share count is 1

 

As a side note; shutting down interface will also remove any static routes that are related to that interface

Regards, ML
**Please Rate All Helpful Responses **

View solution in original post

12 Replies 12

Martin L
VIP
VIP

several things are wrong with static routing and 1 command missing in

router rip

(although not sure how relevant is RIP because of AD).  RIP should be no auto-summary. 

Static routes are pointing wrong direction; i.e.

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1.10 and
ip route 0.0.0.0 0.0.0.0 10.0.0.1;

which one is wrong?

 

Regards, ML
**Please Rate All Helpful Responses **

Hi thanks so much for the suggestion. 

Can you please explain how you determine that the direction of the routes are wrong? I really want to learn.  

Thanks so very much for your help. 

Mostly from routing table. Add static route something u don't have like

ip route 8.7.7.0 255.255.255.0 serial 0.0.0 and then find it in routing table

Also. Use ? With comands

ip route destination network mask next hop. 

What network u must reach ? which way to reach it ? Via

next hop 

of your neighbor or exit interface on your router. 

You can find many videos on YouTube 

Regards, ML
**Please Rate All Helpful Responses **

 

Gotcha. Thanks so much. One last thing if I may, when you say to use ? with commands - in the

ip route 

command the

 next hop

is the interface? i.e.

ip route 8.7.7.0 255.255.255.0 serial 0.0.0 - is the serial 0/0/0 the next hop

or there is a specific way to add the

next hop

to the statement? 

Thanks so very much for your help

No, next hop is always IP of your neighbor and technically you should say "next hop is xx.x.x"; but you could say "exit via IP x"

if you want to use exit interface, it is interface on your router (where u configuring) and you should not say next hop but "exit interface xyz" or just "interface xyz" or "reach network x via interface xyz".  So , you can give exit via next hop IP which is IP of a neighbor or exit interface as my exit interface, i.e serial0

When you give IP as exit (aka next hop), router will do recursive lookup to find exit interface for that IP.  Sometimes such entry fails if router does not know how to reach that IP.  Try enter ip route 8.8.8.8 255.255.255.255 1.1.1.1  and then do show ip route.  Network 8.8.8.8/32 via 1.1.1.1 is not in the  routing table because there is no route to 1.1.1.1.

But if you change IP to something that router knows about it, like ip route 8.8.8.8 255.255.255.255 209.165.200.18. This will show up in the routing table as

S 8.8.8.8/32 [1/0] via 209.165.200.18

because router had figured it out that IP of 209.165.200.18 is on network 209.165.200.16/28 and it is directly connected to  GigabitEthernet0/1, see output below

sh ip ro 209.165.200.18

Routing entry for 209.165.200.16/28

Known via "connected", distance 0, metric 0 (connected, via interface)

Routing Descriptor Blocks:

* directly connected, via GigabitEthernet0/1

Route metric is 0, traffic share count is 1

 

As a side note; shutting down interface will also remove any static routes that are related to that interface

Regards, ML
**Please Rate All Helpful Responses **

Awesome! That clarifies the next hop scenario. So next hop equals IP and exit interface for the interface. 

Thanks so very much I am learning a ton of stuff. 

Hello,

basically, you need the static routes marked in bold. Also, the requirements state that you only need static routes, so I would get rid of RIP altogether. 

If you have actual IP addresses on the other side of the link, it is usually recommended to use these as the

next hop 

in static routes, rather than the outgoing interfaces. It saves time and CPU because the routers do not have to ARP for the

next hop IP address...

Here are the working configs (the revised file is attached as well):

ROI-SYD-R1#sh run
Building configuration...

Current configuration : 1391 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROI-SYD-R1
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX152430K7-
!
spanning-tree mode pvst
!
interface Loopback1
description Multimedia Productions
ip address 192.168.102.1 255.255.255.0
!
interface Loopback2
description IT Support
ip address 192.168.104.1 255.255.255.0
!
interface Loopback3
description Sales and Marketing
ip address 192.168.106.1 255.255.255.0
!
interface GigabitEthernet0/0
description Connection to ROI-SYD-WEB-SVR1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 209.165.200.17 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to ROI-PER-R1
ip address 10.0.0.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
description Connection to ISP
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
--> ip route 0.0.0.0 0.0.0.0 209.165.200.18
--> ip route 10.2.10.0 255.255.255.0 10.0.0.2
--> ip route 10.2.20.0 255.255.255.0 10.0.0.2
--> ip route 10.2.99.0 255.255.255.0 10.0.0.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

ROI-PER-R1#sh run
Building configuration...

Current configuration : 1786 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname ROI-PER-R1
!
enable password 7 0822404F1A0A
!
--> ip dhcp excluded-address 10.2.10.1
--> ip dhcp excluded-address 10.2.20.1
!
ip dhcp pool MULTIMEDIA
network 10.2.10.0 255.255.255.0
default-router 10.2.10.1
dns-server 192.168.100.3
domain-name roi.perth.mm.local
1
ip dhcp pool SALESMARKET
network 10.2.20.0 255.255.255.0
default-router 10.2.20.1
dns-server 192.168.100.3
domain-name roi.perth.mm.local
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524HT19
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
description Connection to ROI-PER-S1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.2.10.1 255.255.255.0
!
interface GigabitEthernet0/1.20
encapsulation dot1Q 20
ip address 10.2.20.1 255.255.255.0
!
interface GigabitEthernet0/1.99
encapsulation dot1Q 99 native
ip address 10.2.99.1 255.255.255.0
!
interface Serial0/0/0
description Connection to ROI-SYD-R1
ip address 10.0.0.2 255.255.255.252
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
--> ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
ip flow-export version 9
!
banner motd ^CUnauthorised access is prohibited!^C
!
line con 0
password 7 0822455D0A16
login
!
line aux 0
!
line vty 0 4
access-class VTY_ACCESS in
password 7 0822455D0A16
login
line vty 5 15
access-class VTY_ACCESS in
password 7 0822455D0A16
login
!
end

Hi Georg

Thanks so very much for that. 

So from what you are saying, if I didn't have the outside IP address RIP would work? I am asking because I really want to learn.

Once again thanks heaps for your support

Cheers

Hello,

if you don't have the IP address of the other side of the link, the static route would look like this:

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1

This means that the router does not know the IP address of the device at the other end, and it will have to send out an ARP request to get that address...which uses up resources.

RIP (or any other dynamic routing protocol) would work. You basically announce the networks you want to advertise, and the corresponding routes get installed...

Hi Georg

Awesome! It's starting to really make sense now. Thanks so much. 

On a different note, why the rip routes wouldn't show in the routing tables of my original file despite rip being configured? I now understand rip is not relevant in this scenario, but I still would like to understand from a configuration standpoint. 

Many thanks in advance

"rip is not relevant in this scenario" because of Administrative Distance, or in short AD.  AD is per-reconfigured or per-determined for all routers and locally significant only.  AD is like a route believability or trustworthy.   Lower number is better.  if you have 2 exactly same networks but from different sources, lowest one wins, and it is entered.  i.e. static routes have number 1, RIP has AD of 120. 

Directly connected routes are the most believed. AD is 0. Those are always preferred over any others.

Static routes have AD of 1. Router assumes that you as admin know what you doing, therefore number is 1.

BGP is 20 and 200, EIGRP AD is 90 and 170, RIP is 120, OSPF 90. 

255 is bad and such route is not installed in routing table, aka means remove it.

you must find a AD table with numbers and memorize it for exam or networking knowledge (google it). 

You can make changes to AD; you can give it more preference over others. For example you could give your static route AD of 125, which is more than default AD for RIP routes. then, RIP will be installed and not static route.  Such static route is often used as a back up route and often called as a floating route. If RIP fails, route x with AD of 120 is removed and static route with AD 125 is installed.

Regards, ML
**Please Rate All Helpful Responses **

Hi 

Thanks so very much for explaining it so well. There is a lot to learn but as previously stated, I am slowly starting to get my head around it. 

I will definitely keep that in mind regarding AD the lower the number the more trustworthy.

The floating route I was getting crazy the other day when I was reading about it. It now makes sense. Thanks so much!

Review Cisco Networking products for a $25 gift card