cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
968
Views
35
Helpful
17
Replies
ccrank
Beginner

Routing

 
 
 

Hello All,

 

I am new to networking and I'm sure that will be apparent by this question. In one of my classes we have been asked to put together this network(see attached). I have connected everything and assigned IP addresses. I have a server and two computers all using different gateways on the router.

 

I don't understand how I am supposed to make all of these reachable without a switch. Any hints?

 

PC1_TestNetwork
NIC1
192.168.1.101
255.255.255.0
192.168.1.100
PC2_TestNetwork
NIC1
192.168.2.101
255.255.255.0
192.168.2.100
Server_TestNetwork
NIC1
192.168.3.101
255.255.255.0
192.168.3.100
Router_TestNetwork
FastEthernet0/0
FastEthernet0/1
FastEthernet1/0
192.168.1.100
192.168.2.100
192.168.3.100
255.255.255.0
n/a

 

Thanks for any advice,

Chris

1 ACCEPTED SOLUTION

Accepted Solutions

If you show the arp table on the PC does it have an entry for the router?

If you show the arp table on the router does it have entries for he PCs?

HTH

Rick

View solution in original post

17 REPLIES 17
luis_cordova
VIP Advisor

Hi @ccrank 

 

In this case, the router will do the job of routing the hosts from one network to another network.
You can check that they will be routed by checking the routing table with the show ip route command

 

Regards

Hi Luis,

 

When I run show ip route, I get this:

C     192.168.1.0/24 is directly connected fa0/0

C     192.168.2.0/24 is directly connected fa0/1

C     192.168.3.0/24 is directly connected fa1/0

If I try to ping any devices all I get is host unreachable. I guess I don't understand what I am missing.

 

 

Hi

 

Can you share the router settings?
Everything looks good, but I would like to review.

Regards

I'm not sure how I can do that. I am working inside of a VM through InfoSec.com. If you tell me what command to run, I can show you a screenshot of that. Does that work?

Hi 

 

The settings look ok.
Have you made sure that the firewalls of the simulated PCs are down?
Sometimes fw blocks ping from external networks.
Another option is to try another simulator.


Regards

 

The command to check the configurations of a router is show running-config

 

For some reason when I run ipconfig on the PC's I have an APIPA address instead of the static address that I assigned to it. Not sure how this happened.

 

i do not believe some time virtual lab hold some config, they do default, also windows PC always have FW you need to disable.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

The firewall were on for domain, so I disabled them. Now I get correct ip address when running ipconfig. However, I still get host unreachable with ping.

If you show the arp table on the PC does it have an entry for the router?

If you show the arp table on the router does it have entries for he PCs?

HTH

Rick

View solution in original post

When I run the show ip arp on the router it only shows the interfaces on the router.

Now I am getting one pc to show up in the arp table. I flushed the arp cache on the pc. however, I can't seem to get the others to follow suit.

The arp output is helpful. If there are no entries for PCs, or an entry for only a single PC then this explains why the PCs are not able to communicate. Did you do something to get that single PC to work?

 

Does ipconfig on each of the PCs show correct address, correct mask, correct gateway?

HTH

Rick

This eventually led me to success. I cleared the arp cache on one of the PCs and then it suddenly appeared in the arp table of the router. I ended up starting the virtual lab from scratch. I powered on each VM and router, then made the ethernet connections, lastly I configured the router and the PCs and everything worked fine. I think there was something strange going on in this virtual environment, the arp cache was full of addresses that I have no idea of the origin. 

 

Thanks so much for the tips.

Chris

Chris

 

Thanks for the update. Glad to know that you started over from scratch and then things worked. Agree that something strange was going on in the virtual environment. Thank you for marking this question as solved. This will help other participants in the community to identify discussions which have helpful information. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

HTH

Rick