cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2466
Views
0
Helpful
11
Replies
Highlighted
Beginner

time based policy

Dear All, I have configured policies to shape the traffic on the interface of cisco 7206 router. Now my managemet wants to configure these policies on time based ie policy should be applicable during specified time period onle. Is it possible? if yes how to configure it?

Please help.                 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Advisor

You can do it depending on how your class maps are set up. If you're classifying traffic with an acl, you can create a time range and then apply that time range to your acl. Let's say that you want to shape web traffic between the hours of 8am and 10am, but anytime after that is not shaped and has 100% of the link:

time-range Web

     periodic 08:00 to 10:00

ip access-list ext Web

     permit tcp any any eq 80 time-range Web

class-map Web

match access-group name Web

policy-map Web

class Web

shape average 128000

class class-default

int s0/0

service-policy output Web

This would shape their traffic only between those hours.

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

Highlighted

Yes. You can use the time range anywhere an acl can be used as far as I know...

John

Please rate all useful posts...

HTH, John *** Please rate all useful posts ***

View solution in original post

11 REPLIES 11
Highlighted
Advisor

You can do it depending on how your class maps are set up. If you're classifying traffic with an acl, you can create a time range and then apply that time range to your acl. Let's say that you want to shape web traffic between the hours of 8am and 10am, but anytime after that is not shaped and has 100% of the link:

time-range Web

     periodic 08:00 to 10:00

ip access-list ext Web

     permit tcp any any eq 80 time-range Web

class-map Web

match access-group name Web

policy-map Web

class Web

shape average 128000

class class-default

int s0/0

service-policy output Web

This would shape their traffic only between those hours.

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

Highlighted

thanks dear for support, can i use time range in rate limit also?

Highlighted

Yes. You can use the time range anywhere an acl can be used as far as I know...

John

Please rate all useful posts...

HTH, John *** Please rate all useful posts ***

View solution in original post

Highlighted

Dear I ahve applied the policy as stated but i am facing some problem, Some time policy does not get started autometically at the specified time. and not gets stoped at the  configured time.

I have to remove and apply policy on interface to take effect.

following is the configuration i have done.

time-range wimx
periodic daily 7:00 to 17:30


access-list 115 permit ip any any time-range wimax

class-map wimax
  match access-group 115

policy-map wimax
  class wimax
    police cir 200000000 bc 31250000 be 31250000 conform-action transmit exceed-action drop violate-action drop
  class class-default

I am using cisco 7206 router running c7600rsp72043-advipservicesk9-mz.122-33.SRD5 ios.

Please help.....

Highlighted

If I'm understanding you right, does the policy only work during the time if you remove it and then reapply it? What time does the local clock say on the router? Is it correct? ("sh clock") When you look at the access-list during the time that it's not working, does the access-list say "Inactive"? Are you wanting to police the traffic inbound during this time? If so, you could change your direction on the interface to "service-policy input wimax". Otherwise, you may need to look for bugs in the OS that you have or upgrade the OS as a test.

HTH, John *** Please rate all useful posts ***
Highlighted

Dear following is the observation.

I mean if the policy applied on the interface it starts activated and some time even after beyond end time policy did not go to default. when i checked the show time-range and show access-list 115, both setting shows inactive.system clock is showing the correct time. but i have applied policy in both direction in and out. is it becose of this?

Highlighted

If the time is showing inactive during the time that it should be active, I'd look into updating the OS. There could be a bug. You can apply the policy in and outbound with no issues. When the ACL is inactive, it shouldn't match on the class. I'm going to lab this up and get back with you....

HTH, John *** Please rate all useful posts ***
Highlighted

On the version that I'm running, it works fine. Maybe update IOS?

HTH, John *** Please rate all useful posts ***
Highlighted

ok dear thanks, let me check and i will update u.

Highlighted

bythe way which ios u have tested it.

Highlighted

I did this in GNS with a 3745:

3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)

HTH, John *** Please rate all useful posts ***