12-07-2021 11:58 PM - last edited on 12-08-2021 03:14 AM by Translator
NOTE: PoC is attached below
R2 INTERFACE:
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 2.2.2.2 YES manual up up
FastEthernet0/1 192.168.20.1 YES manual up up
FastEthernet1/0 unassigned YES unset administratively down down
FastEthernet1/1 unassigned YES manual up up
Tunnel1 172.16.10.1 YES manual up down
R3 INTERFACE:
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 1.1.1.2 YES manual up up
FastEthernet0/1 192.168.10.1 YES manual up up
FastEthernet1/0 unassigned YES unset administratively down down
FastEthernet1/1 unassigned YES unset administratively down down
Tunnel1 172.16.10.2 YES manual up down
CONFIGURATION
R1:
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.10.0 255.255.255.0 1.1.1.2
ip route 192.168.20.0 255.255.255.0 2.2.2.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
R2:
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 1.1.1.2
tunnel key 1111
!
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.10.0 255.255.255.0 172.16.10.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
R3:
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 2.2.2.2
tunnel key 1111
!
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.20.0 255.255.255.0 172.16.10.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
Solved! Go to Solution.
12-08-2021 12:17 AM - last edited on 12-08-2021 03:16 AM by Translator
how is your network look like, as per the information you have R1 between R2 and R3 (this is my guess)
Do you have reachability between R2 to R3 ?
add static route in R2
ip route 0.0.0.0 0.0.0.0 1.1.1.1
add static route in R3
ip route 0.0.0.0 0.0.0.0 2.2.2.1
12-08-2021 01:45 AM - last edited on 12-08-2021 03:20 AM by Translator
Hello,
add the static routes marked in bold:
R1:
redundancy
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 1.1.1.2
ip route 192.168.20.0 255.255.255.0 2.2.2.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane
R2:
!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 1.1.1.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 172.16.10.2
--> ip route 1.1.1.0 255.255.255.252 2.2.2.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane
R3:
!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 2.2.2.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.20.0 255.255.255.0 172.16.10.1
--> ip route 2.2.2.0 255.255.255.252 1.1.1.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane
12-08-2021 12:17 AM - last edited on 12-08-2021 03:16 AM by Translator
how is your network look like, as per the information you have R1 between R2 and R3 (this is my guess)
Do you have reachability between R2 to R3 ?
add static route in R2
ip route 0.0.0.0 0.0.0.0 1.1.1.1
add static route in R3
ip route 0.0.0.0 0.0.0.0 2.2.2.1
12-08-2021 01:56 AM
HELLO SIR,
please help me,
i am stuck on same problem from more than 1 week..
here's the link
12-08-2021 01:56 AM
HELLO SIR,
please help me,
i am stuck on same problem from more than 1 week.. no one is reply my query
here's the link
12-08-2021 02:47 AM - last edited on 12-08-2021 03:18 AM by Translator
I could be wrong, but this doesn't look right:
add static route in R2
ip route 0.0.0.0 0.0.0.0 1.1.1.1
add static route in R3
ip route 0.0.0.0 0.0.0.0 2.2.2.1
R2 has 2.2.2.1 as the next hop, not 1.1.1.1
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
and R3 has 1.1.1.1 as the next hop, not 2.2.2.1
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
Or maybe I am reading it the wrong way...
12-08-2021 03:08 AM
May be other way around, since i do not see how these connected as mentioned in reply.
But bottom line is routing not correct. that fix his problem, hope he got that now i guess.
12-08-2021 03:42 AM
@balaji.bandi No worries, I was just wondering what test equipment you are working on, and how you got static default routes to work with next hops that are not directly connected...next hops that are not really next hops so to speak.
12-08-2021 01:45 AM - last edited on 12-08-2021 03:20 AM by Translator
Hello,
add the static routes marked in bold:
R1:
redundancy
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 1.1.1.2
ip route 192.168.20.0 255.255.255.0 2.2.2.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane
R2:
!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 1.1.1.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 172.16.10.2
--> ip route 1.1.1.0 255.255.255.252 2.2.2.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane
R3:
!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 2.2.2.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.20.0 255.255.255.0 172.16.10.1
--> ip route 2.2.2.0 255.255.255.252 1.1.1.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane
12-08-2021 01:57 AM
HELLO SIR,
please help me,
i am stuck on same problem from more than 1 week.. no one is replying my query
here's the link
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide