cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2043
Views
10
Helpful
8
Replies

Tunnel is UP but protocol is down, while performing GRE tunneling

prabinchand
Level 1
Level 1

NOTE: PoC is attached below

R2 INTERFACE:

Interface                   IP-Address                    OK?           Method            Status                              Protocol
FastEthernet0/0        2.2.2.2                           YES           manual             up                                   up
FastEthernet0/1        192.168.20.1                 YES           manual             up up
FastEthernet1/0        unassigned                     YES           unset              administratively down       down
FastEthernet1/1        unassigned                     YES           manual           up                                    up
Tunnel1                    172.16.10.1                    YES          manual            up                                   down

R3 INTERFACE:

Interface                  IP-Address                      OK?             Method        Status                            Protocol
FastEthernet0/0      1.1.1.2                           YES                manual         up                                 up
FastEthernet0/1      192.168.10.1                 YES                manual         up                                 up
FastEthernet1/0      unassigned                     YES               unset            administratively down    down
FastEthernet1/1      unassigned                     YES               unset            administratively down    down
Tunnel1                  172.16.10.2                   YES                manual         up                                  down




CONFIGURATION

R1:

redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.10.0 255.255.255.0 1.1.1.2
ip route 192.168.20.0 255.255.255.0 2.2.2.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!

R2:

!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 1.1.1.2
tunnel key 1111
!
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.10.0 255.255.255.0 172.16.10.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!

R3:

!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 2.2.2.2
tunnel key 1111
!
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.20.0 255.255.255.0 172.16.10.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane

!
2 Accepted Solutions

Accepted Solutions

balaji.bandi
Hall of Fame
Hall of Fame

how is your network look like, as per the information you have R1 between R2 and R3 (this is my guess)

 

Do you have reachability between R2 to R3 ?

 

add static route in R2

ip route 0.0.0.0 0.0.0.0  1.1.1.1



add static route in R3

ip route 0.0.0.0 0.0.0.0  2.2.2.1

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

Hello,

 

add the static routes marked in bold:

 

R1:

 

redundancy
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 1.1.1.2
ip route 192.168.20.0 255.255.255.0 2.2.2.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane




R2:

!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 1.1.1.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 172.16.10.2
--> ip route 1.1.1.0 255.255.255.252 2.2.2.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane


R3:

!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 2.2.2.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.20.0 255.255.255.0 172.16.10.1
--> ip route 2.2.2.0 255.255.255.252 1.1.1.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane

View solution in original post

8 Replies 8

balaji.bandi
Hall of Fame
Hall of Fame

how is your network look like, as per the information you have R1 between R2 and R3 (this is my guess)

 

Do you have reachability between R2 to R3 ?

 

add static route in R2

ip route 0.0.0.0 0.0.0.0  1.1.1.1



add static route in R3

ip route 0.0.0.0 0.0.0.0  2.2.2.1

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

HELLO SIR,

please help me,

i am stuck on same problem from more than 1 week..

 

here's the link

https://community.cisco.com/t5/routing/how-to-tweak-path-when-1-tunnel-has-2-nhs-using-eigrp/td-p/4514493

HELLO SIR,

please help me,

i am stuck on same problem from more than 1 week.. no one is reply my query

 

here's the link

https://community.cisco.com/t5/routing/how-to-tweak-path-when-1-tunnel-has-2-nhs-using-eigrp/td-p/4514493

@prabinchand @balaji.bandi 

 

I could be wrong, but this doesn't look right:

 

add static route in R2

ip route 0.0.0.0 0.0.0.0 1.1.1.1


add static route in R3

ip route 0.0.0.0 0.0.0.0 2.2.2.1




R2 has 2.2.2.1 as the next hop, not 1.1.1.1




interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto




and R3 has 1.1.1.1 as the next hop, not 2.2.2.1




interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto

 

Or maybe I am reading it the wrong way...

 

May be other way around, since i do not see how these connected as mentioned in reply.

 

But bottom line is routing not correct. that fix his problem, hope he got that now i guess.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

@balaji.bandi No worries, I was just wondering what test equipment you are working on, and how you got static default routes to work with next hops that are not directly connected...next hops that are not really next hops so to speak.

Hello,

 

add the static routes marked in bold:

 

R1:

 

redundancy
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 2.2.2.1 255.255.255.252
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 1.1.1.2
ip route 192.168.20.0 255.255.255.0 2.2.2.2
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane




R2:

!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.1 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 1.1.1.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.10.0 255.255.255.0 172.16.10.2
--> ip route 1.1.1.0 255.255.255.252 2.2.2.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane


R3:

!
redundancy
!
ip tcp synwait-time 5
!
interface Tunnel1
ip address 172.16.10.2 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 2.2.2.2
tunnel key 1111
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 192.168.20.0 255.255.255.0 172.16.10.1
--> ip route 2.2.2.0 255.255.255.252 1.1.1.1
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
control-plane

HELLO SIR,

please help me,

i am stuck on same problem from more than 1 week.. no one is replying my query

 

here's the link

https://community.cisco.com/t5/routing/how-to-tweak-path-when-1-tunnel-has-2-nhs-using-eigrp/td-p/4514493

Review Cisco Networking products for a $25 gift card