cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1018
Views
0
Helpful
3
Replies
merlin956
Beginner

Very low connection speed with Cisco 1801

Hi,

This is my first attempt at configuring an 1801 and I am getting extreamly low bandwidth.

Tests show up/down speeds on aroung 100kbps.  I can't see any reason with the possible exception of the show dsl capacity values which never seem to change.

I am hopeing that someone here will be able to point out my config error.

wan#show ver

Cisco IOS Software, C180X Software (C180X-ADVENTERPRISEK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Tue 20-Mar-12 17:13 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YH13, RELEASE SOFTWARE (fc1)

wan uptime is 7 hours, 46 minutes

System returned to ROM by reload at 00:11:15 AEST Wed Oct 10 2012

System image file is "flash:c180x-adventerprisek9-mz.151-4.M4.bin"

Last reload type: Normal Reload

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 1801 (MPC8500) processor (revision 0x400) with 236544K/25600K bytes of memory.

Processor board ID xxxxxxxxxxx, with hardware revision 0000

9 FastEthernet interfaces

1 ISDN Basic Rate interface

1 ATM interface

1 Virtual Private Network (VPN) Module

63808K bytes of ATA CompactFlash (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#      PID            SN

-------------------------------------------------

*0        CISCO1801             xxxxxxxxxxx    

Configuration register is 0x2102

wan#show run

Building configuration...

Current configuration : 6939 bytes

!

! Last configuration change at 07:18:13 AEST Wed Oct 10 2012 by xxxx

version 15.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname wan

!

boot-start-marker

boot system flash c180x-adventerprisek9-mz.151-4.M4.bin

boot-end-marker

!

!

security authentication failure rate 3 log

logging buffered 51200 warnings

!

no aaa new-model

!

clock timezone AEST 10 0

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2897494766

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2897494766

revocation-check none

rsakeypair TP-self-signed-2897494766

!

!

dot11 syslog

no ip source-route

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.150.128 192.168.150.254

ip dhcp excluded-address 192.168.150.1 192.168.150.32

!

ip dhcp pool internal-net

import all

network 192.168.150.0 255.255.255.0

default-router 192.168.150.254

domain-name xxxxxxxxxxxxxx.com.au

dns-server 192.168.150.1

lease 7

!

ip dhcp pool static-pool

import all

origin file flash://static-bindings

default-router 192.168.150.254

domain-name xxxxxxxxxxxxxx.com.au

dns-server 192.168.150.1

!

!

!

ip cef

ip flow-cache timeout active 5

ip domain name xxxxxxxxxxxxxx.com.au

ip name-server 130.139.4.4

ip name-server 211.29.132.12

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

license udi pid CISCO1801 sn xxxxxxxxxxx

archive

log config

  hidekeys

username xxxx privilege 15 password 7 xxxxxxxxxxxxxxxxxxxxxx

!

!

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh version 2

ip ssh pubkey-chain

  username xxxx

   key-hash ssh-rsa xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx xxxx@xxxxxxxx

  quit

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

crypto isakmp key pacxxxxxxipsecvpntunnel address xx.xxx.xxx.xx

crypto isakmp keepalive 360

!

!

crypto ipsec transform-set pacxxxxxxipsec esp-3des esp-sha-hmac

!

crypto map pacxxxxxx 10 ipsec-isakmp

! Incomplete

description Tunnel to xx.xxx.xxx.xx

set peer xx.xxx.xxx.xx

set transform-set pacxxxxxxipsec

match address IPSEC

!

!

!

!

!

interface Tunnel1

description IPSEC TO xxxxxx

ip address 192.168.149.5 255.255.255.252

ip mtu 576

shutdown

tunnel source Dialer1

tunnel destination xx.xxx.xxx.xx

tunnel path-mtu-discovery

!

interface ATM0

no ip address

no ip route-cache

load-interval 30

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet0

ip address 192.168.100.199 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

!

interface FastEthernet8

no ip address

!

interface Vlan1

description vlanSW

ip address 192.168.150.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

ip access-group 101 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp chap hostname xxxxxxxxxxxxxxx@xxxxxxxx.com.au

ppp chap password 7 xxxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxxxxxx@xxxxxxxx.com.au password 7 xxxxxxxxxxxxxxxxxx

no cdp enable

!

interface Dialer1

no ip address

!

router bgp 65534

bgp always-compare-med

bgp log-neighbor-changes

bgp bestpath med confed

network 192.168.150.0

neighbor 192.168.100.254 remote-as 65531

neighbor 192.168.100.254 prefix-list BGP-IMPORT in

neighbor 192.168.100.254 prefix-list BGP-EXPORT out

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!        

ip flow-export version 5

ip flow-export destination 192.168.150.1 23456

!

ip dns server

ip dns spoofing

ip nat inside source list 23 interface Dialer0 overload

ip nat inside source static tcp 192.168.150.1 22 interface Dialer0 1000

ip nat inside source static udp 192.168.150.1 22 interface Dialer0 1000

ip nat inside source static tcp 192.168.150.1 25 interface Dialer0 25

ip nat inside source static tcp 192.168.150.1 53 interface Dialer0 53

ip nat inside source static udp 192.168.150.1 53 interface Dialer0 53

ip nat inside source static tcp 192.168.150.2 80 interface Dialer0 80

ip nat inside source static tcp 192.168.150.1 110 interface Dialer0 110

ip nat inside source static udp 192.168.150.1 110 interface Dialer0 110

ip nat inside source static tcp 192.168.150.1 143 interface Dialer0 143

ip nat inside source static udp 192.168.150.1 143 interface Dialer0 143

ip nat inside source static tcp 192.168.150.1 465 interface Dialer0 465

ip nat inside source static tcp 192.168.150.1 993 interface Dialer0 993

ip nat inside source static udp 192.168.150.1 993 interface Dialer0 993

ip nat inside source static tcp 192.168.150.1 995 interface Dialer0 995

ip nat inside source static udp 192.168.150.1 995 interface Dialer0 995

ip nat inside source static tcp 192.168.150.2 3389 interface Dialer0 3389

ip nat inside source static udp 192.168.150.2 3389 interface Dialer0 3389

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip access-list extended IPSEC

!

!

ip prefix-list BGP-EXPORT seq 10 permit 192.168.150.0/24 le 32

ip prefix-list BGP-EXPORT seq 99 deny 0.0.0.0/0

!

ip prefix-list BGP-IMPORT seq 10 deny 192.168.150.0/24 le 32

ip prefix-list BGP-IMPORT seq 20 permit 192.168.0.0/16 le 32

ip prefix-list BGP-IMPORT seq 25 permit 172.16.0.0/12 le 32

ip prefix-list BGP-IMPORT seq 30 permit 10.0.0.0/8 le 32

ip prefix-list BGP-IMPORT seq 98 deny 0.0.0.0/0 ge 25

ip prefix-list BGP-IMPORT seq 99 deny 0.0.0.0/0 le 24

access-list 23 permit 192.168.150.0 0.0.0.255

access-list 99 permit 192.168.101.1

access-list 99 permit 192.168.100.1

access-list 99 permit xx.xxx.xxx.xx

access-list 99 permit 192.168.150.1

access-list 101 permit tcp xx.xxx.xxx.x 0.0.0.255 any eq 3389

access-list 101 permit udp xx.xxx.xxx.x 0.0.0.255 any eq 3389

access-list 101 permit tcp xxx.xxx.xxx.x 0.0.0.255 any eq 3389

access-list 101 permit udp xxx.xxx.xxx.x 0.0.0.255 any eq 3389

access-list 101 deny   tcp any any eq 3389

access-list 101 deny   udp any any eq 3389

access-list 101 permit ip any any

no cdp run

!

!

!

!

snmp-server community xxxxxxxxxxxx RO 99

snmp-server ifindex persist

snmp-server location Brisbane, Australia

snmp-server contact Network Operations (noc@xxxxxxxxxxxxxx.com.au)

snmp-server chassis-id Border Router

snmp-server enable traps tty

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

session-timeout 35791  output

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

wan#show int atm 0

ATM0 is up, line protocol is up

  Hardware is MPC ATMSAR (with Alcatel ADSL Module), address is 4055.39a2.2360 (bia 4055.39a2.2360)

  MTU 4470 bytes, sub MTU 4470, BW 814 Kbit/sec, DLY 450 usec,

     reliability 255/255, txload 63/255, rxload 2/255

  Encapsulation ATM, loopback not set

  Keepalive not supported

  Encapsulation(s): AAL5

  23 maximum active VCs, 1024 VCs per VP, 1 current VCCs

  VC Auto Creation Disabled.

  VC idle disconnect time: 300 seconds

  Last input never, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: Per VC Queueing

  30 second input rate 7000 bits/sec, 15 packets/sec

  30 second output rate 203000 bits/sec, 20 packets/sec

     158384 packets input, 40217824 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     171686 packets output, 127415558 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

wan#show dsl int atm 0

ATM0

Alcatel 20190 chipset information

         ATU-R (DS)            ATU-C (US)

Modem Status:     Showtime (DMTDSL_SHOWTIME)

DSL Mode:     ITU G.992.5 (ADSL2+) Annex A

ITU STD NUM:      0x03                 0x2

Chip Vendor ID:     'STMI'                 'IFTN'

Chip Vendor Specific:  0x0000             0x71BE

Chip Vendor Country:   0x0F             0xB5

Modem Vendor ID: 'CSCO'                 '    '

Modem Vendor Specific: 0x0000             0x0000

Modem Vendor Country:  0xB5             0x00

Serial Number Near:    FGL151528D 1801

Serial Number Far:    

ModemChip ID:      C196 (3)

DFE BOM:     DFE3.0 Annex A (1)

Capacity Used:     100%                 73%

Noise Margin:     12.0 dB             21.5 dB

Output Power:     18.5 dBm             12.5 dBm

Attenuation:     23.0 dB              9.0 dB

FEC ES Errors:      0                 212

ES Errors:      0                 30

SES Errors:      0                  1

LOSES Errors:      0                  1

UES Errors:      0                  0

Defect Status:     None                            None                       

Last Fail Code:     None

Watchdog Counter: 0x44

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:     0x00

Interrupts:     15011 (0 spurious)

PHY Access Err:     0

Activations:     1

LED Status:     ON

LED On Time:     100

LED Off Time:     100

Init FW:     init_AMR-4.0.015_no_bist.bin

Operation FW:     AMR-4.0.015.bin

FW Source:     embedded

FW Version:     4.0.15

          DS Channel1      DS Channel0    US Channel1      US Channel0

Speed (kbps):              0           18257             0             814

DS User cells:              0          955591

US User & Idle cells:                          0        53687931

Reed-Solomon EC:          0             469             0            5824

CRC Errors:              0              40             0              40

Header Errors:              0              34             0             271

Total BER:          0E-0         5670E-11

Leakage Average BER:      0E-0         1254E-10

            ATU-R (DS)    ATU-C (US)

Bitswap:               enabled          enabled

LOM Monitoring : Disabled

DMT Bits Per Bin

Not able to get complete DMT bin information.Retry "show dsl" after few seconds.

DSL: Training log buffer capability is not enabled

I have noted that every time I do a "show dsl int atm 0" the "Capacity Used" is always 100% and 73% whereas txload and rxload from "show int atm 0" do vary.

1 ACCEPTED SOLUTION

Accepted Solutions
paolo bevilacqua
Hall of Fame Master

Capacity is a static value so it's normal that never changes.

Config is basically correct, It seems very strange you''ve got such a low speed, have you tried with another router for comparison?

View solution in original post

3 REPLIES 3
paolo bevilacqua
Hall of Fame Master

Capacity is a static value so it's normal that never changes.

Config is basically correct, It seems very strange you''ve got such a low speed, have you tried with another router for comparison?

View solution in original post

Very red faced!

It seems that the same day I swapped in the cisco router the ISP bandwidth limited the account.  The router config works fine now that is fixed.

Thanks for looking at it and sorry to trouble you over nothing.

Not embarassing at all.

Thank you for the nice rating and good luck!