09-02-2014 04:03 AM
I am currently trying to setup a Cisco SG300 switch with a hosted VoIP solution using the SG300's at the customer's premise. The Yealink phones I am not able to get them to pull an IP address and believe the problem is related to LLDP. We also use Polycom phones and they work just fine. Here is the configuration that I am currently using ( I have tried several different configurations and none of them work with the Yealinks. Any help would be greatly appreciated.
DLC#show run
config-file-header
DLC
v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0
set system mode switch
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 2,88
exit
voice vlan id 88
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
hostname DLC
!
interface vlan 2
name Data
!
interface vlan 88
name FlexVoice
!
interface gigabitethernet1
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet2
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet3
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet4
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet5
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet6
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet7
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet8
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet9
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet10
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet11
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet12
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet13
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet14
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet15
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet16
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet17
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet18
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet19
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet20
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet21
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet22
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet23
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet24
switchport trunk allowed vlan add 88
switchport trunk native vlan 2
no macro auto smartport
!
interface gigabitethernet27
switchport mode access
switchport access untagged vlan 2
no macro auto smartport
!
interface gigabitethernet28
switchport mode access
switchport access untagged vlan 88
no macro auto smartport
!
exit
DLC#
09-02-2014 06:20 PM
I think no macro auto smartport is preventing the phones from getting voice VLAN assignment.
09-02-2014 07:49 PM
Hi,
You need to add the Yealink phones OUI into voice Telephony oui-table:
Refer from page:211(use the below link)
http://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/78-19308-01.pdf
--------------------------------------------
I have attached the GUI options also
regards
Moorthy
09-03-2014 01:15 PM
Here is the latest configuration that I tried, Polycom phone worked, Yealink didn't.
co-test#show run
config-file-header
co-test
v1.4.0.88 / R800_NIK_1_4_194_194
CLI v1.0
set system mode switch
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 2,88,881
exit
voice vlan id 88
voice vlan state oui-enabled
voice vlan cos 6 remark
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 0004f2 Polycom
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001565 Yealink
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
hostname co-test
!
interface vlan 2
name data
!
interface vlan 88
name flexvoice
ip address 172.16.88.2 255.255.255.0
no ip address dhcp
!
interface gigabitethernet1
voice vlan enable
!
interface gigabitethernet2
voice vlan enable
!
interface gigabitethernet3
voice vlan enable
!
interface gigabitethernet4
voice vlan enable
!
interface gigabitethernet5
voice vlan enable
!
interface gigabitethernet6
voice vlan enable
!
interface gigabitethernet7
voice vlan enable
!
interface gigabitethernet8
voice vlan enable
!
interface gigabitethernet9
voice vlan enable
!
interface gigabitethernet10
voice vlan enable
!
interface gigabitethernet11
voice vlan enable
!
interface gigabitethernet12
voice vlan enable
!
interface gigabitethernet13
voice vlan enable
!
interface gigabitethernet14
voice vlan enable
!
interface gigabitethernet15
voice vlan enable
!
interface gigabitethernet16
voice vlan enable
!
interface gigabitethernet17
voice vlan enable
!
interface gigabitethernet18
voice vlan enable
!
interface gigabitethernet19
voice vlan enable
!
interface gigabitethernet20
voice vlan enable
!
interface gigabitethernet21
voice vlan enable
!
interface gigabitethernet22
voice vlan enable
!
interface gigabitethernet23
voice vlan enable
!
interface gigabitethernet24
voice vlan enable
!
interface gigabitethernet27
switchport mode access
switchport access vlan 2
no macro auto smartport
!
interface gigabitethernet28
switchport mode access
switchport access vlan 88
no macro auto smartport
!
exit
co-test#
09-03-2014 01:27 PM
Do you know how your Polycom phones get their voice VLAN? OUI, CDP, LLDP, hard coded?
I can tell you that if you default this switch and enter command: voice vlan id 88
then plug in a default Yealink phone it will get voice VLAN via LLDP and the switch port will be auto configured via smartport macro.
09-04-2014 04:53 AM
Hi Thermel31,
I have no Yealink in my lab but I have seen such an issue before. I know that for OUI voice vlan LLDP is needed but somehow Yealink LLDP does not really help and phone stays in the data vlan. I would recommend you to open ticket with Cisco Small Business Support team:
http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html
Regards,
Aleksandra
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide