cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
899
Views
0
Helpful
9
Replies

1841 config question

mjames_wdd
Level 1
Level 1

i'm trying to get my router configured, and seem to be missing something.  feels like it's something easy, but i just can't see it.

here's what is working/not working right now:

- from the router, i can ping a.b.c.177, which is the next hop (a business class cable modem/router from comcast)

- from the router, i can ping a.b.c.190, which is the outside of the cable modem/router from comcast

- from the router, i can ping google.com

- from the router, i can ping 192.168.3.2, which is the computer that i'm working from

- from the router, i cannot ping a.b.c.177 (or anything else) if i specify the source as 192.168.3.1

- from the pc, i can ping 192.168.3.1

- from the pc, i cannot ping anything else (the comcast modem, google, etc)

- if i remove my cisco router, and put the pc in it's place with a.b.c.178 as it's ip address, everything works fine - ping, internet, etc.  this makes me think the comcast router is working properly.

i'd appreciate any help anyone could provide.  the router was in place between two other networks in the past, so i may still have some old setting that's getting in my way.  that network did use the s0/0/0 port, so that could be getting me as well.

thanks - matt

============================

sho run
Building configuration...

Current configuration : 1482 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname <omitted>
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip cef
!
!
no ip dhcp use vrf connected
!
!
!
username <omitted>
!
!
!
interface FastEthernet0/0
ip address A.B.C.178 255.255.255.240
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
description $ES_LAN$
ip address 192.168.3.1 255.255.254.0
duplex auto
speed auto
!
interface Serial0/0/0
bandwidth 1536
no ip address
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation ppp
no ip mroute-cache
shutdown
service-module t1 timeslots 1-24
service-module t1 remote-alarm-enable
service-module t1 fdl both
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 A.B.C.177
ip route 192.168.2.0 255.255.254.0 FastEthernet0/1
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
no cdp run
!
control-plane
!
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
end

1 Accepted Solution

Accepted Solutions

johnlloyd_13
Level 9
Level 9

Hi,

Try adding NAT and test again

int f0/0

ip nat out

int f0/1

ip nat in

ip nat inside source list 100 int f0/0 overload

access-list 100 permit 192.168.3.0 0.0.1.255 any

View solution in original post

9 Replies 9

Mahesh Gohil
Level 7
Level 7

Hello ,

When you ping google or  a.b.c.177 the source it takes as A.B.C.178 and when you ping with  source ip as 192.168.3.1and do not ping it means

a.b.c.177 is not having idea what is 192.168.3.1 ..this is reverse route problem and problem is with the routing with the device installed at a.b.c.177.

you can put static route at .177 for network 192.168.3.0 toward your .178 ip and see the results

Regards

Mahesh

this had no effect.  after adding the static route, ping google.com source 192.168.3.1 still timed out.

an additional piece of info - i also tried "traceroute google.com source 192.168.3.1", and it didn't even get to the first hop.

thanks - matt

hi,

need below

> which device at a.b.c.177

> config of that device

> sh ip route from your router as well as of device (.177)

regards

mahesh

the device at a.b.c.177 is an SMC D3G that comcast left when they installed the internet.  i don't have a lot of options for getting a configuration.  all i can get to is a web interface that shows some of the details.

as for the "sh ip route", the 1841 is configured as such:

Gateway of last resort is a.b.c.177 to network 0.0.0.0

     a.b.0.0/28 is subnetted, 1 subnets
C       a.b.c.176 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via a.b.c.177

i don't know what happened to the internal subnet - it was there in the past.  there was a line that said "C 192.168.2.0 is directly connected, FastEthernet0/1".  but, it's gone now.  the route is still in the sh run, however.  ip route 192.168.2.0 255.255.254.0 FastEthernet0/1.

hi,

It is for sure that problem is with comcast config and not 1841..you should try with remote end only

Regards

Mahesh

johnlloyd_13
Level 9
Level 9

Hi,

Try adding NAT and test again

int f0/0

ip nat out

int f0/1

ip nat in

ip nat inside source list 100 int f0/0 overload

access-list 100 permit 192.168.3.0 0.0.1.255 any

this appears to have worked.  if you could provide me with some info on why it was needed, i'd appreciate it.  i've put some other routers in place in the office before, and never needed that.  maybe it had to do with having more access to the 'next hop' router, i don't know, but this is the first time that i've had to nat my way through a router.

thanks for the help!  if you could now help with a little education for me, that would be great!

matt

Hi,

The machine on your LAN is on a private subnet(192.168.x.x) which is not routeable on the internet so you have to NAT to a public IP address like the one on your interface towards your Comcast so each time you communicate with the internet your source IP is NATed to a public IP which internet routers can reply back to.

Regards.

Alain.

Don't forget to rate helpful posts.

hi,

glad to know it works. further adding to your issue:


- if i remove my cisco router, and put the pc in it's place with a.b.c.178 as it's ip address, everything works fine - ping, internet, etc.  this makes me think the comcast router is working properly.

you've assigned your PC a public IP  a.b.c.178 which is routable on the public network.

Review Cisco Networking products for a $25 gift card