12-02-2006 01:41 PM - edited 03-05-2019 01:08 PM
I have a 3750 stack connected to another 3750 stack using 2 - 100mb links. I wanted to use an etherchannel to combine the bandwidth to be 200mb/s as well as for redundancy in case one link went down or one of the switches went down. I have a port channel defined trunking the vlans I want and have the 2 ports on each switch in the port channel. Because they are cross stack etherchannels, I have to use channel-group # mode ON so I can't use LACP or PAGP. When I remove one link, it doesn't automatically failover to the remaining link. I have read a ton of info on the website, but don't know what I am missing. Do I have to go back and have both ports on one switch instead of having it cross stack?
12-02-2006 01:48 PM
Hello,
Can you please post the configuration of the switch i.e., sh run so we can better diagnose your issue to help you.
Thanks
12-02-2006 02:37 PM
It should failover , an etherchannel is considered one link and traffic just gets shared across both channels , if one goes away then it should just flow across the remaining one . Did you check that both ports were channeling before pulling the one link with the show etherchannel summary and show etherchannel detail commands ? . You do have the stack cables in the back connected correct ? Just looking for the easy stuff first . As the other poster said , the config would help for the etherchannel and the connecting ports themselves on both boxes and both sides . Also maybe post a show switch detail command . Also verify the trunk is working correctly with the show int trunk command and verify what is being allowed across the trunk is the same on both sides of the link .
12-03-2006 08:26 PM
My config is as TAC and the website examples show:
Switch 1 running 3750-IPBASEK9-M, Version 12.2(25)SEE2
hostname CMT-ASE
!
switch 1 provision ws-c3750g-24ps
switch 2 provision ws-c3750g-24ps
switch 3 provision ws-c3750g-24ps
switch 4 provision ws-c3750g-24ps
spanning-tree mode rapid-pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
description ASE trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
!
interface GigabitEthernet1/0/1
description 2230-1
switchport access vlan 22
switchport mode access
switchport voice vlan 701
mls qos trust cos
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/24
description ASE-22 floor
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
speed 100
duplex full
no mdix auto
channel-group 1 mode on
!
interface GigabitEthernet2/0/24
description ASE-22 floor
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
speed 100
duplex full
no mdix auto
channel-group 1 mode on
!
!
end
and the switch on the other end of the 2-100mb links
C3750-IPBASEK9-M, Version 12.2(25)SEB
version 12.2
hostname 34-35
switch 1 provision ws-c3750-24p
switch 2 provision ws-c3750-24p
switch 3 provision ws-c3750-24p
switch 4 provision ws-c3750g-24ps
switch 5 provision ws-c3750-24p
!
spanning-tree mode rapid-pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Port-channel6
description ASE - 22floor
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
duplex full
speed 100
!
!
interface FastEthernet3/0/23
description ASE - 22floor
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
duplex full
speed 100
no mdix auto
channel-group 6 mode on
!
!
interface GigabitEthernet4/0/23
description ASE - 22floor
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
duplex full
speed 100
no mdix auto
channel-group 6 mode on
!
!
interface Vlan1
ip address 172.16.255.6 255.255.255.0
!
ip classless
no ip http server
ip http secure-server
!
logging 10.0.1.101
access-list 102 remark SSH Access
34-35#
12-04-2006 04:46 AM
You should take the settings "channel-group 6 mode active".
From Cisco.com "PAgP cannot be enabled on cross-stack EtherChannels while LACP is supported on cross-stack EtherChannels from Cisco IOS Software Release 12.2(25)SEC and later. "
LACP = mode active
PAGP = mode on
12-04-2006 07:51 AM
Don't thnik so.
mode on - not mean that pagp will take place.
as you say: "PAgP cannot be enabled on cross-stack EtherChannels"
In on mode, a usable EtherChannel exists only when both connected port
groups are in the on mode.
I have similar configuration (mode on used) and all work fine.
But i'am use ISL encapsulation on trunk. Maybe there is problem.
12-04-2006 07:56 AM
Try to not create PortChannel first.
When you issue "channel-group" command portchannel will be created automaticaly. Try to make ALL configuaration on GigabitEthernet and with last command isuue "channel-group".
And you will be shure that all config from GigabitEthernet interface transfered to PortChannel interface.
12-04-2006 09:06 AM
I upgraded the switch on one side so they were both at 12.2.25 SEE2, so now the etherchannel comes up with LACP (channel-group mode active). Still, when I unplug one connection on the etherchannel, I lose connection and the traffic isn't immediately forwarded to the member that is still up.
12-04-2006 09:49 AM
How are you testing to see if the connection is working or not when you pull one side ???
12-04-2006 12:04 PM
I have a laptop over at the remote location pinging a server in the datacenter across the link. With both interfaces in the etherchannel connected, pings go through. I then pull the cable or shut one connection and my pings keep going so that means that through the source mac load balancing, I am using the other interface that is up. Then I put the connection back, wait a couple minutes and then pull the other connection. My pings to the other side then stop, after a minute or so I put the connection back and my pings resume. From other etherchannels I have done, it should failover with maybe 1 or 2 pings dropped.
12-10-2006 08:10 PM
I have exactly the same issue.
My IOS version is c3750-ipservices-mz.122-25.SED1.bin.
At the beginning I set both sides as 'mode on', when one link fails traffic fails to switch to the other link.
Then I configured both sides to use LACP 'mode active', it did work. But the failover takes around one minute.(customer is not happy about this one min outage)
In my setup, my both 100M links are metro ethernet links instead of direct inhouse cables. When one side fails, Ethernet
provider doesn't pass the signal over to the other side. So the other side remains up without knowing far end is down. Hence
Etherchannel still keep sending packets to both interfaces according to its hashing algorithm. After I configured LACP, LACP detects
the failure in about one minute and brings down the interface on the other end.
Just curious to know if you also get Metro Ethernet connections in between.
I can't see any option available for me to tune down the timer in LACP neigotiation altough some command output does show fast/slow LACP. Would be happy to know if anyone from Cisco is able to answer this question.
12-11-2006 07:17 AM
Hi David,
Try using UDLD. http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_guide_chapter09186a00805a6510.html
Its not really meant to detect this, but it may well do as it is based on a Mcast frame on the wire to the other end.
12-14-2006 03:00 AM
It confused me.. So I tried it myself in a lab. I use mode active in a cross stack environment. It works perfectly. When I take a look at your config I see a speed setting at the portchannel interface. I tried it and now I have the same issue. Remove it to see if that is your solution. And LACP is the way to go. The other way is manual and that one is prone to errors. (forgive my english)
12-14-2006 06:54 AM
Thanks for trying it in a lab, I don't have extra switches. I found one problem was with one of my 100mb links. Anyways, the last time I tried it, this was my config for the portchannel:
interface Port-channel6
description ASE-22 floor
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,22,701,997,1002-1005
switchport mode trunk
switchport nonegotiate
end
It didn't seem to make much difference for me. I still have faster failover if I just use 2 trunks with STP blocking one and don't use the portchannel-whether it is mode active or mode on.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide