Showing results for 
Search instead for 
Did you mean: 

3750 recovery BAUD setting


So I had to format flash and recover. I did the quicker way by using set BAUD 115200...once the .bin was across I forgot to set the baud back to 9600. I have followed instructions: go back to switch: set BAUD 9600 then reset. also tried the unset command. problem is it always comes back up with a BAUD of 115200. Can someone tell me wahat I am doing wrong? Will I have to label 1 switch as 115200?


48 Replies 48

Keep us posted.      

I know this is old but I never did find a way to reset the baud. I just labeled the switch for future configuration.

Thanks for all replies!

The unset does not work. There are bugs in certain versions that do not allow you to go back and change the baud rate.

I tried the unset command and all it did was completely screw me up. I couldn't even get a single baud rate to work. All i'm seeing is a bunch of symbols.... even in recovery mode

May try update rommon so to circumvent bugs.

What I did was start up a different terminal program (hyper terminal) was using Secure Crt and was able to change the baud rate back.

The bug report actually says there is no work around and no plans on fixing it lol

Thank you very much Peter,

this helped me to recover CAT2960 after IOS recovery at 115200

the boot process was showing correctlu at 9600 but as soon as it finished booting and "Press ENTER to continue" it switched to 115200

after this it worked just as I expected


richard bedwell

I don't know what version of switch you have, but I have just done this on a 3750 48 port switch, I am currently moving the bin file to the device using 115200, I have tested how to set and 'unset' this, and I simply use the following....

set BAUD 115200

to go back I use

set BAUD 9600

it has worked immediately both ways. I have tried several times, reloading and not reloading. The effert is immediate, but you have to be at the

'switch: '


I have done this both with putty, and with Hyper Terminal.


Posting just to list what worked for me.

I have a 3750G with the same problem. 

I had sped up one last week to 115200 to copy over a *.bin and then set it back to 9600 with no problems.

Today I found a switch in our spares that is set to 115200.  I tried to change the speed at the Console port and after reboot found it went back to 115200.

So, I tried what BlackHawk08 suggested, in another post, by going into ROMMON by holding down the mode button during boot.  The set BAUD 9600 did not work.  But the unset BAUD did work.  I then did flash_init waited and then type boot and waited.  The switch rebooted and came up at 9600.  I then did a show run and the Console port is no longer at 115200. 

So, I've been able to change the speed on a switch to copy the IOS over and set back successfully and fix a switch that had been changed to 115200.



I know I'm posting a year after from the beginning of this threat but. I came looking the answer to my problem which was almost the same. I got scared after reading that there was nothing that can be done. But I found this and it helped me at least.

Using the Cisco IOS Software speed Command

Switch(config)#line con 0
Switch(config-line)#speed 9600

I hope this helps someone.


Enamnuel Leon - That works but once you wri mem and reboot it, it loses speed connection.


I'm probably out of context here. But in my case it worked. I trying this on an old Catalyst 3500 XL. I wouldn't let me change the BAUD rate back to 9600. Every time I thought I changed it I got the message about the "loggin port" so I had to change back to 115200 which is what I had set at one point. But again, I ran "reload" after saving the config file, and also physicly unplugged the switch. Now it works perfectly. Again, I'm might be out of context here and I apologize if I am, but by reading the threat it looked to me that it was a very similar problem.

I was doing mine on a 3750. I think I found a workaround but I don't recall what it was..

and you are fine I was just stating what I remember happened when I did it. In the end I rather have just copied slow


boot your switch and use the following:

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#line con

Switch(config)#line console 0

Switch(config-line)#speed 9600( change your baud rate on ur putty back to 9600 after this command as it will go blank)



I did with a 3560ps.

Just two command in rommon

set BAUD 9600

Then after reboot it recover to 9600.

Sent from Cisco Technical Support iPhone App

I had the same problem where my WS-C3750-48TS with a Version 12.2(44)SE5 bootloader kept reverting back to 115200 after I'd used that baud rate for an XModem transfer a new IOS. chuang123's solution worked with no problems.


set BAUD 9600


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers