07-05-2014 06:21 PM - edited 03-07-2019 07:56 PM
I'm having a bit of a brain fart. I have a 3750G that is a core switch for a very small business network. On the switch I have a few vlans, i.e. vlan10, vlan20, vlan30, etc. Each vlan has int vlan10 ip address 10.0.10.1 255.255.255.0 no shut (subsequently for the other vlans). I have another 3750G that I want to use in another room to extend the network core to this room. I configured both ports gi1/0/1 as trunk ports, connected the switches via CAT6. The second switch picked up the VLAN information, but here's where I'm having a problem. The second switch isn't showing the vlan interface ip addresses assigned, and I can't ping the vlan interface ip's of the original switch. I have ip-routing option as well as made sure to no shut vlan interface. I do not think I have ip default-gateway set as there is no access to anything outside this contained network as of yet. Creating a new vlan works, and the second switch picks it up, however not the clan interface. I can provide running configs if needed. Can someone provide some assistance? Thanks.
Regards,
SK
Solved! Go to Solution.
07-10-2014 02:08 AM
Ok, the IP's seem fine.
Transparent—VTP transparent switches do not participate in VTP. A VTP transparent switch does not advertise its VLAN configuration and does not synchronize its VLAN configuration based on received advertisements, but transparent switches do forward VTP advertisements that they receive out their trunk ports in VTP Version 2.
I would do the following.
1. Disconnect the cable connecting the switches.
2. Change core switch to VTP operating mode server
3. Change 2nd switch to VTP operating mode client
4. Connect the cable
Also, make sure if there is a VTP password set it's the same on both switches.
07-05-2014 07:00 PM
Can you post "sh run inter gi1/0/1" and sh vlan from both switches?
Also, can you make sure that the VTP mode is transparent for both switches.
config t
vtp mode transparent
Are the vlan interfaces up and running on the first switch?
Example:
sh ip int brief vlan 10
also sh run int vlan 10
for testing, do you have a host connected to one of the vlans?
HTH
07-05-2014 09:48 PM
Hi, Thanks for the reply. I made sure the vtp mode is transparent on both switches. I do have a host connected to one of the vlans for testing.
The output is below:
switch a, main switch:
WASH-CRS02#sh run int gi1/0/1
Building configuration...
Current configuration : 99 bytes
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
end
WASH-CRS02#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
10 <<INT_LAN>> active
20 <<vSphere_Mgt>> active
50 <<Wireless_LAN>> active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
50 enet 100050 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
WASH-CRS02#sh ip int brief vlan 10
Interface IP-Address OK? Method Status Protocol
Vlan10 10.0.10.1 YES manual up up
WASH-CRS02#sh run int vlan 10
Building configuration...
Current configuration : 60 bytes
!
interface Vlan10
ip address 10.0.10.1 255.255.255.0
end
WASH-CRS01>en
Password:
WASH-CRS01#sh ip int brief vlan 10
Interface IP-Address OK? Method Status Protocol
Vlan10 unassigned YES manual up up
WASH-CRS01#sh run int vlan 10
Building configuration...
Current configuration : 39 bytes
!
interface Vlan10
no ip address
end
WASH-CRS01#
WASH-CRS02#[SERIAL/DIRECT] INFO: DISCONNECTED
Here's the output from switch B, not showing vlan10 IP information and I can't ping from switch a:
WASH-CRS01#sh run inter gi
WASH-CRS01#sh run inter gigabitEthernet1/0/1
Building configuration...
Current configuration : 99 bytes
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
end
WASH-CRS01#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/49, Gi1/0/50, Gi1/0/51, Gi1/0/52
10 <<INT_LAN>> active
20 <<vSphere_Mgt>> active
50 <<Wireless_LAN>> active Gi1/0/46, Gi1/0/47, Gi1/0/48
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
50 enet 100050 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
WASH-CRS01#
07-06-2014 08:29 AM
Ok, to what port the host is connected and what switch?
on WASH-CRS02 I don't see any port in your vlans
for example if your host is connected to port 1/0/15 and needs to be in vlan 10, you need to add this port to vlan 10
config t
inter gi1/0/10
switchport
switchport mode access
switchport access vlan 10
exit
then try pinging from host to 10.0.10.1
HTH
07-06-2014 10:58 AM
I noticed that, I forgot to enable the port before copying the output of the commands. I had a host connected and in vlan10 on port gig/0/4.
I started over. I wiped all the vlan and interface info from both switches, wrote memory, and copied running to startup. I ensured the VTP was configured the same on both switches, set to version 2, transparent mode, same domain and password. Port's gi1/0/1 on both switches are trunk port and connected.
WASH-CRS02 is my main server switch. I issued the following commands after both switches booted to create vlan10 and the vlan interface and put gi1/0/4 in access mode on that vlan:
config t
vlan10
name vlan10 <<INT_LAN>>
int vlan10
ip address 10.0.10.1 255.255.255.0
no shut
int gi1/0/4
switchport
switchport mode access
switchport access vlan 10
no shut
end
The second switch, WASH-CRS01 did not receive the vlan on it's switch? The client from WASH-CRS02, connected to gi1/0/4 vlan 10 with IP: 10.0.10.100 SN: 255.255.255.0 GW:10.0.10.1 can't pint client connected to WASH-CRS01 switch gi1/0/5 vlan 10 with IP: 10.0.10.101 SN: 255.255.255.0 GW: 10.0.10.1 WASH-CRS01 doesn't have vlan 10 on the switch?
Should the vtp be a different version, or both in server mode, or one server and client? while in config t int vlan10, does that need vtp command? Thanks for the continued help. I have done this a zillion times, but I'm stumped on these switches.
-SK
07-06-2014 11:43 AM
I noticed that, I forgot to enable the port before copying the output of the commands. I had a host connected and in vlan10 on port gig/0/4.
ok, test #1
Can you ping from the host to the default gateway (10.0.10.1)?
Can you ping from WASH-CRS02 to the host?
BTW, make sure the host does not have firewall software that can prevent it from being pinged.
Also, you want both switch to be in transparent mode which is =to no VTP. It should not matter what the version is.
also can you post sh ver from WASH-CRS01?
07-06-2014 09:25 PM
I can ping from the host, 10.0.10.101 to the gateway (10.0.10.1) successfully. I can also ping from WASH-CRS02 to the host successfully. I do not have any firewalls running on client's / servers preventing a ping response. The client is connected to WASH-CRS02 gi1/0/5.
Switch WASH-CRS01 still isn't showing any vlan information from vlan10 that I created on WASH-CRS02.
Both switches are in transparent mode, I believe version 2, but as you said that doesn't matter.
Here's the output from sh ver WASH-CRS01:
WASH-CRS01#sh ver
Cisco IOS Software, C3750 Software (C3750-IPSERVICESK9-M), Version 12.2(55)SE1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Thu 02-Dec-10 07:46 by prod_rel_team
Image text-base: 0x01000000, data-base: 0x02F00000
ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(44)SE5, RELEASE SOFTWARE (fc1)
WASH-CRS01 uptime is 10 hours, 44 minutes
System returned to ROM by power-on
System image file is "flash:c3750-ipservicesk9-mz.122-55.SE1/c3750-ipservicesk9-mz.122-55.SE1.bin"
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
export@cisco.com.
cisco WS-C3750G-48TS (PowerPC405) processor (revision C0) with 131072K bytes of memory.
Processor board ID FOC1038Z046
Last reset from power-on
1 Virtual Ethernet interface
52 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.
512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 00:19:56:27:59:80
Motherboard assembly number : 73-9366-08
Power supply part number : 341-0107-01
Motherboard serial number :
Power supply serial number :
Model revision number : C0
Motherboard revision number : A0
Model number : WS-C3750G-48TS-E
System serial number :
SFP Module assembly part number : 73-7757-03
SFP Module revision Number : A0
SFP Module serial number : CAT10325PVA
Top Assembly Part Number : 800-26345-02
Top Assembly Revision Number : B0
Version ID : V02
CLEI Code Number : CNMWP00ARB
Hardware Board Revision Number : 0x05
Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 52 WS-C3750G-48TS 12.2(55)SE1 C3750-IPSERVICESK9-M
Configuration register is 0xF
WASH-CRS01#
07-07-2014 04:29 PM
Still no VLAN info has been propogated to the other switch.
-SK
07-08-2014 03:56 PM
Not sure if I've read something wrong here but you need to assign the 2nd switch an IP address on the required SVI so probably 'int vlan 10', which will be used for management. Only the core switch needs an IP on each SVI.
Are you also having a problem with VTP? If all the VLANs have gone across I'd say it's working fine. But you can post 'show VTP status' from each switch.
07-09-2014 03:43 PM
I'm not sure I understand the first statement? On the second switch in global configuration I entered:
int vlan 10
ip address 10.0.10.2. 255.255.255.0
no shut
The core switch I have only has vlan10 IP address 10.0.10.1 255.255.255.0 Int gi1/0/1 on both the core switch and the 2nd is configured switchport trunk.
I don't think that VTP is working. I'm not getting any vlan information from the core switch on the second switch. Here's the vtp status from both switches. WASH-CRS02 is my main switch:
WASH-CRS02#sh vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 001b.532f.9e80
Configuration last modified by 0.0.0.0 at 3-2-93 05:42:53
Feature VLAN:
--------------
VTP Operating Mode : Transparent
Maximum VLANs supported locally : 1005
Number of existing VLANs : 6
Configuration Revision : 0
MD5 digest : 0x86 0xE2 0x6D 0xEA 0x82 0xA9 0xBD 0xAF
0x96 0x42 0x61 0xE1 0x82 0x7B 0x9E 0xBF
WASH-CRS02#
WASH-CRS01#sh vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 0019.5627.5980
Configuration last modified by 0.0.0.0 at 3-2-93 05:42:53
Feature VLAN:
--------------
VTP Operating Mode : Transparent
Maximum VLANs supported locally : 1005
Number of existing VLANs : 5
Configuration Revision : 0
MD5 digest : 0x1D 0x38 0x03 0xF0 0xCC 0x00 0x5C 0xDB
0xA5 0xB8 0xCC 0x70 0x1B 0x5D 0xE3 0xC6
WASH-CRS01#
07-10-2014 02:08 AM
Ok, the IP's seem fine.
Transparent—VTP transparent switches do not participate in VTP. A VTP transparent switch does not advertise its VLAN configuration and does not synchronize its VLAN configuration based on received advertisements, but transparent switches do forward VTP advertisements that they receive out their trunk ports in VTP Version 2.
I would do the following.
1. Disconnect the cable connecting the switches.
2. Change core switch to VTP operating mode server
3. Change 2nd switch to VTP operating mode client
4. Connect the cable
Also, make sure if there is a VTP password set it's the same on both switches.
07-11-2014 12:03 PM
Thanks for the info. I did just that. Turns out I had an MD5 mismatch and configuration revision was not correct. I got the core switch in server mode and the second switch in client. The VTP was operating correctly. I was able to get a vlan created on the core and it successfully made it to the second switch, and I could ping from one client on the second switch to a host connected to the core switch in a different vlan. Thanks for the assistance. I changed the second switch to server so that I could modify vlan info on that switch as well.
-SK
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide