Showing results for 
Search instead for 
Did you mean: 

3850 clear flash: space


I have a new Catalyst 3850 24T. I want to upgrade it to the latest IOS XE. I have uploaded the bin file, but it says it doesn't have enough space to extract it. I am new to XE, and I'm unfamiliar with all the things in flash: Does anyone know what is safe to delete to clear up some space for me? cat3k_caa-universalk9.16.03.07.SPA.bin is the one I'm trying to boot from.


Switch#dir flash:
Directory of flash:/

8094 -rwx 2097152 Jan 5 2019 00:41:30 +00:00 nvram_config
8083 -rw- 537489817 Jan 5 2019 00:31:33 +00:00 cat3k_caa-universalk9.16.03.07.SPA.bin
8086 -rwx 30418104 Sep 25 2014 07:53:39 +00:00 cat3k_caa-iosd-universalk9.SPA.150-1.EX3.pkg
8088 -rwx 64586444 Sep 25 2014 07:53:39 +00:00 cat3k_caa-wcm.SPA.
8096 -rw- 1237 Mar 11 2017 18:55:03 +00:00 packages.conf
8092 -rw- 1248 Apr 3 2015 11:08:35 +00:00 packages.conf.00-
40406 -rw- 34846028 Apr 3 2015 11:08:31 +00:00 cat3k_caa-iosd-universalk9.SPA.150-1.EZ5.pkg
40408 -rw- 77456192 Apr 3 2015 11:08:31 +00:00 cat3k_caa-wcm.SPA.
8090 -rw- 303772864 Mar 11 2017 18:49:07 +00:00 cat3k_caa-universalk9.SPA.03.06.06.E.152-2.E6.bin
8082 -rwx 1224 Sep 25 2014 07:53:49 +00:00 packages.conf.01-
8097 -rw- 83293932 Mar 11 2017 18:54:58 +00:00 cat3k_caa-base.SPA.03.06.06E.pkg
8098 -rw- 3982012 Mar 11 2017 18:54:58 +00:00 cat3k_caa-drivers.SPA.03.06.06E.pkg
8099 -rw- 33788908 Mar 11 2017 18:54:58 +00:00 cat3k_caa-infra.SPA.03.06.06E.pkg
8100 -rw- 43074880 Mar 11 2017 18:54:58 +00:00 cat3k_caa-iosd-universalk9.SPA.152-2.E6.pkg
8101 -rw- 28394380 Mar 11 2017 18:54:58 +00:00 cat3k_caa-platform.SPA.03.06.06E.pkg
8102 -rw- 111233856 Mar 11 2017 18:54:59 +00:00 cat3k_caa-wcm.SPA.
8095 drwx 4096 Nov 9 2018 14:12:14 +00:00 dc_profile_dir

1562509312 bytes total (204087296 bytes free)





Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

The files are OK to delete, however, use the "software clean" command to remove them properly.

I'm not sure I understand. Are you saying just run "software clean" and it will delete everything that's not used? Will that delete the file I just uploaded? For some reason it took a really long time to upload it and I'd prefer not to erase it.


Do I delete files manually until I have enough space to boot to the new software, then run "software clean"?


If so, which files can I delete? It is currently running 3.6.6. And as I said, I'm trying to get it to boot to cat3k_caa-universalk9.16.03.07.SPA.bin.


Thanks for your help.


the 'software clean' is like a macro command that automatically erase unnecessary package files. it's safe to run this command rather than deleting files manually.

see helpful link:


Switch#software clean     
Preparing clean operation ...
[1]: Cleaning up unnecessary package files
[1]: No path specified, will use booted path flash:packages.conf
[1]: Cleaning flash:
[1]: Preparing packages list to delete ...
     In use files, will not delete:
     Committed files, will not delete:
[1]: Files that will be deleted:

[1]: Do you want to proceed with the deletion? [yes/no]: yes
[1]: Clean up completed

VIP Guru VIP Guru
VIP Guru

Part of upgrade it will clean up proceedure. follow the below guide.



***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help


I am also going from 3.xE to Cisco IOS XE Denali. I ran out of space also and tried deleting all the files I could with the 'software clean' but it wasn't enough as I still need another 400mB. Cisco TAC stated you can erase all .pkg for current version and it won't cause an outage as long as you upgrade with the newly freed up space before any power outage.


So steps is to erase any .pkg files from the current booted version, then upgrade to v16, then check to insure all the newest v16 .pkg files are present, then reboot so the bootvar changes to the new version.


copy and paste from TAC:

"Deleting the 03.06.06E .pkg files won't cause any problems till the time you reload the switch. Make sure the 16.03.07 installation is successful and you have the .pkg files for 16.03.07 in flash before reloading the switch."

As Long as Switches not rebooted when you deleted the image, you are fine.


If you worried, then other approach and safe for you is -  copy the new image to USB flash, Boot from USB Flash test all working, then clean up for space and install new image.


make sense ?




***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

make sure its in install mode going from 3.x to 16.3
i had to convert my switches first , if its in bundle the bootloader may not update and brick itself , its in the release notes of 16.3

This is how i did it going from 3.x to Denali without any issues

A if switch is in bundle mode convert it to install mode – if already install you can move direct to section B
1 Check switch is in bundle mode in show version * 1 52 WS-C3650-48PS 03.06.07b.E cat3k_caa-universalk9 BUNDLE
2 Clean the flash with software command - software clean file flash:
3 Check flash is cleaned old images are removed
4 Re-added original .bin 3.6.7b from USB to local flash - copy usbflash0:cat3k_caa-universalk9.SPA.03.06.07b.E.152-2.E7b.bin flash:
5 Expand the software - software expand file flash:cat3k_caa-universalk9.SPA.03.06.07b.E.152-2.E7b.bin
6 Set the bootvar to packages and save -- boot system flash:packages.conf
7 Confirm Boot is – show boot - BOOT variable = flash:packages.conf;
8 Save and Reload

B Switch is now ready for Denali upgrade
1 Check switch is in Install mode in show version * 1 52 WS-C3650-48PS 03.06.07b.E cat3k_caa-universalk9 INSTALL
2 Copy Denali from USB to flash - copy usbflash0:cat3k_caa-universalk9.16.03.07.SPA.bin flash:
3 Use software install force command to push package - software install file flash:cat3k_caa-universalk9.16.03.07.SPA.bin new force
4 Accept reload after packages removed added through install - Do you want to proceed with reload? [yes/no]: yes
5 Confirm Denali is in place and in INSTALL mode with show ver - * 1 52 WS-C3650-48PS 16.3.7 CAT3K_CAA-UNIVERSALK9 INSTALL

If its a remote upgrade you will lose the cipher and RSA ssh wont work after upgrade , apply this first to the switch if its remote it will generate new SSH keys when rebooting with new image

event manager applet Xilinx_SSH_RSA_Generate
event timer cron cron-entry "@reboot"
action 0.0 info type routername
action 0.1 set status "none"
action 1.0 cli command "enable"
action 2.0 cli command "show ip ssh | include ^SSH"
action 2.1 regexp "([ED][^ ]+)" "$_cli_result" result status
action 3.0 if $status eq "Disabled"
action 3.1 cli command "configure terminal"
action 3.2 cli command "crypto key generate rsa modulus 2048 label $_info_routername"
action 3.3 cli command "end"
action 3.4 end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: