Showing results for 
Search instead for 
Did you mean: 

7206VXR NPE400 keeps entering ROMmon after upgrade to 12.2(33)SRC3

Hi Sir,

I have a Cisco 7206VXR with NPE400. Its "sh version" is as follows:


Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-K4P-M), Version 12.0(31)S6, RELEASE SOFTWARE (fc1)

Technical Support:

Copyright (c) 1986-2006 by cisco Systems, Inc.

Compiled Wed 19-Jul-06 11:35 by leccese

Image text-base: 0x60008F3C, data-base: 0x616E6000

ROM: System Bootstrap, Version 12.2(4r)B2, RELEASE SOFTWARE (fc2)

BOOTLDR: 7200 Software (C7200-BOOT-M), Version 12.0(31)S6, RELEASE SOFTWARE (fc1)

C7206 uptime is 2 years, 4 weeks, 4 days, 23 hours, 43 minutes

System returned to ROM by power-on

System restarted at 13:58:19 GMT Mon Apr 16 2007

System image file is "disk0:c7200-k4p-mz.120-31.S6.bin"

cisco 7206VXR (NPE400) processor with 491520K/32768K bytes of memory.

Processor board ID 29812250

R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2 Cache

6 slot VXR midplane, Version 2.7

Last reset from power-on

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

Channelized E1, Version 1.0.

PCI bus mb0_mb1 (Slots 0, 1, 3 and 5) has a capacity of 600 bandwidth points.

Current configuration on bus mb0_mb1 has a total of 400 bandwidth points.

This configuration is within the PCI bus capacity and is supported.

PCI bus mb2 (Slots 2, 4, 6) has a capacity of 600 bandwidth points.

Current configuration on bus mb2 has a total of 200 bandwidth points

This configuration is within the PCI bus capacity and is supported.

Please refer to the following document "Cisco 7200 Series Port

Adaptor Hardware Configuration Guidelines" on CCO <>,

for c7200 bandwidth points oversubscription/usage guidelines.

2 FastEthernet/IEEE 802.3 interface(s)

4 Serial network interface(s)

8 Channelized E1/PRI port(s)

125K bytes of non-volatile configuration memory.

125952K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).

8192K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x2102

C7206#sh bootv

BOOT variable = disk0:c7200-k4p-mz.120-31.S6.bin,1;

CONFIG_FILE variable does not exist

BOOTLDR variable = bootflash:c7200-boot-mz.120-31.S6.bin

Configuration register is 0x2102


Its "boot" commands are as follows:

boot system flash disk0:c7200-k4p-mz.120-31.S6.bin

boot bootldr bootflash:c7200-boot-mz.120-31.S6.bin

I copied the following new IOS image and bootloader image to disk0:



And deleted the old boot commands and configured new boot commands to point to the above files.

Reloaded the router but it entered ROMmon mode. Manually booted the 12.2(33)SRC3 IOS; it could boot up. However the router keeps entering ROMmon mode each time it is reloaded or power cycled.

Anyone experienced this issue before? Please provide some pointers.

Thank you.


Lim TS


What command did you use to manually boot to the image?

Is that a new flash disk?

If it is, perhaps it needs to be formatted.



At the ROMmon prompt, I typed "confreg" and checked that the config register was correct - 0x2102. I executed "boot disk0:c7200-advipservicesk9-mz.122-33.SRC3.bin" and it booted into 12.2(33)SRC3. I just don't understand why it keeps going into ROMmon mode whenever it is reloaded or power cycled.

The "boot" commands in the running-config are:

boot system flash disk0:c7200-advipservicesk9-mz.122-33.SRC3.bin

boot bootldr disk0:c7200-boot-mz.122-33.SRC3.bin

No, it is an old flash disk. This router has been running on 12.0(31)S6 for two years. Only yesterday I attempted to upgrade it to 12.2(33)SRC3 but got stuck with the ROMmon issue. I did similar upgrade for several 7206VXR NPE-G1 and never faced this issue before.

Please advise.

Thank you.


Lim TS


I'm not sure, as I have not tried it myself, but I have the idea that some kind of IOS has to be in the bootflash: device in order to get the router up and running.

Have you tried to put the c7200-boot-mz.122-33.SRC3.bin image in bootflash: and have boot bootldr bootflash:c7200-boot-mz.122-33.SRC3.bin?

Let me know how it goes.



The bootflash: (7,602,176 bytes) has insufficient space to store the new IOS image (27,954,632 bytes) or the new bootldr image (7,659,504 bytes).

C7206#dir all

Directory of system:/

2 dr-x 0 memory

1 -rw- 9743 running-config

12 dr-x 0 vfiles

No space information available

Directory of nvram:/

115 -rw- 9709 startup-config

116 ---- 1956 private-config

117 -rw- 9709 underlying-config

1 ---- 32 persistent-data

2 -rw- 0 ifIndex-table

129016 bytes total (115251 bytes free)

Directory of disk0:/

1 -rw- 20021696 Feb 22 2006 08:02:50 +08:00 c7200-p-mz.123-14.T6.bin

2 -rw- 3812556 May 02 2006 17:59:44 +08:00 c7200-boot-mz.120-31.S4.bin

3 -rw- 10492320 May 02 2006 18:03:24 +08:00 c7200-k4p-mz.120-31.S4.bin

4 -rw- 10496460 Jun 21 2006 00:18:50 +08:00 c7200-k4p-mz.120-31.S5.bin

5 -rw- 10497856 Mar 16 2007 11:42:46 +08:00 c7200-k4p-mz.120-31.S6.bin

128659456 bytes total (73330688 bytes free)

Directory of bootflash:/

1 -rw- 3812812 Mar 16 2007 12:03:34 +08:00 c7200-boot-mz.120-31.S6.bin

7602176 bytes total (3789236 bytes free)

Directory of lex:/

No files in directory

No space information available


Thank you.


Lim TS


You do not need to upgrade the boot image. Leave what you have there.



I tried to remove any "boot bootldr" command from the config and only left with "boot system flash disk0:c7200-k4p-mz.120-31.S6.bin".

Still, it goes into ROMmon each time it is reloaded or power cycled.

I also tried to delete all unused images on disk0: and only left with the 12.2(33)SRC3 IOS image and bootloader image. Then I removed all "boot bootldr" and "boot system flash" commands from the config. The problem still persists.

Thank you.


Lim TS


Can you include a console log of a failed boot.


I don't see the image you are trying to boot to on disk0:



It looks to me that the boot variable is incorrect:

BOOT variable = disk0:c7200-k4p-mz.120-31.S6.bin,1;

I would put this image on disk0:


and add these lines to the config:


boot system disk0:c7200-advipservicesk9-mz.122-33.SRC3.bin




The outputs of "sh version", "sh bootvar", and "dir all" that I posted were before I copied the new IOS and bootloader images to disk0: and modified the boot commands.

Sorry for the confusion. There's no mistake here.

Thank you.


Lim TS



      you coped "c7200-k4p-mz.120-31.S6.bin" in Disk0: but as per my experince this should be copy in the flash:

Thats why router going to rommon mode also it is unable to boot with IOS.

Now please do i thing. arrange 1 new flash 128 MB or higher.

than install new IOS in disk0:

and this need to copy in flash "c7200-k4p-mz.120-31.S6.bin"

from Romman mode.

and run the boot command

as follow:

"boot disk0:c7200-advipservicesk9-mz.122-33.SRC3.bin"

than put enter...

hope your problem will resolve..



Content for Community-Ad