cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12985
Views
20
Helpful
29
Replies

9200 unable so Smart License due IPv6 name resolution??

soportefibratel
Beginner
Beginner

Hello everyone,

 

I'm having an issue with the Smart License registration on a 9200 Stack running Version 16.09.04. Altough in both the Core Switch (an old 4500) and the access switch I'm trying to register (9200) I have configured the same name servers, on the 9200 it's resolving the IPv6 address for Cisco, and thus, is unable to ping to it.

 

Below you can see how the core switch (rigth side) resolves IPv4 addresses, but the 9200 is resolving Cisco or Facebook with IPv6. I can ping all the IPv4 addresses from the 9200, but I'm unable to ping to the names if they are resolved with IPv6

Cisco Forum.png

 

I've disabled "ipv6 unicast-routing" and also entered "ip host cisco.com 72.163.4.185" on the 9200 but still no luck.

 

Any ideas would be welcomed

 

Thanks in advance

 

 

29 Replies 29

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Do you have IPv6 enable ? if so you can disable IPv6 - so IPv4 prefered - if i understand correctly

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi Balaji,

 

In addition to the "no ipv6 unicast routing" I added

no ipv6 enable

no ipv6 address dhcp
no ipv6 address autoconfig
no ipv6 dhcp client request vendor

With this now I can ping cisco.com, but not registering yet.

Cisco Forum2.png

Cisco Forum3.png



Hi Georg,

 

Its configured. I'v tried both the internal name server and 8.8.8.8. Also, they both resolve cisco.com, so the issue shouldn't be there.

 

Now it pings cisco resolving with IPv4, but when I try to register, this is what appears:

 

Registration:
Status: REGISTERING - REGISTRATION IN PROGRESS
Export-Controlled Functionality: NOT ALLOWED
Initial Registration: FAILED on Apr 20 07:49:14 2020 CEST
Failure reason: Fail to send out Call Home HTTP message.
Next Registration Attempt: Apr 20 08:53:27 2020 CEST

 

I followed this https://www.cisco.com/c/en/us/support/docs/switches/catalyst-9500-series-switches/214484-cisco-smart-licensing-troubleshooting.html#anc26 and when I telnet to tools.cisco.com on port 443, I see it is responding again via IPv6 (please refer to previous post)

Hello,

 

can you post the config of the switch ? What do you have configured as:

 

ip http client source-interface

 

and what does the call home configuration look like ?

Hello,

 

The requested outputs

Cisco Forum4.png

Hello,

 

can you ping 8.8.8.8 (or any other public IP address) when sourced from the Vlan 1 interface ? The idea  to specify the outgoing interface as the source interface:

 

ip http client source-interface external_facing_interface

Hi,

Vlan 1 is the only SVI, so all is sourced from that interface. I can ping external IP addresses. If you go to the first post you´ll see those tests.

I don´t know why even with Ipv6 disabled, the switch keeps resolving IPv6 for some things, like the telnet test, and probably the Smart License registration.

Also, try and specify http instead of https:

 

destination address http http://tools.cisco.com/its/service/oddce/services/DDCEService

Hi,

 

I don't think that will solve the issue. As you can see, when I telnet port 80, it's responding an IPv6 address

Cisco Forum5.png

 

Hi,

 

Just for the sake of trying, I edited the call-home profile, and it does't register with either https or http

Cisco Forum6.pngCisco Forum7.png

After each editing of the profile I entered the comand

license smart register idtoken <token> 

 

 

I think the issue is not related with the Smart Call Home configuration, I think the problem is with the IPv6 resolution of the address.

Hello,

 

I am starting to think that the problem might be with the portal itself. You could try and contact GLO at the numbers below:

 

https://www.cisco.com/c/en/us/support/web/tsd-cisco-worldwide-contacts.html

You also might want to check the troubleshooting tips below:

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/smart_call_home/book/SCH31_Ch5.html#wp1039677

Hi Georg,

I´ve just opened a case.

Regards
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers