11-29-2018 10:38 AM - edited 11-29-2018 10:46 AM
Hello. I'm trying to setup a Port-Channel (or EtherChannel) between my ASR 1000f Router and 3570X Switch.
I need to pass VLANs 10,20,30 & 40 over the Port-Channel (This is why I set the Switch ports as Trunks)
Need to confirm if this is the correct approach as the documentation can sometimes be a bit unclear.
Would you be so kind as to take a look below and advise if this is the correct approach and/or if i'm all wrong.
And provide direction/advice in order to achieve my goal.
Much appreciated :)
On ASR 1000 Router:
Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end
Router# configure terminal
Router(config)# interface gigabitethernet0/0
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end
Router# configure terminal
Router(config)# interface gigabitethernet0/1
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end
Router# write mem
The above should create a Port-Channel, assign an IP address of 192.168.1.1 and MASK of 255.255.255.0
to the Port-Channel itself. Then add Ports GigabitEthernet0/0 & GigabitEthernet0/1 to the Port-Channel as members.
Correct ??
On the 3750X Switch:
Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# end
Switch#
Switch# configure terminal
Switch(config)# interface range gigabitethernet1/0/49 - 50
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# switchport trunk encapsulation dot1Q
Switch(config-if-range)# switchport trunk native vlan 10
Switch(config-if-range)# switchport trunk allowed vlan 10,20.30.40
Switch(config-if-range)# channel-group 1 mode on
Switch(config-if-range)# exit
Switch(config)#end
Switch# write mem
The above should create a Port-Channel, Then add Ports GigabitEthernet1/0/49 & GigabitEthernet1/0/50 to the Port-Channel as members.
Then allow vlans 10,20,30 & 40 over the Port-Channel correct ??
Solved! Go to Solution.
11-30-2018 06:17 AM
11-29-2018 02:35 PM
Hello,
since you are creating a layer 3 port channel, the port channel interface on your 3750 needs an IP address. Also, with LACP, active - active is recommended, although active - on will work.
11-30-2018 06:14 AM
Hi there, cheers.
Thanks for the information, much appreciated. I have updated my config based on your input, Please take a quick look when you get a moment and confirm if this is right.
On ASR 1000 Router:
Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end
Router# configure terminal
Router(config)# interface gigabitethernet0/0
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end
Router# configure terminal
Router(config)# interface gigabitethernet0/1
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end
Router# write mem
The above should create a Port-Channel, assign an IP address of 192.168.1.1 and MASK of 255.255.255.0
to the Port-Channel itself. Then add Ports GigabitEthernet0/0 & GigabitEthernet0/1 to the Port-Channel as members.
Correct ??
On the 3750X Switch:
Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 192.168.1.2 255.255.255.0
Switch(config-if)# channel-group 1 mode active
Switch(config-if)# end
Switch#
Switch# configure terminal
Switch(config)# interface range gigabitethernet1/0/49 - 50
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# switchport trunk encapsulation dot1Q
Switch(config-if-range)# switchport trunk native vlan 10
Switch(config-if-range)# switchport trunk allowed vlan 10,20.30.40
Switch(config-if-range)# channel-group 1 mode active
Switch(config-if-range)# exit
Switch(config)#end
Switch# write mem
The above should create a Port-Channel, assign an IP address of 192.168.1.2 and MASK of 255.255.255.0
to the Port-Channel itself. Then add Ports GigabitEthernet1/0/49 & GigabitEthernet1/0/50 to the Port-Channel as members.
Correct ??
Thanks again
11-30-2018 06:17 AM
Hello,
looks perfect to me. Now you need to implement it...;)
11-30-2018 11:10 AM
12-07-2018 06:48 AM
Hi George and Experts
Still having some issues trying to get this Port Channel setup between my ASR 1002-F Router and 3750X Switch.
I have some VLANs on the Switch that I need to pass thru the Port Channel to the Router then out to the Internet.
This is why I have the ports setup as Trunks on the Switch. But I can't seem to establish a Port Channel connection. Perhaps you can assist. Here is the Configs.
Things i've tried to this point. I've gone thru the documentation on the Cisco website just to be sure I have the commands and concept right. I replaced the ethernet cables (just to ensure the cables are not the problem). I double checked that the "No Shut" command was entered on all the ports. But I can't help to think this is a configuration problem, so perhaps you experts can help :)
ASR 1002-F Router:
Interface Port-Channel1
Desc Port-Channel ASR to 3750
ip address 192.168.1.1 255.255.255.0
Interface GigabitEthernet0/0/2
Desc Port-Channel 1 Member
no ip address
duplex full
speed 1000
channel-group 1
Interface GigabitEthernet0/0/3
Desc Port-Channel 1 Member
no ip address
duplex full
speed 1000
channel-group 1
3750X Switch:
Interface Port-Channel1
Desc Port-Channel 3750 to ASR
switchport
switchport trunk allowed vlan 20,30,40,50,60
switchport mode trunk
Interface GigabitEthernet1/0/48
Desc Port-Channel 1 Member
switchport
switchport encapsulation dot1q
switchport trunk allowed vlan 20,30,40,50,60
switchport mode trunk
duplex full
speed 1000
channel-group 1 mode on
Interface GigabitEthernet1/0/49
Desc Port-Channel 1 Member
switchport
switchport encapsulation dot1q
switchport trunk allowed vlan 20,30,40,50,60
switchport mode trunk
duplex full
speed 1000
channel-group 1 mode on
12-08-2018 01:22 PM
Hello Community :)
Thanks for all the suggestions. I still continued to have problems getting the Port-Channel setup and working. After some additional serching and experimenting and testing, I finally got it to work. Here is an example of my configs in case anyone else
had the same or similar problem trying to setup a Port-Channel on the ASR 1002-F to connect to a 3750X Switch :)
Had to create Sub-Interfaces to the Port-Channel interface on the ASR Router
On the ASR 1002F Router:
interface Port-channel1
description Port-Channel to 3750 SW
no ip address
ip nat inside
negotiation auto
!
interface Port-channel1.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface Port-channel1.2
encapsulation dot1Q 20
ip address 192.168.2.1 255.255.255.0
ip nat inside
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/0/3
no ip address
negotiation auto
channel-group 1 mode active
On the 3750X Switch:
interface Port-channel1
description Port-Channel to ASR 1002-F Router
switchport trunk allowed vlan 1,20,30,40,50,60
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/48
description Port-Channel to ASR 1002F
switchport trunk allowed vlan 1,20,30,40,50,60
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/0/49
description Port-Channel to ASR 1002F
switchport trunk allowed vlan 1,20,30,40,50,60
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide