cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
807
Views
12
Helpful
10
Replies

Bridge a Catalyst 2900 XL (WS-C2924C-XL-EN)

ewf_cirda
Beginner
Beginner

Hi , i've recently got a 2900XL which is running very slow. The network traffic passing through is at very low speeds (2 mbps). I've tried to use a CNET switch instead of the 2900XL and the traffic is about 5 mbps. So , does anyone know how to configure this switch so that the network traffic will get a couple of mbps faster ?

1 Accepted Solution

Accepted Solutions

sounds like you should leave the switchports as auto for both speed and duplex .

View solution in original post

10 Replies 10

dave.keith
Beginner
Beginner

You may want to check for duplex mis-matches between the 2900XL and the devices attached to it ... just an idea.

Dave

Dave is correct check for that on all your ports . Any ports running full duplex should not be seeing any errors . Clear the counters and see if any ports are rapidly increasing errors .

Okay , cleared the counters and transfered a 244 mb file. No errors. I checked the duplex and all ports has full duplex. The CPU usage is:

CPU utilization for five seconds: 27%/5%; one minute: 27%; five minutes: 27%

Also good to know is that the console shows this everytime i boot up that switch:

C2900XL POST FAILURE: front-end post: FastEthernet0/1:

C2900XL POST FAILURE: looped-back packet not received

C2900XL POST FAILURE: front-end post: FastEthernet0/13:

C2900XL POST FAILURE: looped-back packet not received

C2900XL POST FAILURE: front-end post: FastEthernet0/14:

C2900XL POST FAILURE: looped-back packet not received

C2900XL POST FAILURE: front-end post: FastEthernet0/15:

C2900XL POST FAILURE: looped-back packet not received

C2900XL POST FAILURE: front-end post: FastEthernet0/16:

C2900XL POST FAILURE: looped-back packet not received

FOUND an unknown transceiver on port 13

00:00:14: %LINK-4-ERROR: is experiencing errors

FOUND an unknown transceiver on port 14

FOUND an unknown transceiver on port 15

FOUND an unknown transceiver on port 16

The ports 13,14,15,16 are not working , got no link when using them. But the others are working. I can post the config if anyone wants.

Its failing POST you need a new switch .

Yeah , i know but the switch is still working.

I can get a link on other ports but 1,13,14,15,16.

The ports 2,3,4,5,6,7,8,9,10,11,12,17,18,19,20,21,22 is working perfectly. The problem is that the switch is running slower than my other switches , which has nothing to do with this switch.

You say the ports are set as full duplex you must verify the attached devices are also hardcoded to full duplex if they are set as auto there is a speed duplex mismatch , if your cnet switch was set as auto that would indicate that the pc client nics are auto and your switchports are hardcoded which is incorrect , try setting your ports as auto . Set interfaces

as speed auto , duplex auto .

Okay , tested to hardcode the switchports and auto-code them and everything goes faster when i auto-code them. I have tested Everything with this config:

1.Auto-Duplex - Auto-Speed

2.100-Coded duplex - Auto-Speed

sounds like you should leave the switchports as auto for both speed and duplex .

Maybe...i will soon test a bit more with the bandwidth....I will do that tomorrow.

I have tested the bandwidth with this configuration:

1.Disabled Spanning Tree on all VLANs.

2.Disabled CGMP

3.Duplex Auto on all ports

4.Highest bandwidth set on VLAN 10

5.Disabled CDP

6.VTP mode Transparent

7.Management VLAN: 1

8.Assigned IP Address 192.168.1.83 to VLAN 1

9.Assigned IP Address 192.168.2.83 to VLAN 10

Note: VLAN1 is the management VLAN and VLAN 10 is the "network" VLAN. All Ports are assigned to VLAN10

With this configuration , no bandwidth is lost. I even got 13.4 MB/S as the top speed!

The speed were even better when i tried to shutdown vlan 1

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers