cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
179
Views
0
Helpful
4
Replies

C8000v dot1q/BDI switching config question

BrandonRumer
Level 1
Level 1

Hi

I am trying to configure a Catalyst8000v, running 17.9 and another 17.11 (problem exists on both code versions) and I cannot for the life of me get a good config for a simple dot1q interface. Below are my configs. Can somebody help me out? The goal is to have the connected gi5 interface be untagged.

```

--CONFIGS--

bridge-domain 100

interface GigabitEthernet5
description To-Linux
no ip address
negotiation auto
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100

interface BDI100
ip address 10.10.100.1 255.255.255.0
encapsulation dot1Q 100

```

--SHOW COMMANDS--

```
#sh int gi5
GigabitEthernet5 is up, line protocol is up


#sh int bdi100
BDI100 is up, line protocol is up


#sh mac add interface gi5
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports
---- ----------- -------- -----


#sh ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.10.100.1 - 001e.1452.c3bf ARPA BDI100
```



# CCIE 58997
1 Accepted Solution

Accepted Solutions

BrandonRumer
Level 1
Level 1

After sleeping and re-reading about EVCs, it was clear that the BDI config was incorrect. I have also corrected my physical interface to be untagged, below. The working configs should be:

interface GigabitEthernet5
description To-Linux
no ip address
negotiation auto
service instance 100 ethernet
  encapsulation untagged
  encapsulation dot1q 100
  rewrite ingress tag pop 1 symmetric
  bridge-domain 100

interface BDI100
ip address 10.10.100.1 255.255.255.0
  encapsulation dot1Q 100



# CCIE 58997

View solution in original post

4 Replies 4

balaji.bandi
Hall of Fame
Hall of Fame

what is the use case here ? 

what device connected other side ? (as i see in the config mentioned Linux ?)

check below guide : (check - Example Configuration Bridge-Domain Virtual IP Interface)

https://www.cisco.com/c/en/us/td/docs/routers/C8000V/Configuration/c8000v-installation-configuration-guide/bdi_c8kv.html#con_1077581

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks. Yes, I've seen that document and it is lacking on dot1q and EVC in so many ways.

Use case: on-box NFVIS & when the connected device is a routed interface (maybe even a Linux or Windows VM), which doesn't run a routing protocol (due to technical or administrative policy limitations), than it would make sense to me to use VLAN/dot1q tags. LMK if I'm missing a better solution.

Thanks.



# CCIE 58997

Why you want BDI? Are router dont support subinterface or vlan ?

MHM

BrandonRumer
Level 1
Level 1

After sleeping and re-reading about EVCs, it was clear that the BDI config was incorrect. I have also corrected my physical interface to be untagged, below. The working configs should be:

interface GigabitEthernet5
description To-Linux
no ip address
negotiation auto
service instance 100 ethernet
  encapsulation untagged
  encapsulation dot1q 100
  rewrite ingress tag pop 1 symmetric
  bridge-domain 100

interface BDI100
ip address 10.10.100.1 255.255.255.0
  encapsulation dot1Q 100



# CCIE 58997
Review Cisco Networking for a $25 gift card