cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
269
Views
5
Helpful
3
Replies
Highlighted
Beginner

Can I use SVI interface as server's gateway IP and also make the vPC working correctly?

Sorry, I do not have enough knowledge about vPC mechanism. Can someone tip me or tell me that will it working?

 

Here is my situation now:

I have two Nexus 3000 series switches: N3K-A & N3K-B and I referred many blogs make them as vPC device.

Then, I create 4 SVI (4 vlan interfaces) on N3K-A and those 4 SVI interfaces will be server's network gateway address as following:

SVI vlan 2011: 192.168.211.254

SVI vlan 2012: 192.168.212.254

SVI vlan 2013: 192.168.213.254

SVI vlan 2014: 192.168.204.254

 

However, when I use command "show vpc brief" then I noticed an error message

Type-2 inconsistency reason : SVI type-2 configuration incompatible

 

But when I compare N3K-A and N3K-B running configuration file, the only difference is N3K-B does not have the 2011~2014 SVI interface.

 

My purpose is:

I have to use 2NICs from server and will use LACP connect to N3K-A and N3K-B by using Nexus's port-channel.

 

Question 1: Can I make this scenario achieve? vPC + SVI as server's gateway IP

Question 2: If question1 is yes, why I got the error message from show vpc brief? Is there any wrong from both N3K configuration?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

change the config as below :

 

 

1. I have changed VPC config to allowed limited VLAN, if you need more add them in to config

2. I have  given HSRP config for VLAN same will be other VLAN ( make sure you enable the Feature before you adding HSRP)

3. If the Server connected and support LACP ( configure that Port-channel with vpc config)

 

let me know how it goes.

 

interface port-channel99
description vPC Peer-Link
switchport mode trunk
spanning-tree port type network
switchport trunk allowed vlan 1,2011-2012
vpc peer-link

nexus 3K1

vlan 2011
name 2011
!
interface Vlan2011
description 2011
no shutdown
mtu 9216
ip address 192.168.211.252/24
hsrp bfd
hsrp version 2
hsrp 2011
preempt
priority 200
ip 192.168.211.254
wr

nexus 3K2

configure terminal
!
vlan 2011
name 2011
!
interface Vlan2011
description 2011
no shutdown
mtu 9216
ip address 192.168.211.253/24
hsrp bfd
hsrp version 2
hsrp 2011
priority 190
ip 192.168.211.254
wr

BB
*** Rate All Helpful Responses ***

View solution in original post

3 REPLIES 3
Highlighted
VIP Mentor

change the config as below :

 

 

1. I have changed VPC config to allowed limited VLAN, if you need more add them in to config

2. I have  given HSRP config for VLAN same will be other VLAN ( make sure you enable the Feature before you adding HSRP)

3. If the Server connected and support LACP ( configure that Port-channel with vpc config)

 

let me know how it goes.

 

interface port-channel99
description vPC Peer-Link
switchport mode trunk
spanning-tree port type network
switchport trunk allowed vlan 1,2011-2012
vpc peer-link

nexus 3K1

vlan 2011
name 2011
!
interface Vlan2011
description 2011
no shutdown
mtu 9216
ip address 192.168.211.252/24
hsrp bfd
hsrp version 2
hsrp 2011
preempt
priority 200
ip 192.168.211.254
wr

nexus 3K2

configure terminal
!
vlan 2011
name 2011
!
interface Vlan2011
description 2011
no shutdown
mtu 9216
ip address 192.168.211.253/24
hsrp bfd
hsrp version 2
hsrp 2011
priority 190
ip 192.168.211.254
wr

BB
*** Rate All Helpful Responses ***

View solution in original post

Highlighted

Hi BB, thank you for your suggestion and it really give me more tips on how to search related information from google.

Your example configuration is work and we got vPC & HSRP benefit on our environment.

 

Could you please also explain what "preempt" definition or why this parameter should be configured on HSRP primary device?

Highlighted

Glad all working as expected.

 

If SWITC 1 has the higher priority and if it is configured with preempt then any given time SWITCH 1 is up then it will be active. There is no need for preempt on SWITCH 2.

 

This is a normal HSRP behavior.

BB
*** Rate All Helpful Responses ***
Content for Community-Ad