Showing results for 
Search instead for 
Did you mean: 

Catalyst 3570 express setup...webpage won't go away!!!!!

i've got a stack of 3750's configured, everything is working fine, but the web interface for the stack will only present the web based express configuration page. I can't get it to go away. what needs to be done to clear whatever flag or register that causes this behavior. the cli is fine, it's not trying to force epxress setup there, only in the web interface. will reloading the software image fix this?

Reza Sharifi
Hall of Fame Expert

Hi Alex,

Can you post the verion of IOS you are running?



do i have to reload the software to get the express setup webpage to go away and give me back my regular device management page?


I have the same issue. I updated a stack of 3750g switches and cannot get to the device manager - it goes directly to the express setup. Have you had any luck with your problem?




I am seeing this as well after just upgrading from an ancient 3750 version (12.2(25)) to 12.2(53)SE via the gui.

FYI, I just updated another box and got the same result.

I filed a case with the TAC. They finally got back to me saying that this is a bug in the IOS version. We need to keep checking for another updated version.

Old post here, but TAC is wrong.  It's not a bug, this is by design.  You have loaded the low memory packages for older switches with 16MB flash.

From 12.2(53)SE1 release notes:

"with device manager Express Setup files only. This image is intended for switches that have a 16M flash size".

If you have an older device, express setup is all that is supported.  If you have a switch with greater that 16MB flash, download and install the full TAR package.

Looking at the html directory in the flash I'm guessing that the

express setup is all that's left for the onboard gui. I tried reading the backrev

releasenotes to see if I could find the depreciation announcement but didn't see it.

I'm just using the CNA now...

I just found c3750-ipbasek9-tar.122-50.SE3 dated 12/15 and installed it via CNA. The device manager now works.


How about the output of Switch# show setup express?

Any Switch LEDs above the Mode button start blinking?

Have you tried separating one of the Switches from the Stack, does it go to Express Setup?

On the Master Switch:

Switch(config)# no setup express

If Express Setup is active on the switch, entering the write memory or copy running-configuration startup-configuration privileged EXEC commands deactivates Express Setup.


Early on, we included the no setup express:

mcstack#sh setup express

express setup mode is not active

The TAC duplicated this issue on a 3750 at their location and concluded that it is a bug in the IOS. According to them, we will have to wait for a new release or downgrade to the old version.



haven't followed thread for a while....

i never found an issue, was going to re-image with same os, but since i see from a prior post, that it may be an OS bug, will wait for next release.

i'll bet a full os reload will reset it, cause that archives all existing directories, and puts new versions out there...i've got other switches with this os, and they're fine...not sure what got me in my situation, but guessing a reload would fix it...or jus wait for next firmware rev...


I have had the same issue. Replicated over several pieces of hardware. To test, I upgraded from 122-35 (what came on the switch) to 122-53 using TAR which caused the problem.  To correct I backrev'd to 122-50.  I then upgraded the ISO ONLY using bin to 122-53 which does NOT cause the issue.