cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8322
Views
0
Helpful
6
Replies

Changing Native VLAN

yagateela
Level 1
Level 1

Hi,

I am just a basic learner and i am having a small issue in setting up my router and switch 

I am using a 2620XM router and 2960G series switch I have created 3 vlan 100,200,300 on a switch and have assigned those vlans to 3 different PC's and changed my native vlan to vlan 99 and all the unused ports are moved to a dump vlan 101 and I have given 3 sub interfaces on the router and given the 3 different IP's on those interfaces and i am trying to ping the directly connected interface witch is my gateway from PC's and i am getting reply as "destination host not reachable"

 

I really appreciate if someone can help me in trouble shouting steps and tell me reason for causing my issue 

 

Thank you 

 

ROUTER CONFIGS

!
!
!
!
interface Ethernet0/0
no ip address
half-duplex

!
interface Ethernet0/0.100
encapsulation dot1Q 100
ip address 10.0.0.254 255.255.255.0
!
interface Ethernet0/0.200
encapsulation dot1Q 200
ip address 20.0.0.254 255.255.255.0
!
interface Ethernet0/0.300
encapsulation dot1Q 300
ip address 30.0.0.254 255.255.255.0
!
interface Serial0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Serial0/1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
no auto-summary

 

 

Switch Configs 

interface GigabitEthernet0/1
description Management_PC
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/2
description Professor_PC
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet0/3
description Student_PC
switchport access vlan 300
switchport mode access
!
interface GigabitEthernet0/4
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/5
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/6
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/7
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/8
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/9
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/10
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/11
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/12
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/13
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/14
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/15
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/16
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/17
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/18
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/19
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/20
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/21
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/22
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/23
switchport access vlan 101
switchport mode access
shutdown
!
interface GigabitEthernet0/24
description LINK_ROUTER
switchport trunk native vlan 99
switchport trunk allowed vlan 100,200,300
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache 

2 Accepted Solutions

Accepted Solutions

Deepak Kumar
VIP Alumni
VIP Alumni

Hi,

I didn't find any VLAN 99 on the router. Please check again the router configuration.

 

interface Ethernet0/0.99
encapsulation dot1Q 99 native
ip address x.x.x.x 255.255.255.0
!

Second issue that VLAN 99 is not allowed on the switch trunk port.

Also share output as

Show interface trunk 

 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

View solution in original post

Hello

Your trunk towards the router is native vlan 99 so you need just to create a sub-interface on the router (no ip address) as native vlan.
No need to allow it on the trunk or have it even created in the vlan database of the switch.

interface Ethernet0/0.99
encapsulation dot1Q 99 native
no ip address

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

6 Replies 6

luis_cordova
VIP Alumni
VIP Alumni

Hi @yagateela ,

 

Try removing this command:

switchport trunk allowed vlan 100,200,300

 

 

I hope you find it useful

 

Regards

depending on the running software versionin the switch , you may need to add to the Switch Config

interface GigabitEthernet0/24

 switchport trunk encapsulation dot1q

 

(in IOS V12 default encapsulation is not dot1q)

chrihussey
VIP Alumni
VIP Alumni

On the switch side, you specify VLAN 99 as the native VLAN, yet that's not what you have in the router. Suggest removing the native VLAN 99 from the switch's trunk port.

Also:

1- Not sure why you have the router's E0 interface set to half duplex. In auto on both sides it should negotiate to 10/full.

2- Are the VLANs created in the switch and is the switch in vtp server or transparent mode? "sh vlan" and "sh vtp status"

Hope this helps

Deepak Kumar
VIP Alumni
VIP Alumni

Hi,

I didn't find any VLAN 99 on the router. Please check again the router configuration.

 

interface Ethernet0/0.99
encapsulation dot1Q 99 native
ip address x.x.x.x 255.255.255.0
!

Second issue that VLAN 99 is not allowed on the switch trunk port.

Also share output as

Show interface trunk 

 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

Hello

Your trunk towards the router is native vlan 99 so you need just to create a sub-interface on the router (no ip address) as native vlan.
No need to allow it on the trunk or have it even created in the vlan database of the switch.

interface Ethernet0/0.99
encapsulation dot1Q 99 native
no ip address

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

yagateela
Level 1
Level 1
Thank you guys for helping me out and giving me some ideas where to start with and helped me to solve my issue
Review Cisco Networking products for a $25 gift card