cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
754
Views
5
Helpful
7
Replies

channel group mode error - Cisco 3750G

Herald Sison
Participant
Participant

Hi All,

I have a 2 cisco 3750G switch and it is connected via stackwise cables and i am trying to use a channel group for 2 uplink ports that are located in port 48 in each switch for my VMware ESXi and now when i tried the channel group modes below i got the same error always.

 I tried:

channgel-group mode on

channgel-group mode desirable

channgel-group mode auto

and i got this error: With PAgP enabled, all ports in the Channel should belong to the same switch
Command rejected (Port-channel22, Gi1/0/46): Invalid etherchnl mode

 

but when i try these modes below:

channgel-group mode active

channgel-group mode passive

there is no error when i try these 2 modes above but when i check the port speed for the port-channel i only get 1Gb speed instead of 2GB and it says Port channe is down.

HeraldSison_0-1667064692295.png

by the way both ports are using mode access (not mode trunk)

any ideas and suggestion are much appreciated.

1 Accepted Solution

Accepted Solutions

Herald Sison
Participant
Participant

Hi everyone i have finally solved the mystery. It just my mistake that i did not clear the current mode config from active before i change its mode config to on. Everything is doing well now.

View solution in original post

7 Replies 7

balaji.bandi
Hall of Fame
Hall of Fame

PAGP is a cisco proprietary, so it works between the Cisco switch and to cisco switch, if you looking to configure a port channel between the Cisco switch and VMWARE ESXi, suggest using Mode on, or Lacp port channel depending on the requirement.

 

(Port-channel22, Gi1/0/46): Invalid etherchnl mode

 

Can you post the configuration :

show run interface port-channel 22

show run interface gi1/0/48 and 1/0/46 (whatever port-channel members)

we need to see more output also below

show EtherChannel 22 details

show interface gi1/0/48 and 1/0/46 (part of port-channel)

Look at the VMWARE suggestion : (to build a port-channel on ESXi side)

https://kb.vmware.com/s/article/82609

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

1.GIF2.GIF3.GIF4.GIF5.GIF

Can you post the below information which i missed asking: ( I am thinking they are up as (I) individual

show EtherChannel  summary

show switch

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello,

PAgP is not supported on cross-stack EtherChannel, so in any case, LACP must be used (mode on).

That said, I am not really clear on what the channel is connecting to:

--> I have a 2 cisco 3750G switch and it is connected via stackwise cables and i am trying to use a channel group for 2 uplink ports that are located in port 48 in each switch for my VMware ESXi

What is the hypervisor running on ? What machine (dual NICs) ? Can you provide a schematic drawing of the physical setup ?

I am running VMWare ESXi 7.0U3 with Dell R520Poweredge and with dual NICs configured NIC Teaming inside ESXi. even using the command Channel-group 22 mode on still gets me an error - With PAgP enabled, all ports in the Channel should belong to the same switch
Command rejected (Port-channel22, Gi1/0/46): Invalid etherchnl mode

1.GIF

HeraldSison_0-1667067440358.png

 

 

Hello,

I think the config should look like this:

interface Port-channel22
switchport
switchport access vlan 10
switchport mode access
no ip address
!
interface GigabitEthernet1/0/46
switchport
switchport access vlan 10
switchport mode access
no ip address
channel-group 22 mode on
!
interface GigabitEthernet2/0/46
switchport
switchport access vlan 10
switchport mode access
no ip address
channel-group 22 mode on

Herald Sison
Participant
Participant

Hi everyone i have finally solved the mystery. It just my mistake that i did not clear the current mode config from active before i change its mode config to on. Everything is doing well now.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: