cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

341
Views
0
Helpful
2
Replies
Highlighted

Cisco 1800 Series Router Configuration w/ ISP Modem

your computer appears to be correctly configured, but the device or resource (DNS server) is not responding


I recently purchased a Cisco 1841 router to add to my home lab, in preparation for the CCNA. My problem is, I can't get out to the internet. After running the config's (will post below) I plug my laptop into fa0/1, on the router, and try to reach google or cisco websites, but cannot access any sites.. I can ping 4.2.2.2 and 8.8.8.8, and 75.75.75.75 (Comcast DNS) from the router, with 100% pass through. When I run a diagnostic on the NIC  (ethernet) I get the following message "your computer appears to be correctly configured, but the device or resource (DNS server) is not responding". I guess that the best way to get some help would to start by providing my specs.



Router(s): Cisco 1841 running IOS 15.1 (Has been restored to factory default)

Modem: Arris

Switches: 2- Cisco 3550 (currently not configured but fa/01 from the router will run to fa0/2 on SW001)

ISP: Comcast

Interfaces on Router: fa0/0 and fa0/1

Architecture:

Arris modem->fa0/0 on Cisco 1841->fa0/2 on Sw001 (Cisco 3550)

All other interfaces on the switch will be open



CONFIG CMD's:

interface fa0/0
ip address dhcp
no shut
exit
 
interface fa0/1
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
 
show ip interface brief
 
config t
ip dhcp excluded 192.168.1.1 192.168.1.2
ip dhcp pool DeadPool
network 192.168.1.0 255.255.255.0
default router 192.168.1.2
import all
ip dhcp pool TheDeadPool
dns-server 4.2.2.2
exit
 
no access-list 101 permit ip 192.168.1.0 0.0.0.255 any
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
 
access-list 10 permit 192.168.1.0 0.0.0.255
ip nat inside source list 10 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 dhcp
 
copy run start
RUNNING CONFIG:

LABROUTER1#show running-config
Building configuration...

Current configuration : 1207 bytes
!
! Last configuration change at 02:52:25 UTC Sat Sep 10 2016
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LABROUTER1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$AY8U$XMFtjJJSTxm0vMl1c0.y7/
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.2
!
ip dhcp pool DEADPOOL
import all
network 192.168.1.0 255.255.255.0
dns-server 4.2.2.2
default-router 192.168.1.2
!
!
!
ip cef
no ipv6 cef
!

Can anyone offer some insight as to what I am doing wrong?

Thank you in advance!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1841 sn FTX1013Y1VA
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 10 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end

Everyone's tags (1)
2 REPLIES 2
VIP Mentor

Patrick, 

Patrick, 

you are almost there, a couple of things need to be added. The correct configuration would look like this (additions/changes are marked with an -->):

ip dhcp excluded-address 192.168.1.1 192.168.1.2
!
ip dhcp pool DEADPOOL
import all
network 192.168.1.0 255.255.255.0
dns-server 4.2.2.2
--> default-router 192.168.1.1

interface FastEthernet0/0
ip address dhcp
--> ip nat outside
duplex auto
speed auto

interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
--> ip nat inside
duplex auto
speed auto

ip forward-protocol nd
no ip http server
no ip http secure-server

--> ip nat inside source list 101 interface FastEthernet0/0 overload
--> ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

--> access-list 101 permit ip 192.168.1.0 0.0.0.255
!
!
!

VIP Advocate

Hi,

Hi,

Please change your default router IP address in DHCP address

!

default-router 192.168.1.1

!

!

! ! ! ! Enable NAT on inside and outside interface as below :

interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto

interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto

!

!

Regards,

Deepak Kumar

www.deepuverma.in 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards