cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1173
Views
5
Helpful
6
Replies
Highlighted
Beginner

Cisco 6500 DHCP Relay Redundancy

Hello;

In our network topology , we 've two windows DHCP server. So we use "ip helper" command for relaying;

....

interface Vlan11

ip address 10.50.11.252 255.255.255.0

ip helper-address 10.50.10.10

ip helper-address 10.50.10.11

no ip redirects

no ip proxy-arp

ip wccp 0 redirect in

ip wccp 70 redirect in

standby delay minimum 180

standby 11 ip 10.50.11.254

standby 11 timers msec 500 2

standby 11 priority 150

standby 11 preempt

standby 11 track 1 decrement 35

........

I've two question ;

1 ) Is "ip helper" command provide check of DHCP service availabilitiy on servers ?

2) A few days ago, our first dhcp server (10.50.10.10) service (not machine) went down, but client couldnt requested ip from secondary dhcp. So how could we do redundacy when we face similar issue ?

Best regards, Thanks

Everyone's tags (5)
6 REPLIES 6
VIP Advisor

Re:Cisco 6500 DHCP Relay Redundancy

Hello

1) the dhcp relay helps to forward dhcp bootp broadcasts to a dhcp server residing on a diferrent network separated by a l3 device such as a switch/router as by default broadcast are prohibited to traverse a router.

2) when you say service was the primary helper addrees still available and also is the secondary helper addreess reachable?

res
Paul


Sent from Cisco Technical Support Android App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Cisco 6500 DHCP Relay Redundancy

I mean, server is up but DHCP service stopped mode for maintenance. Secondary was reacheble.

Also scope on two server running without overlapping. Network range is same but we use excluded ip range feature.

Best regards.

Cisco Employee

Cisco 6500 DHCP Relay Redundancy

Hi,

How does DHCP relay redundancy works?

Having the following configuration:

interface X
ip helper-address 1.1.1.101
ip helper-address 1.1.1.102

This will configure DHCP relay in the router. It receives a broadcast DHCP request and converts it into a unicast message directed exclusivly to both DHCP servers.
The router "sees" the DHCPDISCOVER packet and forwards it to bothaddresses simultaneously. Then, both DHCP servers will make an offer (DHCPOFFER), if they are up and received the request.
The client will receive each offer at one time, one first then the other. if it finds the offer agreeable, itwill send another broadcast, a DHCPREQUEST, specifically requestingthose particular IP parameters. Why does the client broadcast therequest instead of unicasting it to the server? A broadcast is usedbecause the first message, the DHCPDISCOVER, may have reached more thanone DHCP server. If more than one server makes an offer, thebroadcasted DHCPREQUEST allows the other servers to know which offerwas accepted. The offer accepted is usually the first offer received.
Sometimes, in other to make one server responde faster then the other, you can configure the delay of response in the DHCP server.Also, for sincronization between DCHP server, either they support this feature or you will have to have your subnet divided betweenthe 2 servers without overlapping.

HTH

Regards

Inayath

Beginner

Cisco 6500 DHCP Relay Redundancy

According to this informations, our clients should have request ip over second one and took ip address.

Have u any idea regarding our issue ? What we supposed to do ?

VIP Advisor

Cisco 6500 DHCP Relay Redundancy

Hello

Is the second ip helper-address reachable?

Also are both dhcp scopes enabled and authorised in dhcp on Both servers?

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Cisco 6500 DHCP Relay Redundancy

Hello;

Unfortunately i couldnt test it now because of windows 2012 upgrade processes. But my colleagues told me it was authorised and reachable status at issue date.

After completing upgrade, i'm going to test again and inform you regarding to case.

Thanks, regards

Umut

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards