cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1040
Views
0
Helpful
7
Replies

Cisco CBS350 LAG issue on fiber interfaces

TEST1285
Level 1
Level 1

Good day, guys!

I have a simple topology with two devices (Cisco CBS350-48T-4G Version: 3.2.0.84 and Meraki MS 120 Version: MS 15.4) and two optical links between them. 

These two interfaces are in one LAG with LACP mode.
Configuration of CBS350:

#sh run int po2
interface Port-Channel2
no negotiation
description ===MS120-Po2===
switchport mode trunk
switchport trunk native vlan 300
switchport trunk allowed vlan 300
!
#sh run int gi49
interface GigabitEthernet49
description ===MS120-25port===
channel-group 2 mode auto
switchport mode trunk
switchport trunk native vlan 300
switchport trunk allowed vlan 300
!
#sh run int gi50
interface GigabitEthernet50
description ===MS120-26port===
channel-group 2 mode auto
switchport mode trunk
switchport trunk native vlan 300
switchport trunk allowed vlan 300

This port-channel periodically (about once a two our)flaps and goes up only with one random interface (gi49 or gi50) or with both of them:


04-Nov-2022 04:04:55 :%LINK-I-Up: Po2

04-Nov-2022 04:04:55 :%TRUNK-I-PORTADDED: Port gi50 added to Po2

04-Nov-2022 04:04:52 :%LINK-W-Down: Po2

04-Nov-2022 04:04:52 :%TRUNK-W-PORTREMOVED: Port gi50 removed from Po2

04-Nov-2022 04:04:51 :%TRUNK-W-PORTREMOVED: Port gi49 removed from Po2

Such behavior is unexpected, I need a more stable connection. I couldn`t find anything similar in the bug list.
I`ve tested the same scheme with a copper connection and everything was working as expected, without any flaps.

Maybe somebody also has the same issue? Have you any thoughts on what it can be?

1 Accepted Solution

Accepted Solutions

 

Thank`s  a lot for your answer!

It was really the issue with Meraki switch, not with cbs350 as I thought at first.

When I configure the aggregate interface from scratch, on the Meraki side RSTP runs on physical interfaces, not on logical. That's why the loop is detecting and one of the interfaces is blocking.
But when I disable and then enable the aggregate interface, RSTP enables on the aggregate interface and everything looks good.
I`ve tested this behavior several times, changed devices, which are connected to the Meraki and got the same results.

View solution in original post

7 Replies 7

balaji.bandi
Hall of Fame
Hall of Fame

why you looking to mode auto.

try changing  auto to active (see if that fix the issue) - also tell us what is other side connected switch( what logs you see)

- check physical cables any loose contact.

channel-group 2 mode auto

to

channel-group 2 mode active

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank`s a lot for your answer!

There are such options for configuration:

int gi49
(config-if)#channel-group 2 mode
on Add port without LACP
auto Add port with LACP

Meraki switch supports only LACP mode, that's why I use mode auto.

 

make sense - since we did know other side. now we know meraki what is configured other side ?

https://documentation.meraki.com/General_Administration/Tools_and_Troubleshooting/Link_Aggregation_and_Load_Balancing

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Configuration of the aggregation interface from the meraki side:

LAG Config.png

LAG Config part2.PNG

 Seems like everything should be good...

Log from meraki switch at the moments of issue happening:

meraki log.PNG

I have seen this issue, Most of the time Meraki device try to elect as ROOT bridge in STP,

So change the prirority to different or make Switch as ROOT for STP.

you can use root gaurd feature if you like to protect not to become root bridge for STP.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

 

Thank`s  a lot for your answer!

It was really the issue with Meraki switch, not with cbs350 as I thought at first.

When I configure the aggregate interface from scratch, on the Meraki side RSTP runs on physical interfaces, not on logical. That's why the loop is detecting and one of the interfaces is blocking.
But when I disable and then enable the aggregate interface, RSTP enables on the aggregate interface and everything looks good.
I`ve tested this behavior several times, changed devices, which are connected to the Meraki and got the same results.

Glad suggestion worked and appricaited your input.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Review Cisco Networking for a $25 gift card