10-10-2012 06:35 AM - edited 03-07-2019 09:23 AM
Hey guys, I'm having an issue with one of my LANs, in this I have several servers and one PC, now based on the diagram below the PC can ping the switch and router but not the servers. And the Servers can ping each other and the switch but not the router and pc. I set them all in the same vlan, created a trunk connection to the router from the switch, made sure the IP config was correct and turned up now I am stuck. Any suggestions or help is appreciated.
Below is the PC pinging the router and then a server in its VLAN
Below is a serving pinging another device in the vlan
Below is the same server unable to reach both router and the pc in its vlan.
Here is the Router Config
Current configuration : 2333 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
username jason privilege 15 secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 202.18.81.9 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 18
ip address 44.33.77.1 255.255.255.240
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 202.18.81.34 255.255.255.252
!
interface Serial0/0/1
ip address 202.18.81.37 255.255.255.252
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
switchport mode access
shutdown
!
interface FastEthernet1/1
switchport mode access
shutdown
!
interface FastEthernet1/2
switchport mode access
shutdown
!
interface FastEthernet1/3
switchport mode access
shutdown
!
interface FastEthernet1/4
switchport mode access
shutdown
!
interface FastEthernet1/5
switchport mode access
shutdown
!
interface FastEthernet1/6
switchport mode access
shutdown
!
interface FastEthernet1/7
switchport mode access
shutdown
!
interface FastEthernet1/8
switchport mode access
shutdown
!
interface FastEthernet1/9
switchport mode access
shutdown
!
interface FastEthernet1/10
switchport mode access
shutdown
!
interface FastEthernet1/11
switchport mode access
shutdown
!
interface FastEthernet1/12
switchport mode access
shutdown
!
interface FastEthernet1/13
switchport mode access
shutdown
!
interface FastEthernet1/14
switchport mode access
shutdown
!
interface FastEthernet1/15
switchport mode access
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 202.18.81.0
no auto-summary
!
ip classless
!
!
!
banner motd ^C
*************************************************
Authorized Users Only!!
*************************************************
^C
!
!
!
!
line con 0
exec-timeout 30 0
password cisco
logging synchronous
login
line vty 0 4
exec-timeout 30 0
password cisco
logging synchronous
login
transport input telnet
!
!
!
end
Here is the switch config
Current configuration : 1701 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk allowed vlan 18
switchport mode trunk
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
!
interface Vlan18
description Servers
ip address 44.77.33.1 255.255.255.240
!
ip default-gateway 44.77.33.1
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
I can take more screen shots and post more info if needed.
Solved! Go to Solution.
10-10-2012 02:56 PM
Your vlan 18 subnets do not match on the switch and router. The router says 44.33.77.1 and the switch and servers says 44.77.33.1 . Two different subnets . Where are your servers actually being routed? They are not in the vlan 18 address space .? This is not vlan 18 so its not being routed as only vlan 18 is allowed on the trunk which is 44.33.77.x so it cannot go anywhere. I would say you misaddressed the switch address and gateway and also the servers if they are meant to be in the same subnet. Currently the pc and switch are not in the vlan address space on the router.
interface FastEthernet0/0.1
encapsulation dot1Q 18
ip address 44.33.77.1 255.255.255.240
!
interface Vlan18
description Servers
ip address 44.77.33.1 255.255.255.240
!
ip default-gateway 44.77.33.1
!
10-10-2012 02:15 PM
Hello Janson,
Look your servers are ping each other because they are all on the same subnet /28 and I do not believe you had configured the default gateway on them .
But on the PC for example you had configured the default gateway which is your router ip address 44.33.77.1 and on your router you had configured RIP version 2 with just network 202.18.81.0 you will need to add network 44.33.77.0 as you know you need to add all the networks connected to your router .
In your situation you are sending to your router traffic for the 4.33.77.0 network and your poor router do not know where to send it so it get droped
to solve your porblem just add the following to your router :
router rip
network 44.33.77.0
Hope it will Help
Ahmed Sonba
10-10-2012 02:56 PM
Your vlan 18 subnets do not match on the switch and router. The router says 44.33.77.1 and the switch and servers says 44.77.33.1 . Two different subnets . Where are your servers actually being routed? They are not in the vlan 18 address space .? This is not vlan 18 so its not being routed as only vlan 18 is allowed on the trunk which is 44.33.77.x so it cannot go anywhere. I would say you misaddressed the switch address and gateway and also the servers if they are meant to be in the same subnet. Currently the pc and switch are not in the vlan address space on the router.
interface FastEthernet0/0.1
encapsulation dot1Q 18
ip address 44.33.77.1 255.255.255.240
!
interface Vlan18
description Servers
ip address 44.77.33.1 255.255.255.240
!
ip default-gateway 44.77.33.1
!
10-11-2012 02:47 PM
Hi Ahmed & Glen. Thank you for the fixes. I made the changes and everything is working correctly. I appreciate you guys help.
10-11-2012 02:49 PM
Jason
You are most Welcomed
Ahmed Sonba
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide