cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
871
Views
0
Helpful
23
Replies

Cisco Router 2600 Unable to connec to the internet

andyferguson1977
Beginner
Beginner

So, my IPS is Time Warner and so I have a router, dynamic IP Address

I just trying configure my Cisco 2600, which will be connected to a cisco switch 2950 switch and from there, connect PCs to and go online..

Can someone help me please

Please find config below


Router>
Router>en
Password:
Router#show config
Using 1689 out of 29688 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jzHw$5SqvwC0Gxen1r8lkYwtRp.
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.20
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 192.168.2.2
ip dhcp excluded-address 192.168.2.3
ip dhcp excluded-address 192.168.2.4
ip dhcp excluded-address 192.168.2.5
ip dhcp excluded-address 192.168.2.6
ip dhcp excluded-address 192.168.2.7
ip dhcp excluded-address 192.168.2.8
ip dhcp excluded-address 192.168.2.9
ip dhcp excluded-address 192.168.2.10
ip dhcp excluded-address 192.168.2.11
ip dhcp excluded-address 192.168.2.12
ip dhcp excluded-address 192.168.2.13
ip dhcp excluded-address 192.168.2.14
ip dhcp excluded-address 192.168.2.15
ip dhcp excluded-address 192.168.2.16
ip dhcp excluded-address 192.168.2.17
ip dhcp excluded-address 192.168.2.18
ip dhcp excluded-address 192.168.2.19
ip dhcp excluded-address 192.168.2.20
!
ip dhcp pool DATA
import all
network 192.168.2.0 255.255.255.0
dns-server 4.2.2.2
default-router 192.168.2.1
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 101 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip http server
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end

Thanks

1 Accepted Solution

Accepted Solutions

You need to be in configuration mode -

"no ip route 0.0.0.0 0.0.0.0 fa0/0"

then -

"ip route 0.0.0.0 0.0.0.0 192.168.1.254"

then do a "sh ip route" and you should it in the routing table.

Then from the router try pinging 4.2.2.2 again and see if it works. If it does try from a 192.168.2.x client.

Jon

View solution in original post

23 Replies 23

andrewswanson
Rising star
Rising star

Hi

You are specifying access-list 101 in your nat but the acl isn't present in your configuration - try adding the following:

access-list 101 permit ip 192.168.2.0 0.0.0.255 any

hth

Andy

it didn't work

please help


Router#show config
Using 1741 out of 29688 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jzHw$5SqvwC0Gxen1r8lkYwtRp.
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.20
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 192.168.2.2
ip dhcp excluded-address 192.168.2.3
ip dhcp excluded-address 192.168.2.4
ip dhcp excluded-address 192.168.2.5
ip dhcp excluded-address 192.168.2.6
ip dhcp excluded-address 192.168.2.7
ip dhcp excluded-address 192.168.2.8
ip dhcp excluded-address 192.168.2.9
ip dhcp excluded-address 192.168.2.10
ip dhcp excluded-address 192.168.2.11
ip dhcp excluded-address 192.168.2.12
ip dhcp excluded-address 192.168.2.13
ip dhcp excluded-address 192.168.2.14
ip dhcp excluded-address 192.168.2.15
ip dhcp excluded-address 192.168.2.16
ip dhcp excluded-address 192.168.2.17
ip dhcp excluded-address 192.168.2.18
ip dhcp excluded-address 192.168.2.19
ip dhcp excluded-address 192.168.2.20
!
ip dhcp pool DATA
import all
network 192.168.2.0 255.255.255.0
dns-server 4.2.2.2
default-router 192.168.2.1
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 101 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip http server
!
access-list 101 permit ip 192.168.2.0 0.0.0.255 any
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end

Router#

Hi

Additional to the ACL 101 (who should includes the internal networks to be translated) This routers is knowing the internal company routes? do you have them into the routing table? otherwise you should be using static route or dynamic routing protocols. 

example:

192.168.0.0/24
192.168.1.0/24  ---router X fa0/1 --- 10.0.0.0/24 --- fa0/1 Router 1 fa0/0 ----------Internet
192.168.2.0/24

Router 1

interface f0/0
ip address dhcp
ip nat outside
no shut

interface fa0/1
ip add 10.0.0.1 255.255.255.0
ip nat inside

ip access-list standard INTERNAL-NETS
permit 192.168.0.0 0.0.0.255
permit 192.168.1.0 0.0.0.255
permit 192.168.2.0 0.0.0.255

ip nat inside source list INTERNAL-NETS interface f0/0 overload

ip route 0.0.0.0 0.0.0.0 f0/0 name DEFAULT-ROUTE

ip route 192.168.0.0 0.0.0.255 10.0.0.2 name INTERNAL-NET-1
ip route 192.168.1.0 0.0.0.255 10.0.0.2 name INTERNAL-NET-2
ip route 192.168.2.0 0.0.0.255 10.0.0.2 name INTERNAL-NET-3

Router X

ip route 0.0.0.0 0.0.0.0 10.0.0.1 name DEFAULT-ROUTE

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Are you receiving an IP for the interface f0/0, could you please share the output of  show ip interface brief.

Thank you




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<


Router#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.47 YES DHCP up up
FastEthernet0/1 192.168.2.1 YES NVRAM up down
Router#

Sorry, ignore that last post.

Your fa0/1 interface is down so nothing is going to work until you fix that.

Jon

-

I am connecting to the internet using wifi, that's why.



Router#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.47 YES DHCP up up
FastEthernet0/1 192.168.2.1 YES NVRAM up up
Router#

Not sure I follow.

You said you were using a 2950 switch and now the interface is showing as up.

Do you mean you have an AP connected to the switch ?

Anyway if the interface is up then can you first try pinging 4.2.2.2 from the router. If that works can you try a ping from a 192.168.2.x client.

If that does not work post "sh ip nat translations" from the router.

Jon

No AP connected

I just cannot connect to the internet when I'm connected to the Cisco or when I'm connected directly to the routers 0/1 interface

So even from the router you cannot ping internet IPs ?

Jon

I cannot ping from the router to the internet but I am about to ping for PC to PC and from PC to gateway

Can you post a "sh ip route" from your router ?

Can you ping the modem ?

Jon


Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1
S* 0.0.0.0/0 is directly connected, FastEthernet0/0
Router#

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers