cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
70725
Views
59
Helpful
9
Replies
brandondillon
Beginner

Cisco USB console connection

I am having a heck of a time getting this Cisco USB Console to work,

I down loaded and installed the driver, its a windows 7 x64 system

I plug in the router and it install and if I look in device manager I get comport 3 under ports and at the top I see cisco USBconsolewindowsdriver

inside that it shows cisco buss enumerator and Cisco USB to serial adapter but there is ? in the icons but everything says it installed.

but when I try to open comport 3 says cant open

tried unistalling and reinstalling and shows and acts the same way

tried tera term, putty, same thing

what am I doing wrong?

I am using version 3.1 as well

9 REPLIES 9
Reza Sharifi
Hall of Fame Expert

Can you try a different USB port?

What will give a different com port.

Also, after connecting the USB cable to the device, look under "devices and printer" it should show up there, if not it has not been installed.

HTH

Richard Primm
Cisco Employee

Hi Brandon,

Please give a try with the following procedure:

1) Install the USB console driver (download from cisco CCO)
2) Follow the wizard and accept the defaults
3) Restart PC (the installer usually says it needs a restart)
4) After PC restart, plug-in the USB cable
5) PC should say installing Device driver software and fail at the Cisco Virtual Comm Port00
6) Click Windows button, right click computer, manage
7) Under Computer Management, Click Device Management
8) Go to Ports (COM & LPT)
9) You should see the Cisco Virtual Comm Port00 with a Yellow Exclamation point on it
10) Right Click on the Cisco Virtual Comm Port00 and select Properties
11) Click the Driver Tab
12) Click Update Driver
13) Select Browse my computer for driver software
14) Select Let me pick from a list of device drivers on my computer
15) Choose the Cisco Serial Driver
16) Device Driver is installed successfully, take note of the com port it is using

Let me know if you still get problems.

I never saw the com port with a ! it was all set, unfortunatly I do not have the 2911 here any more so I guess It will have to wait for the next time I try USB but thank you for the help guys.

I did try a USB 2.0 and 3.0 ports and everything on my computer seemed ok

thanks again =)

This worked for me. I am using windows 8.1 64bit.

Thanks,

yes, it's correct. worked better. 

Nick White
Beginner

I just want to note that this also worked for me. My case was a little different though. After battling this off and on for several weeks, I finally decided to sit down and figure this out. Running Windows 7 x64, and I previously had several USB Serial drivers from the various USB-to-Serial adapter manufacturers out there.

After installing the Cisco driver (v3.1), everything showed up in Device Manager properly, but the difference was that under Ports (COM & LPT) it said "USB Serial Port" instead of "Cisco Serial". Per @Richard Primm's instructions, #12-15 I went in and did an update driver, then "Let me pick..." and switched it to Cisco Serial, then it started working.

Only thing I can think is that Windows saw another USB-Serial driver in there and thought that was better by default.


Reno, NV Internet Service

This method worked for me.

After wrangling around with my new VG310s trying to get the USB serial connection to work, I found your solution and it worked!  Thanks for the info.  I was wondering if I just had a stubborn machine.  Turns out I was the stubborn one!

m.rana.ku
Beginner

Hi,
In the following video step by step process has been shown how to Connect Cisco Router or Switch using PuTTY and Console Cable as well as how to Change Text Color, Font Size, Background color permanently on PuTTY.

 

https://www.youtube.com/channel/UCmZZ2BNGXQH1HPS3uIVnr7A?sub_confirmation=1


https://youtu.be/WQeAe8_vbLI

 

First Download and install PuTTY (emulator terminal software) from https://www.putty.org/

Step 1: Attach the DV9 Female end of Console cable with the DV9 Male end of the USB to DV9 Serial Converter and then connect the RJ54 connector end of the Console cable to the Cisco router or Switch.
First check the COM port number

Step 2: Check the COM Port number:
=> Go Device Manager->Port (COM & LPT)-> check USB Serial Port (COM port)

Step 3: Open Putty
-> Select Connection Type to "Serial"
-> in Serial Line change the COM port number exactly which we checked in step 2.
-> click open and a black window will appear and press Enter finally it will access the Cisco Device.
-> Type "enable" to go to privilege mode.

Cisco #Putty #IT_Support_PeopleIT Support People Facebook Page:https://www.facebook.com/IT_Support-PeopleDesktop-Support-111268543923018Link for Other Rel...