cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
872
Views
0
Helpful
19
Replies
Beginner

Core network changes & problems

Hi everybody,

Here is some background first of all.

We have 1941/K9 series and now decided to replace our HP ProCurves with three Cisco Catalyst 3750G. We have them configured as a stack in our test environment. Our current network is on 192.168.10.0 /24 and we don’t use any VLANs. We just have interface gigabitEthernet 0/1 configured on 1941/K9 and that interface then goes to our HP ProCurve. HP ProCurve has got default configuration so basically it is a dumb switch which just interconnects our devices.

As our 1941/K9 has only got 2 ports – one for WAN, one for LAN; we have purchased additional EWIC with 4 ports (I do not have part number however I can probably find on Monday).

What I want to achieve is the below.

  1. Have 2 VLANS (or more in future) – 192.168.10.0 /24 and 192.168.10.50 /24.
  2. Preferably have 4 (if not possible, 2) links going from 1941/K9 to 3750G stack to provide redundancy and load balancing. We will connect let’s say one cable per switch in scenario where we have 3 cables/ports and in scenario with 4 cables/ports, there will be 2 going to the master and then one per member and so on.

Here is a drawing of what I would like to achieve (PLAN 1 is the main one). I will explain about PLAN 2 in a minute.

It is very simple design, however I ran into some problems because of 1941/K9.

First of all, we only have one 1941/k9 therefore I am unable to play around with the configuration in the test environment and GNS3 does not support this model. I have decided to use Cisco Packet Tracer as it should include every command that I need.

PLAN 1:

Basically, since the configuration doesn’t need to be complex and we only have one logical switch (3x3750 in a stack), I thought that I will configure an EtherChannel and 802.1Q Trunking between Catalyst L3 Switch and a 1941/K9 Router.

I have also followed a guide from Cisco website:

http://www.cisco.com/c/en/us/support/docs/switches/catalyst-2950-series-switches/24042-158.html#sthash.ssXraOw5.dpuf

I got Catalyst 3750G configured as required however:

  1. I have created channel-group 1.
  2. When I try to assign interfaces to channel-group 1 either by going manually to each individual one or by using interface range command it will either not recognize channel-group command on switch modules installed in 1941/K9 (when going to each individual interface) or when I use interface range command it will recognize the command however it will say:
Router(config-if-range)#channel-group 1 mode on 

% Interface range command failed for FastEthernet0/0/0

% Command failed on interface FastEthernet0/0/0. Aborting
  1. Due to the above, I am unable to configure an EtherChannel and also EtherChannel trunking. At the beginning of the Cisco guide it doesn’t mention 1941/K9 as supported router for EtherChannel trunking so this makes me think that maybe this is something that I can’t configure with this model?
  2. I am also unable to create interface channel-group 1.10 – it will not recognize this command.

PLAN 2

If this is the case, how else would you achieve my scenario? I was thinking about having normal LAN interfaces so let’s say:

- gigabitEthernet 0/0/0, gigabitEthernet 0/0/1 -> channel-group 1 (ip add 192.168.10.254 255.255.255.0)

- gigabitEthernet 0/0/2, gigabitEthernet 0/0/3 -> channel-group 2 (ip add 192.168.50.254 255.255.255.0)

However how would you then allow both channels to be up as spanning-tree won’t allow it to avoid loop probably. Also like I said earlier, I can’t assign 4 new interfaces to channel-group for some reason as mentioned in point 2.

I hope someone can advise :)

Looking forward to hearing from you.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Hall of Fame Community Legend

Just use one link.

Just use one link.

View solution in original post

Highlighted
Participant

What do you expect from

What do you expect from having more than 1 link to the router? You won't be able to utilize the additional bandwidth anyway, besides the 4ESW  does not support port-channels at all.


Better use the switch for the intervlan routing and create an additional /30 Network between router and switch. That way only the WAN-Traffic is going northbound, reducing load on the router and giving you line rate gigabit routing between the vlans.

 

Best Regards

 

View solution in original post

19 REPLIES 19
Highlighted
Hall of Fame Community Legend

% Interface range command

% Interface range command failed for FastEthernet0/0/0
% Command failed on interface FastEthernet0/0/0. Aborting

Etherchannel must have the same speed.  I am suspecting this is why you're getting this error message.

Highlighted
Beginner

HiEtherchannel have the same

Hi

Etherchannel have the same speed on both ends, each single port as well and I still get no 'channel-group' command when trying to configure individual interfaces, if I try it by 'interface range' command I will be able to input channel-group however it will come back with the same error message as mentioned earlier. It is worth to mention that this command works on built-in gigabit ports on the router.

Highlighted
Hall of Fame Community Legend

built-in gigabit

built-in gigabit

The error message is from a FastEthernet port.    Could you try setting the speed of the GigabitEthernet to auto-100 Mbps and see if this works?

Highlighted
Beginner

This is really annoying as I

1941/k9(config)#interface range gigabitEthernet 0/0 - gigabitEthernet 0/1

1941/k9(config-if-range)#no shut

1941/k9(config-if-range)#speed 100

1941/k9(config)#interface gigabitEthernet 0/0

1941/k9(config-if)#channel-group 1

%LINK-5-CHANGED: Interface Port-channel 1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up

1941/k9(config)#interface gigabitEthernet 0/1

1941/k9(config-if)#channel-group 1

It works perfectly fine as you can see above.

The only difference I can think of is that the gigabitEthernet interfaces are built-in interfaces which you can assign an IP address directly to. Additional EWIC module is a switch module therefore you would need to assign a VLAN to this interface. Would that make a difference with EtherChannel? I don't know as it works on 3750G stack and it is a switch.

Highlighted
Hall of Fame Community Legend

Ahhhh ... I see what you mean

Ahhhh ... I see what you mean.  

 

 

4ESW is a Layer 2 switch only therefore you won't be able to put it in an EtherChannel with the on-board NIC.

 

Highlighted
Beginner

Right, that's not good. Do

Right, that's not good. Do you have any other idea on how to accomplish my scenario? ie. with physical interface per LAN?

Highlighted
Hall of Fame Community Legend

Just use one link.

Just use one link.

View solution in original post

Highlighted
Beginner

That's not close to ideal...

That's not close to ideal... how could we achieve the following without STP blocking one link all the time:

- interface gigabitEthernet 0/0/1 as a default gateway for 192.168.10.0 /24 going to gigabitEthernet 1/1/48 in the stack

- interface gigabitEthernet 0/0/2 as a default gateway for 192.168.50.0 /24 going to gigabitEthernet 1/2/48 in the stack

 

gigabitEthernet 0/0/1
interface gigabitEthernet 0/0
interface gigabitEthernet 0/0
Highlighted
Participant

What do you expect from

What do you expect from having more than 1 link to the router? You won't be able to utilize the additional bandwidth anyway, besides the 4ESW  does not support port-channels at all.


Better use the switch for the intervlan routing and create an additional /30 Network between router and switch. That way only the WAN-Traffic is going northbound, reducing load on the router and giving you line rate gigabit routing between the vlans.

 

Best Regards

 

View solution in original post

Highlighted
Beginner

Hello,That is very good point

Hello,

That is very good point. Thanks for your post.

I only expect some redundancy. For instance, our stack consists of three 3750 switches and let's say if we have only 1 link going to the stack master and the stack master dies for some reason, whole stack loses WAN connectivity until we reconfigure another switch in the stack with a trunk port and physically reconnect the cable. Therefore, I was thinking about having etherchannel connected to at least 2 physical switches / 1 logical and this would provide at least some redundancy in this type of scenario.

Anyway, you are right and I will give it a go, however I just wonder how would it work in our MPLS scenario. We have 10 sites on the different subnets and each one can communicate with each other. When I talk to our MPLS provider, which networks would I have to ask him to advertise on the MPLS? Only /30 network between the default gateway and L3 switch or the networks configured on the switch as well?

Do I need to have a routing protocol in between the router and a switch so they can advertise the networks? For instance RIPv2 or EIGRP? I am not sure if I'm correct here.

Highlighted
Participant

If you want to use a dynamic

If you want to use a dynamic routing protocol certainly depends on your needs and preferences. For those 2 VLANs it probably would be little over engineering. All you need is a default route on the switch (as you already have) plus a default route on the router pointing to the MPLS cloud and a route for vlan 10 and 20 pointing to the switch.

Your MPLS provider needs to advertise at least both networks configured on the switch, but for the sake of troubleshooting and visibility you want him to advertise all networks you use at your site, including the /30 transfer network. That network btw should use a private ip range as well.

 

Best regards

 

Highlighted
Beginner

Hi,Sorry I have changed my

I totally agree that routing protocols would be over kill at this point.

Would you tweak the below configuration any how or is it correct? Any changes to STP on any LAN interfaces?

1941/k9#sh start
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 description WAN_MPLS
 ip address 10.0.56.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description LOCAL_LAN
 ip address 192.168.200.1 255.255.255.252
 duplex auto
 speed auto
!
router ospf 10
 log-adjacency-changes
 redistribute static subnets
 network 10.0.56.0 0.0.0.3 area 0
!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.200.2
ip route 192.168.50.0 255.255.255.0 192.168.200.2

 

3750-STACK#sh start
!
ip routing
!
spanning-tree mode pvst
!
interface FastEthernet0/10
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/1
 description link_to_1941/k9
 no switchport
 ip address 192.168.200.2 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan10
 ip address 192.168.10.253 255.255.255.0
!
interface Vlan20
 ip address 192.168.50.253 255.255.255.0
!
ip default-gateway 192.168.200.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.200.1
!
Highlighted
Participant

I guess that is because your

I guess that is because your remote sites don't know about the local networks configured on the switch. 


What is the standard procedure to announce new prefixes to your MPLS provider? Is there usually a phone call to be made or do you already use the OSPF 10 process for that? If the latter is true than you have two options: redistribute static subnets to OSPF 10 or create an OSPF adjacency with the switch (assuming you have the needed IOS/license installed). 

Again, do not use public IPs for transfer networks.

 

 

EDIT

ok you edited your post in between, so disregard my last comment.

 

 

Highlighted
Beginner

Hi,I have now amended

Hi,

I have now amended everything, final version is just about your post (the one with image).

The standard procedure is to call them. I will ask them to redistribute my static subnets as above.

Please if you wouldn't mind - have a look and confirm it you would make any tweaks like STP.

CreatePlease to create content
Content for Community-Ad