cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
370
Views
0
Helpful
5
Replies
Highlighted
Beginner

DHCP IP Helper Helper - Not Working

Hi,

 

I have a mini test setup that I am attempting to setup to support testing of IP phone provisioning. The setup consists of a IP Phone, Windows 2008 and Cisco 3560 POE switch. On the switch I have created three VLAN's

VLAN 100 Native - 10.252.100.0/24

VLAN 200 Voice - 10.252.200.0/24

VLAN 54 Admin - 10.252.54.0/24

 

The 2008 has IP address 10.252.54.55, in DHCP I have created a scope for both the native and voice vlan. In addition I have added IP Helper address to each VLAN on the 3560. For the Phone I have created a trunk port that has a native VLAN 100 defined.

 

I was expecting/hoping that by connecting the phone it would boot in VLAN 100 and get an IP address from the server. As part of phone configuration file download it would be told to use VLAN 200, at this point is should (in theory) boot in VLAN 200 and get the correct IP address from the server scope for voice.

 

For whatever reason I am not seeing any DHCP request land on the server via the IP helper, I can PING all elements via the layer 3 routing, however my DHCP does not seem to work. If I make the native VLAN 54 the phone does get an IP as it is the same subnet as the server.....

 

I thought that I could use a single DHCP server with a single IP address that has multiple scopes. Using IP HELPER I was expecting this to correctly identify the source network for the scope. Should this work in a Layer2/3 switch without the need to introduce a dedicated router? Or have I missed something in the configuration?? Any help/suggestion greatly appreciated.

 

vtp mode transparent
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/13
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/14
switchport access vlan 54
speed 100
duplex full!

!
interface Vlan54
ip address 10.252.54.1 255.255.255.0
!
interface Vlan100
ip address 10.252.100.1 255.255.255.0
ip helper-address 10.252.54.55
!
interface Vlan154
ip address 10.252.154.60 255.255.255.0
shutdown
!
interface Vlan200
ip address 10.252.200.1 255.255.255.0
ip helper-address 10.252.54.55
!
interface Vlan2105
no ip address
!
ip default-gateway 10.252.54.1
ip classless
ip http server

5 REPLIES 5
Highlighted
VIP Expert

where is your DHCP Server, if the DHCP Server not on this device, it is ouside of this device, the device should know how to reach that IP address.

 

 

Also you need to allow rest of the VLAN required if this is uplink port as below :

 

nterface FastEthernet0/13
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk

 

what kind of DHCP Server is this ? you need to setup a Options for the Voice VLAN

example :

https://blog.router-switch.com/2013/03/dhcp-option-150-dhcp-option-66/



BB


*** Rate All Helpful Responses ***

Highlighted

OFFICIAL

I have a windows 2008 Server where I have created a scope for native under 10.252.100.0/24 for a block of 10 addresses and I have done the same for voice under 10.252.200.0/24 again for a block of 10 addresses. Appreciate I can push VLAN from CDP and LLDP, however for this particular requirement VLAN is pushed via a variable in the phone configuration file.
Highlighted

need more information "however for this particular requirement VLAN is pushed via a variable in the phone configuration file."  ( example of the config).

 

what Phones, who is the vendor ? does this worked from vendor any where else ?



BB


*** Rate All Helpful Responses ***

Highlighted

Default gateway IP 10.252.54.1 is one of switch own  interface Vlan 54 IP.

 

Default gateway is the next-hop for a packet arriving on the switch.

 

I would recommend to change it and then test again.

Highlighted
VIP Expert

Hello,

 

--> and I have done the same for voice under 10.252.200.0/24 again for a block of 10 addresses.

 

So Vlan 200 is your voice Vlan ? Which port is the phone connected to ? I might be missing something, but if your phone is directly connected to the switch (and not behind a computer), have you tried to simply assign the port as an access port in Vlan 200 ?

Content for Community-Ad