cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2376
Views
75
Helpful
37
Replies

eigrp one of subnet not updated

Arie
Level 1
Level 1

Can anyone explains me why R2 is not getting information from R1 about his inner subnet: 172.16.1.0?

R1 has in eigrp network classfull subnet added: 172.16.0.0 so 172.16.1.0 should be attached and R2 should receive it inside his routing table.

Funny thing is R2 has similar situation (also network 172.16.0.0 added) and R1 can see R2's 172.16.2.0 

Topology:

Heres my configs:

R1

R1#sh run
Building configuration...

Current configuration : 717 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "R1"
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
ip address 192.168.10.5 255.255.255.252
half-duplex
no cdp enable
!
interface FastEthernet0
ip address 172.16.1.1 255.255.255.0
speed auto
no cdp enable
!
interface Serial0
ip address 172.16.3.1 255.255.255.252
clockrate 64000
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
no cdp enable
!
router eigrp 1
network 172.16.0.0
network 192.168.10.4 0.0.0.3
no auto-summary
!
ip classless
no ip http server
!
!
no cdp run
!
line con 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end

R1#

R2


R2#sh run
Building configuration...

Current configuration : 759 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 172.16.3.2 255.255.255.252
!
interface Serial0/1/1
ip address 192.168.10.9 255.255.255.252
clock rate 64000
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

1 Accepted Solution

Accepted Solutions

Great, 

The interface Fa0 should have communication with the other end, so try to connect a computer to the port FastEthernet 0 using a crossover cable. Test the connectivity with a ping from the PC to the ip 172.16.1.1

And assign to the computer the IP 172.16.1.2 255.255.255.0

Also please remove the loopback created previously. 

In a real environment if there is nothing connected to the port, the subnet will not be advertised by the routing protocol. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

37 Replies 37

Hi,

The serial interface on R2 is not on the same segment that the serial interface in R1.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

@Julio: they are both in same subnet. Or i dont get it.

R1  routing table: (all subnets correctly added)

R1#show ip route

192.168.10.0/30 is subnetted, 1 subnets
C 192.168.10.4 is directly connected, Ethernet0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.1.0/24 is directly connected, FastEthernet0
D 172.16.2.0/24 [90/2172416] via 172.16.3.2, 00:33:10, Serial0
C 172.16.3.0/30 is directly connected, Serial0

R2  routing table:

192.168.10.0/30 is subnetted, 2 subnets
D 192.168.10.4 [90/2195456] via 172.16.3.1, 00:41:40, Serial0/1/0
C 192.168.10.8 is directly connected, Serial0/1/1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/30 is directly connected, Serial0/1/0

Hi Arie

R1

interface Serial0
ip address 172.16.3.1 255.255.255.252
clockrate 64000
no fair-queue
no cdp enable

R2

interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3/1
ip address 192.168.10.10 255.255.255.252

If one of these interface is connected to R1, it should be on the same subnet that R1 or vice versa R1 should be on the same subnet of R2. And this subnet must be advertised under the EIGRP process. 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

SORRY ! I provided config from R3 (other router) as R2 - now i placed correct config for R2 can you check again?

No worries,

The R2's routing table is receiving the subnet 192.168.10.4. It looks be fine.

Try to execute these lines on R2

show ip route 192.168.10.5 and  show ip route 172.16.1.1




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

R2#show ip route 192.168.10.5
Routing entry for 192.168.10.4/30
Known via "eigrp 1", distance 90, metric 2195456, type internal
Redistributing via eigrp 1
Last update from 172.16.3.1 on Serial0/1/0, 00:51:00 ago
Routing Descriptor Blocks:
* 172.16.3.1, from 172.16.3.1, 00:51:00 ago, via Serial0/1/0
Route metric is 2195456, traffic share count is 1
Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 241/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

R2#show ip route 172.16.1.1
% Subnet not in table
R2#

Could you please execute this command on R1, i would like to see if the interface FastEthernet 0 is up otherwise R1 will not advertise it.

show ip interface brief. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

it's up, i also checked before.

R1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0 172.16.1.1 YES NVRAM up up
Ethernet0 192.168.10.5 YES NVRAM up up
Serial0 172.16.3.1 YES NVRAM up up
Serial1 unassigned YES NVRAM administratively down down

Just for testing purpose, configure keepalive command line under the interface FastEthernet 0  and check again the routing table on R2

Are you able to ping the 172.16.1.1 from the PC?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

If that does not work, we are going to remove the IP 172.16.1.1 under the FastEthernet0 and create a loopback on R1

example:

interface loopback 100
ip add 172.16.1.1 255.255.255.0

In order to discard any bug or problem between the PC and the FastEther0




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

i don't know this what is the full command Julio?

dont have the pc there, lets first try keepalive and the i create loopback (whats full command for keepalive)?

just keepalive.

interface FastEthernet 0
keepalive




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Keepalive command is used to send keepalive packets to the next router or device altough we dont have response from that. So the interface will look up any time. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

no change after keepalive, trying with loopback...

Review Cisco Networking for a $25 gift card